You are not logged in.

#26 2014-11-22 14:00:37

davidm
Member
Registered: 2009-04-25
Posts: 339

Re: Can't boot from btrfs RAID1[SOLVED]

Added section about it under the troubleshooting section to the btrfs arch wiki entry.

https://wiki.archlinux.org/index.php/Bt … ree_failed

Please correct any formatting or other errors.  I'm a relatively new wiki editor.

Offline

#27 2014-11-22 14:32:34

lahwaacz
Wiki Admin
From: Czech Republic
Registered: 2012-05-29
Posts: 580

Re: Can't boot from btrfs RAID1[SOLVED]

The wiki is not a bug tracker. Please don't only work around the consequence, but primarily fix the cause.

Has anyone created a bug report? How can you expect an announcement/warning when there is not even a bug report?

Offline

#28 2014-11-22 16:57:39

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 15,183

Re: Can't boot from btrfs RAID1[SOLVED]

I cannot make this an official announcement, but I will consider making a 'sticky' for now.  Before I do that, do the workarounds do the trick.  Perhaps if someone could put together a few bullet points to get this to work.  If you are all still at a dead end, then perhaps someone could put together a brief statement as to what is wrong and what needs to be done to get off top dead center.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
----
How to Ask Questions the Smart Way

Offline

#29 2014-11-22 17:45:10

davidm
Member
Registered: 2009-04-25
Posts: 339

Re: Can't boot from btrfs RAID1[SOLVED]

lahwaacz, Sorry I just figured since it was over a week something should probably go up there because it's a pretty nasty error which causes a totally unbootable system.  In addition many people might see the error and try various "repairs" to their btrfs filesystem thinking it is faulty and in many cases that can cause other damage.  Feel free to remove it if you feel that is most appropriate.  I searched a few times on the Arch bug tracker and did not see a report.  I don't think one exists.  I don't know about upstream. 

ewaller, the solution described here worked well for me:
https://bbs.archlinux.org/viewtopic.php … 4#p1475754

1. Boot with the arch install disc/iso.
2. mount the filesystem, chroot or arch-chroot to the install
3. edit /etc/mkinitcpio.conf
4. remove 'btrfs' from the HOOKS section and add it to the MODULES section instead.
5. regenerate the image with 'mkinitcpio -p linux'
6. unmount and reboot.

Last edited by davidm (2014-11-22 17:51:12)

Offline

#30 2014-11-22 19:01:02

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 15,183

Re: Can't boot from btrfs RAID1[SOLVED]

I will 'sticky' this topic for a while


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
----
How to Ask Questions the Smart Way

Offline

#31 2014-11-23 15:14:32

rpodgorny
Member
Registered: 2014-11-19
Posts: 7

Re: Can't boot from btrfs RAID1[SOLVED]

...so, i've created a bug report: https://bugs.archlinux.org/task/42884

Offline

#32 2014-11-23 16:26:30

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 6,263

Re: Can't boot from btrfs RAID1[SOLVED]

You know, it's a bit ridiculous that people are complaining that it's been a week, it took them forever to debug, calling for an announcement, etc; and yet nobody bothered to file a bug report until just now. How did you expect anything to happen without letting anyone know?

Offline

#33 2014-11-23 19:38:41

rpodgorny
Member
Registered: 2014-11-19
Posts: 7

Re: Can't boot from btrfs RAID1[SOLVED]

well, some people probably assumed people with "forum moderator" or "wiki admin" by their nicks are also arch devs somehow. at least i did. ;-) ...silly, i know. ...anyway, the bug is there for you to tinker with. i suspect the devs would appreciate some help so be sure to head over there!

Offline

#34 2014-11-23 20:19:31

davidm
Member
Registered: 2009-04-25
Posts: 339

Re: Can't boot from btrfs RAID1[SOLVED]

Scimmia wrote:

You know, it's a bit ridiculous that people are complaining that it's been a week, it took them forever to debug, calling for an announcement, etc; and yet nobody bothered to file a bug report until just now. How did you expect anything to happen without letting anyone know?

I think people sometimes can be intimidated by the process for participating in various things.  It could be a lack of familiarity, experience, time, or perhaps they are just afraid that if they make a mistake somewhere someone is going to jump all over them for it.  In the latter case the more users see this happen to others I think the less participation there will be in this kind of thing. 

I know at first I only made a forum post because:

1. I've never filed a bug report on the Arch bug tracker before.
2. I didn't feel familiar with the technical details as others seemed to be.
3. Frankly I didn't want to make a mistake.

I made a troubleshooting entry on the Arch Wiki also after the problem continued but you see how that worked out. wink  For me that was quite a step though and took about 20-30 minutes to do in order to attempt to get the formatting correct not being familiar with it.  It was only the second edit I've ever made on the Arch wiki.

Not everyone is going to be able to do as much as others for various reasons but I would think something is usually better than nothing.  i.e. a forum post is better than no forum post at all, a poor bug report is better than no bug report, etc. I don't think anyone is being malicious in trying to contribute.  I know I certainly am not.

Last edited by davidm (2014-11-23 20:25:07)

Offline

Board footer

Powered by FluxBB