You are not logged in.

#1 2014-09-08 16:15:34

edudobay
Member
Registered: 2013-09-28
Posts: 2

Characters missing in GTK apps

In the past few weeks the following happened a few times:

I booted up the system, logged in to the desktop (MATE with Compiz). Everything was normal. After some time random characters were missing from most applications, both those that were already running and newly-launched ones. Screenshot: http://i.imgur.com/CQ1tKDM.png

* Google Chrome and Qt applications seem to be unaffected, so the problem seems to be constrained to GTK apps.
* After changing the current fonts (e.g. the terminal font or the GTK theme font) the problem disappears in all places the old font was displayed, but when switching back to the old font the problem persists.
* My antialias settings (in the MATE Control Panel's Appearance settings) were: Grayscale / No hinting / RGB. When switching from Grayscale to Subpixel (LCD), the problem disappeared (for good, apparently)!

I couldn't find any information about this (I did find some reports pointing to video driver issues, but that would require restarting X and then my problem would not show up again for a while), so I'd like to know if I should file a bug report or something like that (and, if so, where should I file it). Thanks! smile

Offline

#2 2014-10-12 08:38:02

rohansftw
Member
Registered: 2011-12-09
Posts: 8

Re: Characters missing in GTK apps

Face the same, Dont know what causes it . But it went away after a upgrade and again back when i upgraded my laptop again . Its pretty annoying sad .

Offline

#3 2014-10-12 12:10:33

ooo
Member
Registered: 2013-04-10
Posts: 1,608

Re: Characters missing in GTK apps

You didn't mention which video drivers you're using, but if you have either ati or nvidia video card you should try if the issue persists with both proprietary and open source drivers.
If this only happens with open source drivers, try changing your 2d acceleration method (e.g. with intel, try 'uxa' and 'glamor' AccelMethod).
Also does this happens with both gtk2 and gtk3 applications?

In any case, if this really only happens with gtk+ applications I'd report the bug to gtk developers at bugzilla.gnome.org.
Try to pin-point the cause as well as you can, i.e. if this only happens with cerntain video drivers, accel method, font rendering settings and/or only after certain gtk version etc.

Offline

#4 2014-10-12 12:29:48

bstaletic
Member
Registered: 2014-02-02
Posts: 658

Re: Characters missing in GTK apps

Weird problem. I have only gtk2 applications installed (along with some application not using any toolkit) and never have seen this problem. I'm using i3wm wih ATI open source drivers. So the problem shouldn't be in gtk or open source drivers (can't speak for nVidia or Intel cards).

Offline

#5 2014-12-09 08:57:07

Avathar
Member
Registered: 2014-05-04
Posts: 3

Re: Characters missing in GTK apps

I'm facing a similar problem with Kubuntu. I think it is related to libglib2 according to this bug report: https://bugs.debian.org/cgi-bin/bugrepo … bug=760435

Offline

#6 2015-05-17 22:31:26

hadi1337
Member
Registered: 2015-05-17
Posts: 1

Re: Characters missing in GTK apps

Sorry for digging up an old thread but has anyone found a solution to this problem? I'm still getting it. It tends to disappear after an upgrade and reappear a couple of upgrades later. I'm using the intel drivers and running gnome 3. Changing the font scaling from 1.0 to 0.99 (or any other number for that matter) seems to have fixed it for now.

Offline

#7 2015-05-18 07:58:14

Chazza
Wiki Maintainer
From: United Kingdom
Registered: 2013-06-02
Posts: 506

Re: Characters missing in GTK apps

I had a similar issue (also Intel graphics). I found that switching to the UXA backend fixed the problem: https://wiki.archlinux.org/index.php/In … SNA_issues

Offline

Board footer

Powered by FluxBB