You are not logged in.

#1 2014-12-06 20:56:00

davermont
Member
Registered: 2014-09-07
Posts: 21

Touchscreen stops responding after resume from sleep in Gnome 3.

I just installed Gnome on my Dell Inspiron 15" 7537 and the touchscreen works fine until I close the lid. When the laptop resumes from sleep the touchscreen doesn't respond any more. I previously had KDE4 on this machine, and while the touch support was less functional I never noticed this problem previously, which makes me think it may have something to do with Gnome. The Gnome installation is a fresh install though; I didn't just uninstall KDE and install Gnome. Any ideas?

Thanks,
D

Last edited by davermont (2014-12-06 21:23:06)

Offline

#2 2014-12-08 03:57:24

brittyazel
Member
From: Davis, CA
Registered: 2013-05-11
Posts: 158

Re: Touchscreen stops responding after resume from sleep in Gnome 3.

I also have this issue, also running Gnome3. I did just install it yesterday though, for which I 'thought' was working well until this morning.


I don't really know what I'm doing.

Offline

#3 2014-12-16 13:33:09

MaTachi
Member
From: Göteborg, Sweden
Registered: 2011-06-07
Posts: 52
Website

Re: Touchscreen stops responding after resume from sleep in Gnome 3.

I also bought a Dell Inspiron 15 7537 and I had the same problem as OP, but on Fedora 21 64-bit with Gnome 3.14. I haven't tried any other distros or DEs. However, both Arch and Fedora run systemd, so I think my solution work the same on both systems. I fixed it by doing the following steps:

1. Create a script that reloads the kernel module hid_multitouch.

$ sudo mkdir /opt/touchscreen-fix
$ cd /opt/touchscreen-fix
$ echo '#!/bin/sh
/sbin/rmmod hid_multitouch && /sbin/modprobe hid_multitouch' | sudo tee resume.sh
$ sudo chmod +x resume.sh

Executing this script after a resume will make the touchscreen work again. However, it will of course not run automatically after a resume.

2. Schedule the script to run after resume.

Create the systemd service file:

$ echo '[Unit]
Description=Fix touchscreen after resume
After=suspend.target

[Service]
Type=simple
ExecStart=/opt/touchscreen-fix/resume.sh

[Install]
WantedBy=suspend.target' | sudo tee /etc/systemd/system/touchscreen-fix.service

Enable it:

$ sudo systemctl daemon-reload
$ sudo systemctl enable touchscreen-fix

Done! And that's all! I'm not sure if you also might need to restart the computer for it to work.

To accomplish this I used the following resources:
https://wiki.archlinux.org/index.php/Po … leep_hooks
http://unix.stackexchange.com/questions … -at-resume
https://bugs.launchpad.net/ubuntu/+sour … omments/28

Last edited by MaTachi (2014-12-16 13:35:21)


 (\_/)
(o.o)
(___)0

Offline

#4 2015-01-06 07:23:38

rishychacko
Member
Registered: 2015-01-03
Posts: 7

Re: Touchscreen stops responding after resume from sleep in Gnome 3.

Hello, has this been confirmed by anyone else? I attempted to do the same, succeeded in creating the necessary scripts, restarted my machine and found that the scripts did not prevent my machine's touch screen from becoming inactive. I don't know if new updates rendered the fix invalid or if this is user error on my part. Thanks for the help guys!

Offline

#5 2015-01-06 12:18:40

MaTachi
Member
From: Göteborg, Sweden
Registered: 2011-06-07
Posts: 52
Website

Re: Touchscreen stops responding after resume from sleep in Gnome 3.

rishychacko wrote:

Hello, has this been confirmed by anyone else? I attempted to do the same, succeeded in creating the necessary scripts, restarted my machine and found that the scripts did not prevent my machine's touch screen from becoming inactive. I don't know if new updates rendered the fix invalid or if this is user error on my part. Thanks for the help guys!

See if reloading the kernel module hid_multitouch does the job or not. That would make it easier to narrow down the problem.


 (\_/)
(o.o)
(___)0

Offline

#6 2015-01-06 23:07:27

rishychacko
Member
Registered: 2015-01-03
Posts: 7

Re: Touchscreen stops responding after resume from sleep in Gnome 3.

I'm actually not having luck reloading the module. What worked for me was using xinput enable "My touchscreen name" but I don't quite know why replacing the commands you provided with xinput enable doesn't do the trick.

Offline

#7 2015-01-17 05:58:37

rishychacko
Member
Registered: 2015-01-03
Posts: 7

Re: Touchscreen stops responding after resume from sleep in Gnome 3.

To write a script, you could then do something of the like xinput enable "ELAN Touchscreen" Then follow the advice given up above but remember to set the display prior to using xinput for desired results.

Offline

#8 2015-02-18 11:43:34

BillyIII
Member
Registered: 2015-02-18
Posts: 1

Re: Touchscreen stops responding after resume from sleep in Gnome 3.

Works on Yoga 13. Thanks!

Offline

#9 2015-04-10 04:13:24

quantheory
Member
Registered: 2012-02-07
Posts: 6

Re: Touchscreen stops responding after resume from sleep in Gnome 3.

If using "xinput enable" works for you and you are using GNOME 3.14, it may be a bug in gnome-settings-daemon 3.14.2. Either upgrading or downgrading should fix the problem, as that is the only release that seems to have the problem.

See here:

https://bugzilla.gnome.org/show_bug.cgi?id=743252

Offline

#10 2016-04-06 00:18:48

roffe
Member
From: 127.0.0.1
Registered: 2016-04-03
Posts: 11

Re: Touchscreen stops responding after resume from sleep in Gnome 3.

Thank you MaTachi

This helped me resolve same problem on Dell XPS 13 9350 QHD. After doing your solution touchscreen now works after resume with Kernel 4.6-RC2 smile

Last edited by roffe (2016-04-06 00:19:07)


Fedora 23, Kernel 4.6-RC3 list of modifications
Dell XPS 13 9350 - 8 GB - 256GB NVMe - QHD - Skylake

Offline

#11 2016-08-23 13:24:33

cejota
Member
Registered: 2016-08-23
Posts: 1

Re: Touchscreen stops responding after resume from sleep in Gnome 3.

I just wanted to note that neither of these solutions (reloading hid_multitouch and using xinput enable) work on my Dell XPS 13 9350 QHD. I'm running kernel 4.7.1-1 and GNOME 3.20.4.

Offline

#12 2016-11-11 01:00:21

anthony.naddeo
Member
Registered: 2016-11-11
Posts: 1

Re: Touchscreen stops responding after resume from sleep in Gnome 3.

This is now fixed in the kernel. I reached out to the developer who fixed it and he was able to help me make a more reasonable workaround while we wait for that code to be released.

https://gist.github.com/naddeoa/16d0792 … dc67f0ad32

Last edited by anthony.naddeo (2016-11-11 01:02:30)

Offline

Board footer

Powered by FluxBB