You are not logged in.

#1 2004-02-12 14:25:31

vande198
Member
From: East Lansing, MI, USA
Registered: 2003-09-12
Posts: 98

Ethernet module b44 won't load on 2.6

I've got the following listing on my 2.6.2 kernel modprobe.conf

alias eth0 b44

but my ethernet interface doesn't come up.

I've gone to
/lib/modules/2.6.2/kernel/drivers/net

where b44.ko is and typed

insmod b44.ko

But then I get this error:

b44.ko: couldn't find the kernel version the module was compiled for

What am I doing wrong?


"To be a Spartan is to be a philosopher much more than to be an athlete."
Plato, the <i>Protagoras</i>, 342e-343a

Offline

#2 2004-02-12 14:28:17

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,863

Re: Ethernet module b44 won't load on 2.6

Hi

Have you got b44 in MODULES in rc.conf......?

Or you could do modprobe b44 what does that give?


Mr Green

Offline

#3 2004-02-12 14:38:28

vande198
Member
From: East Lansing, MI, USA
Registered: 2003-09-12
Posts: 98

Re: Ethernet module b44 won't load on 2.6

I just put b44 in rc.conf's "modules" and rebooted.

eth0 didn't load up, and I got this error when I went "modprobe b44":

modprobe: Can't locate module b44

"To be a Spartan is to be a philosopher much more than to be an athlete."
Plato, the <i>Protagoras</i>, 342e-343a

Offline

#4 2004-02-12 14:39:41

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,863

Re: Ethernet module b44 won't load on 2.6

Do uname -a


Mr Green

Offline

#5 2004-02-12 15:19:18

vande198
Member
From: East Lansing, MI, USA
Registered: 2003-09-12
Posts: 98

Re: Ethernet module b44 won't load on 2.6

uname -a:

Linux vande198 2.4.24 #1 SMP Thu Feb 12 06:39:40 UTC 2004 i686 unknown unknown GNU/Linux

ok...so it's identified as the wrong kernel....how can I fix this?

edit:  oops, I double-checked my grub config, and I found that I was booting into my 2.4 kernel...sorry.

I still have the same problem, though.  Here's what happens when I put in modprobe b44:

FATAL:  module b44 already in kernel

"To be a Spartan is to be a philosopher much more than to be an athlete."
Plato, the <i>Protagoras</i>, 342e-343a

Offline

#6 2004-02-12 15:31:23

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,863

Re: Ethernet module b44 won't load on 2.6

Emmmm...let me think....did you configure lilo for new kernel?


Mr Green

Offline

#7 2004-02-12 15:33:03

vande198
Member
From: East Lansing, MI, USA
Registered: 2003-09-12
Posts: 98

Re: Ethernet module b44 won't load on 2.6

sorry about that, see my previous post.


"To be a Spartan is to be a philosopher much more than to be an athlete."
Plato, the <i>Protagoras</i>, 342e-343a

Offline

#8 2004-02-12 15:35:21

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,863

Re: Ethernet module b44 won't load on 2.6

right what does lsmod give you


That error tells you module is loaded  big_smile

I tried it myself....& I use r8169  lol


Mr Green

Offline

#9 2004-02-12 15:43:38

vande198
Member
From: East Lansing, MI, USA
Registered: 2003-09-12
Posts: 98

Re: Ethernet module b44 won't load on 2.6

b44 shows up on the lsmod list, but I still can't ping anything.


"To be a Spartan is to be a philosopher much more than to be an athlete."
Plato, the <i>Protagoras</i>, 342e-343a

Offline

#10 2004-02-12 16:10:00

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,863

Re: Ethernet module b44 won't load on 2.6

Hi post your rc.conf


Mr Green

Offline

#11 2004-02-12 16:15:16

vande198
Member
From: East Lansing, MI, USA
Registered: 2003-09-12
Posts: 98

Re: Ethernet module b44 won't load on 2.6

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

#
# Localization
#
# HARDWARECLOCK: set to "UTC" or "localtime"
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: fount in /usr/share/kbd/consolefonts (only needed for non-us)
# USECOLOR: use ANSI color sequences in startup messages
#
HARDWARECLOCK="UTC"
TIMEZONE=America/Detriot
KEYMAP=us
CONSOLEFONT=
USECOLOR="yes"

#
# Networking
#
HOSTNAME="vande198"

#
# Module to load at boot-up (in this order)
#   (prefix a module with a ! to disable it)
#
MODULES=(usbserial b44 ide-scsi sr_mod sd_mod sg)

#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   (prefix an interface in INTERFACES with a ! to disable it)
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
eth0="dhcp"
INTERFACES=(lo eth0)

#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   (prefix a route in ROUTES with a ! to disable it)
#
gateway="35.8.2.3"
ROUTES=(gateway)

#
# Daemons to start at boot-up (in this order)
#   (prefix a daemon with a ! to disable it)
#
DAEMONS=(syslogd klogd network crond sshd portmap fam)

# End of file

"To be a Spartan is to be a philosopher much more than to be an athlete."
Plato, the <i>Protagoras</i>, 342e-343a

Offline

#12 2004-02-12 16:19:47

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,863

Re: Ethernet module b44 won't load on 2.6

No looks O.k. ......did it work in 2.4


Mr Green

Offline

#13 2004-02-12 16:24:58

vande198
Member
From: East Lansing, MI, USA
Registered: 2003-09-12
Posts: 98

Re: Ethernet module b44 won't load on 2.6

actually, I've always had problems with the modules for this ethernet card.  Even when I got it to work I'd always get this message when the "network" daemon started up:

SIOCADDRT: No such device

Under 2.4 I've been running a driver from the vendor, which is supposed to only work with 2.2 and 2.4 kernels.  It still gives the above error message.  I guess I could try to install it under 2.6, but I really wanted to use the module that came with the kernel.  (peace of mind, I guess).


"To be a Spartan is to be a philosopher much more than to be an athlete."
Plato, the <i>Protagoras</i>, 342e-343a

Offline

#14 2004-02-12 16:27:46

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,863

Re: Ethernet module b44 won't load on 2.6

do a google on your card


www.google.com/linux

see if anyone else has the problems

I assume you are talking about a pci card ......


Good luck & don't give up  lol

Mr Green


Mr Green

Offline

#15 2004-02-12 17:29:11

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Ethernet module b44 won't load on 2.6

vande198 wrote:
gateway="35.8.2.3"
ROUTES=(gateway)

You don't need to set your gateway if you're using dhcp.  Put a ! in front of the gateway entry in ROUTES and try that.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#16 2004-02-12 19:05:35

vande198
Member
From: East Lansing, MI, USA
Registered: 2003-09-12
Posts: 98

Re: Ethernet module b44 won't load on 2.6

thanks, but no change. :-/


"To be a Spartan is to be a philosopher much more than to be an athlete."
Plato, the <i>Protagoras</i>, 342e-343a

Offline

#17 2004-02-12 21:06:29

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,863

Re: Ethernet module b44 won't load on 2.6

Are you running a modem or router......

silly question is it set up in bios ?

Mr Green


Mr Green

Offline

#18 2004-02-15 21:53:23

Guest
Guest

Re: Ethernet module b44 won't load on 2.6

I'm running on an lan with dhcp through my school, and I'm pretty sure that it's all configured in bios because I'm using the card with the vendor's driver under my 2.4 kernel, and no problems there.

basically, it looks like the b44 module is just buggy as hell, so I'll either have to wait for (1) the b44 in the kernel to get fixed or (2) wait for Broadcom to release its own driver for the 2.6 kernel (presently, the only supply a driver that works with 2.4).

Thanks for your persistent assistance.

#19 2004-02-15 22:03:27

vande198
Member
From: East Lansing, MI, USA
Registered: 2003-09-12
Posts: 98

Re: Ethernet module b44 won't load on 2.6

p.s. that was just me.


"To be a Spartan is to be a philosopher much more than to be an athlete."
Plato, the <i>Protagoras</i>, 342e-343a

Offline

#20 2004-02-16 02:37:28

The Analog Kid
Member
From: Pennsylvania, USA
Registered: 2004-01-05
Posts: 27

Re: Ethernet module b44 won't load on 2.6

I have a Broadcom 4401 onboard ethernet on one of my machines, and it runs Arch, and it works fine. I've only had one or two problems with Linux and that was with 2.4.22, it would drop it's connection but then when 2.4.23 came out it was since they pulled the updates to the driver from the 2.6 branch.

You might want to try Broadcom's own driver, despite what you say their driver works on both 2.4 and 2.6. I know, I've used it on 2.6. The module would then be called bcm4400.

BTW, did you roll your own kernel? If you didn't, then do it.

Offline

Board footer

Powered by FluxBB