You are not logged in.

#1 2014-12-28 14:03:40

satori
Member
Registered: 2013-01-21
Posts: 29

[SOLVED] How to get rid of systemd "starting version 217" message?

Hello,

I'm trying to achieve quiet login and messages like "starting version 217" or 218 appeared recently.
I was able to track it down to systemd but I cannot find how to disable it.

Any hints?

Last edited by satori (2014-12-29 18:36:11)

Offline

#2 2014-12-28 14:06:44

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,386
Website

Re: [SOLVED] How to get rid of systemd "starting version 217" message?

Rebuild your initramfs:

# mkinitcpio -p linux

See this thread:
https://bbs.archlinux.org/viewtopic.php?id=191243

Sorry, you mean get rid of the message entirely don't you?

I'm typing without thinking again...

I don't know how to get rid of it, sorry.

Last edited by Head_on_a_Stick (2014-12-28 14:09:24)

Offline

#3 2014-12-28 18:46:54

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [SOLVED] How to get rid of systemd "starting version 217" message?

Are you using 'quiet' and 'show_status=0' in your kernel commandline?

Offline

#4 2014-12-28 22:08:41

jakschu
Member
Registered: 2014-08-18
Posts: 2

Re: [SOLVED] How to get rid of systemd "starting version 217" message?

add rd.udev.log-priority=3 to your kernel command line.
See: systemd-udevd.service.html

Btw. my refind_linux.conf:

"Boot with standard options" "rw root=UUID=49784a9c-9029-4f3d-936a-5dce55d5d7fe vga=current quiet loglevel=3 rd.udev.log-priority=3 splash initrd=\initramfs-linux.img"

Offline

#5 2014-12-29 18:35:36

satori
Member
Registered: 2013-01-21
Posts: 29

Re: [SOLVED] How to get rid of systemd "starting version 217" message?

Thank you for your answers!

@Head_on_a_Stick:
Yes, I wanted to completely remove the message.

@karol:
I was using 'quiet' and 'loglevel=0'. Adding 'show_status=0' (or replacing 'loglevel=0' with it) did not help.

@jakschu:
Adding 'rd.udev.log-priority=3' solved the problem, the message is not visible anymore during boot. Many thanks!

Marking post as solved.

Offline

#6 2015-05-02 13:51:45

Smod
Member
From: Belgium
Registered: 2011-09-25
Posts: 9

Re: [SOLVED] How to get rid of systemd "starting version 217" message?

Hi,

Since this topic appeared on top in my google search, I'm posting here another way that doesn't require to edit your kernel boot parameters (which imho should only be done in exceptional situations).

Just edit your /etc/udev/udev.conf file

# see udev.conf(5) for details

udev_log=3

Then, rebuild your initramfs

mkinitcpio -p linux

You're done.

Offline

Board footer

Powered by FluxBB