You are not logged in.

#1 2014-12-29 03:24:19

antsunrise
Member
Registered: 2014-12-19
Posts: 26

Pacmanpackage query yaourt issue going on for me.

neckbeards% install yaourt
resolving dependencies...
warning: cannot resolve "pacman<4.2", a dependency of "package-query"
warning: cannot resolve "package-query>=1.4", a dependency of "yaourt"
:: The following package cannot be upgraded due to unresolvable dependencies:
      yaourt

:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<4.2
:: yaourt: requires package-query>=1.4

Not sure on the fix for this. I had this issue with testing. But I disabled testing and now have this. I did notice a recent pacman update. Sorry if a repost. Still no answer found for me. thanks

Offline

#2 2014-12-29 03:30:12

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 24,203
Website

Re: Pacmanpackage query yaourt issue going on for me.

antsunrise wrote:

... I disabled testing ...

Clearly you haven't done this properly.  Pacman 4.2 is still in testing.
Oops.  I see it was *just* moved to core.

EDIT: What is this "install" command?  I figured this was a wrapper to makepkg.  But that's clearly not using the PKGBUILDs currently in the AUR.  This issue existed while pacman 4.2 was in testing, but the PKGBUILDs have been updated.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#3 2014-12-29 03:38:35

antsunrise
Member
Registered: 2014-12-19
Posts: 26

Re: Pacmanpackage query yaourt issue going on for me.

That's just my alias for sudo pacman -S

Offline

#4 2014-12-29 03:40:20

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 24,203
Website

Re: Pacmanpackage query yaourt issue going on for me.

Pacman can't install packages from the AUR.  If you are using that unofficial repo that tries to break archlinux systems, feel free to report the bug to them.  Or just stop using it.  Also please be sure to mention when you are using unoffical repos.

The fix is simple though: install these properly from the AUR.

EDIT: Antsunrise - I'm sorry for my tone in this thread, it is not really what it should be.  I have issues with the archlinux.fr repo, but this should not be directed at new members to these forums.  So please accept my appologies for the tone.  But the message is the same: my recommendation would be to remove that repo and actually learn about how to use the AUR effectively.  The AUR wiki page can help.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#5 2014-12-29 03:46:02

antsunrise
Member
Registered: 2014-12-19
Posts: 26

Re: Pacmanpackage query yaourt issue going on for me.

Hmm alright. I'll just lurk other threads with the same issue. thanks.

okay understood. no problems. I'll look into it in the morning about to get some sleep for now. thanks for info. I've only been using arch for a few months. so i'm not the best with it yet

Last edited by antsunrise (2014-12-29 04:10:21)

Offline

#6 2014-12-29 04:40:01

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: Pacmanpackage query yaourt issue going on for me.

I'd like to point out that

$ which install
/usr/bin/install

so don't forget 'install' is an alias on your computer.


Apart from what Trilby wrote, there are other AUR helpers besides yaourt, you might want to "shop around".

Offline

#7 2014-12-29 07:50:50

phanisvara
Member
From: west bengal, india
Registered: 2012-07-08
Posts: 74

Re: Pacmanpackage query yaourt issue going on for me.

last time i tried, a couple of weeks ago, yaourt itself wouldn't build with the current pacman version. yaourt-git and packagequery-git worked fine though. properly installed from their AUR packages, of course.

Offline

#8 2014-12-29 08:08:35

fladi
Member
Registered: 2014-10-30
Posts: 19

Re: Pacmanpackage query yaourt issue going on for me.

antsunrise wrote:
neckbeards% install yaourt
resolving dependencies...
warning: cannot resolve "pacman<4.2", a dependency of "package-query"
warning: cannot resolve "package-query>=1.4", a dependency of "yaourt"
:: The following package cannot be upgraded due to unresolvable dependencies:
      yaourt

:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<4.2
:: yaourt: requires package-query>=1.4

Not sure on the fix for this. I had this issue with testing. But I disabled testing and now have this. I did notice a recent pacman update. Sorry if a repost. Still no answer found for me. thanks

I "solved" this by
pacman -R yaourt package-query
pacman -Syyu
pacman-db-upgrade

"solved" under quotes because now pacman works but yaourt is gone. I will try packer instead today, hopefully this works better.

Offline

#9 2014-12-29 08:49:43

genEric
Member
From: Sweden
Registered: 2013-09-26
Posts: 38

Re: Pacmanpackage query yaourt issue going on for me.

package-query-1.5.2 is out now (this morning). All good now. smile


[genEric@…] ~$

Offline

#10 2014-12-29 09:05:17

speedyx
Member
From: Italy
Registered: 2008-09-05
Posts: 68
Website

Re: Pacmanpackage query yaourt issue going on for me.

Yes, after update package-query all works well.


The Freedom Technologies Are Available... And Work!
Twitter: @speedytux

Philipe Müller, Manjaro: "Always remember how you started with Linux and what your beginner questions were!"

Offline

#11 2014-12-29 14:22:58

antsunrise
Member
Registered: 2014-12-19
Posts: 26

Re: Pacmanpackage query yaourt issue going on for me.

Hey guys. Just woke up. Problem solved on update. I guess the repo children fixed it all. thanks for help and replies.

Offline

#12 2014-12-29 15:21:03

xero
Member
From: ~/
Registered: 2014-04-02
Posts: 86
Website

Re: Pacmanpackage query yaourt issue going on for me.

fladi wrote:

pacman -R yaourt package-query
pacman -Syyu
pacman-db-upgrade
> then manually reinstall yaourt

thanx. this fixed the issue for me as well.


▬▬ι═══════ﺤ
http://git.io/.files

Offline

#13 2014-12-29 16:13:11

fcn
Member
Registered: 2014-12-29
Posts: 1

Re: Pacmanpackage query yaourt issue going on for me.

xero wrote:
fladi wrote:

pacman -R yaourt package-query
pacman -Syyu
pacman-db-upgrade
> then manually reinstall yaourt

thanx. this fixed the issue for me as well.

There is no need for that. Now that package-query is updated, all you need to do is update (reinstall) it via yaourt:

yaourt -S package-query

After doing that pacman -Syyu will work fine.

Offline

#14 2014-12-29 16:40:10

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,865

Re: Pacmanpackage query yaourt issue going on for me.

But then you still have to rebuild package-query manually after the update.

Offline

#15 2014-12-29 17:29:11

fsckd
Forum Fellow
Registered: 2009-06-15
Posts: 4,173

Re: Pacmanpackage query yaourt issue going on for me.

antsunrise wrote:

Hey guys. Just woke up. Problem solved on update. I guess the repo children fixed it all. thanks for help and replies.

Congrats. smile Please mark the thread as [SOLVED]. Directions on how to do so are here. Thanks.


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

#16 2014-12-29 18:22:16

cavalierejody
Member
Registered: 2014-12-26
Posts: 8

Re: Pacmanpackage query yaourt issue going on for me.

I had the same problem... and solved it using the procedure above. Thanks.
My question now is: what is the "right" way to upgrade pacman the next time?

Last edited by cavalierejody (2014-12-29 18:25:14)

Offline

#17 2014-12-29 18:27:15

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 24,203
Website

Re: Pacmanpackage query yaourt issue going on for me.

The right way to upgrade an archlinux system has and always will be `pacman -Syu`.

The problem here is not pacman, but one or more of the following: the yaourt-affiliated packages, the archlinux.fr repo, and most importantly users who remain willfully ignorant of what they are doing by relying far to heavily on the first two items on this list.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#18 2014-12-29 18:57:42

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,046
Website

Re: Pacmanpackage query yaourt issue going on for me.

Trilby wrote:

The right way to upgrade an archlinux system has and always will be `pacman -Syu`.

The problem here is not pacman, but one or more of the following: the yaourt-affiliated packages, the archlinux.fr repo, and most importantly users who remain willfully ignorant of what they are doing by relying far to heavily on the first two items on this list.


QFT. Closing.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB