You are not logged in.

#1 2004-02-16 17:23:32

Shemeta
Member
Registered: 2004-02-11
Posts: 117

Permission problems

Hi Arch community,

i have problems with the permissions. i run the following commands :

chown -R root.audio /dev/sound
chmod 770 /dev/sound
chmod 660 /dev/sound/*

so my sound would work. i have all needed modules in /dev/sound/  but when i restart my comp, i get the error from GNOME, "Can't open /dev/sound/mixer"

after reboot i don't access & permission rights to the directory /dev/sound . any other suggestions?

# Allow access to sound devices for group "audio"
REGISTER ^sound/.* PERMISSIONS root.audio 0660
REGISTER ^snd/.* PERMISSIONS root.audio 0660

i also added myself to the group audio. so i have no clue what else to try.

any help would be appreciated. Thanks a lot, Shemeta

Offline

#2 2004-02-16 20:43:31

Blaasvis
Member
Registered: 2003-01-17
Posts: 467

Re: Permission problems

did you add the group audio to your system ?


Freedom is what i love

Offline

#3 2004-02-16 22:17:06

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,442

Re: Permission problems

good question.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#4 2004-02-17 15:25:19

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: Permission problems

Shemeta wrote:

# Allow access to sound devices for group "audio"
REGISTER ^sound/.* PERMISSIONS root.audio 0660
REGISTER ^snd/.* PERMISSIONS root.audio 0660

I would just change that to:

REGISTER ^sound/.* PERMISSIONS root.users 0660
REGISTER ^snd/.* PERMISSIONS root.users 0660

Offline

Board footer

Powered by FluxBB