You are not logged in.

#1 2006-03-21 08:08:16

Neuro
Member
From: Poland
Registered: 2005-10-12
Posts: 352

USB storage (module autoloading) problem

I'm running a custom kernel 2.6.15.6, no initrd, just a semi-static kernel for my own personal use.
Lately, USB stick handling via udev stopped working. I can't exactly say which upgrade caused the problem, because I don't use usb sticks everyday wink

Now, I'm running udev-087-2 and yes, I applied the uevent patch to the kernel and I put CONFIG_KOBJECT_UEVENT=y into my config file at build. However when I zcat /proc/config.gz it's not there. Dunno why, but it just isn't there. But still I think it's there, somewhere.

As for what dmesg says:

usb 1-4: new high speed USB device using ehci_hcd and address 2

udev doesn't load usb-storage automatically, that's the main problem here. But when I do it by hand, everything works fine:

usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
  Vendor: Pretec    Model: 512MB Tiny        Rev: 1.00
  Type:   Direct-Access                      ANSI SCSI revision: 02
SCSI device sdb: 1024000 512-byte hdwr sectors (524 MB)
sdb: Write Protect is off
sdb: Mode Sense: 00 00 00 00
sdb: assuming drive cache: write through
SCSI device sdb: 1024000 512-byte hdwr sectors (524 MB)
sdb: Write Protect is off
sdb: Mode Sense: 00 00 00 00
sdb: assuming drive cache: write through
 sdb: sdb1
sd 2:0:0:0: Attached scsi removable disk sdb
sd 2:0:0:0: Attached scsi generic sg1 type 0
usb-storage: device scan complete

Anyone knows why the module autoloading doesn't work? Any tips on how to reenable it?

Offline

#2 2006-03-21 09:23:48

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: USB storage (module autoloading) problem

come on you read udev readme?

Offline

#3 2006-03-21 10:06:12

Neuro
Member
From: Poland
Registered: 2005-10-12
Posts: 352

Re: USB storage (module autoloading) problem

yep, I did...

-----------------------------------------------------------------
* Modules are not loaded anymore during coldplug or hotplug event
-----------------------------------------------------------------
- Udev is usually responsible for this, but the MOD_AUTOLOAD switch will
  now disable it.  If you want automatiic hot/cold-plugging, turn on
  MOD_AUTOLOAD.  Otherwise you will have to load all your modules manually,
  either with /sbin/modprobe or entries in the MODULES=() array.
Solution:
- For bootup (coldplug) enter this in rc.conf: MODULES=(moduleA moduleB)
- After bootup (hotplug) use this: modprobe <moduleA>

Is there anyway to autoload the modules without the autoload at startup?

Offline

Board footer

Powered by FluxBB