You are not logged in.

#1 2015-03-06 15:52:41

Registered: 2013-10-07
Posts: 8

Arch linux on Acer Iconia Tab 8 W

Shopping list

What do you need:
1. Acer Iconia Tab 8 W
2. USB OTG adaptor
3. At least 4 USB hub
4. Keyboard
5. One 8+GB USB drive for Windows Recovery(just in case)
6. USB boot media(at least 2GB)
7. USB Wifi supported by linux


Just to be sure create a recovery USB in Windows

Reboot into UEFI:
- from Windows
- go to _Change PC Settings_
- Click Update and recovery, then select Recovery.
- To the right beneath Advanced Startup, click Restart now.
- Once the boot menu appears, select Troubleshoot.
- In the Troubleshoot menu, select Advanced options.
- In the Advanced options menu, click UEFI Firmware Settings.
-Click Restart. The system will restart and enter UEFI.
- With keyboard
- F2 is your friend

The boot media created below should work with Secure Boot on, but just in case you can disable it on the Boot tab(the UEFI is touch only, keyboard sadly does not work)

You also need to change the boot priority to have USB HDD on top

Boot media

Unfortunately this:

dd if=archlinux-*-dual.iso of=/dev/sdX

does not work.

The device has IA32 UEFI which is extremely rare and the default installation media does not work on these devices.

You need different boot manager, I went with rEFInd

My stupid way of doing this:
1. Create arch boot media:

dd if=archlinux-*-dual.iso of=/dev/sdX

2. Copy the ==arch== directory from the ARCH_* partition
3. Create rEFInd media

dd if=refind-flashdrive-*.img of=/dev/sdX

4. Copy the ==arch== directory to the created media
5. I did copy the contents of _arch/boot/i686_ to _EFI/boot_ this might not be necessary but makes life easier
6. Edit ==EFI/boot/refind.conf==:

        menuentry Linux {
        icon /EFI/boot/icons/os_arch.png
            loader  /EFI/boot/vmlinuz
           initrd  /EFI/boot/intel_ucode.img
        initrd  /EFI/boot/archiso.img
        options "archisobasedir=arch archisolabel=ARCH_201503"
Change ARCH_201503 for the label of the drive(or change the lable of the drive to it), this is inspired by the _loader/entries/archiso-x86_64.conf_ on the original install media

Now you should be able to boot into install. This worked even with the secure boot enabled for me.


You do need the external Wifi module to get connected to the internet.

Also the time was pretty messed up on my device so I needed to enable ntpd daemon

systemctl start ntpd

to update the date and time(pacman would complain during installation about invalid keys).

Installation should go through as expected the disk drives are eMMC so they show up as /dev/mmcblk0 partitions as /dev/mmcblk0p*

What does not work

I am skiping what works section because at this time that is kind of pointless.

Oh yeah, the IA32 UEFI did prove to be quite a hassle. And No I did not convice it to accept my bootloaders. I did try the Grub IA32 version and rEFInd on the boot drive

Grub proved to be quite useless as it did not manage to make the boot process flawless(it got stuck in rootfs shell as it did not manage to mount root partition - but continues on with no issues after you exit this shell)

rEFInd interesting boot loader, but still not recognised by the UEFI.

The only way I can get it to boot is using the installation media rEFInd which luckily detects the kernels on the disks and after the rEFInd installation in the OS and the configuration creation it boots even with correctly mounting the root drive

I would guess that

efibootmgr -c -d /dev/mmcblk0 -p 1 -l /EFI/boot/bootia32.efi -L "rEFInd Boot Manager"

(I did try puting the partition number to it and withouth it directly for mmcblk0p1 - my EFI partition) is not able to store anything pernamently into the UEFI

I am not sure if this:

    [   17.710271] mmcblk0rpmb: error -110 transferring data, sector 8064, nr 8, cmd response 0x900, card status 0xb00
    [   17.710945] mmcblk0rpmb: retrying using single block read
    [   17.713089] mmcblk0rpmb: timed out sending r/w cmd command, card status 0x400900
    [   17.715733] mmcblk0rpmb: timed out sending r/w cmd command, card status 0x400900
    [   17.718410] mmcblk0rpmb: timed out sending r/w cmd command, card status 0x400900
    [   17.721081] mmcblk0rpmb: timed out sending r/w cmd command, card status 0x400900
    [   17.723749] mmcblk0rpmb: timed out sending r/w cmd command, card status 0x400900
    [   17.726360] mmcblk0rpmb: timed out sending r/w cmd command, card status 0x400900
    [   17.726885] blk_update_request: I/O error, dev mmcblk0rpmb, sector 8064
has anything to do with it as the only thing I can find about it is to ignore it and a patch for kernel to disable the error.

It does work, but you need to compile 4.0 kernel. After that it works like a charm.

tl;dr: No way

There is a post about the BCM4330 which is as far as I know the wifi/bt chip used in this. I did apply the patch mentioned there to the 4.0 kernel while compiling it for the Touch support, unfortunately that did not go well for me and even though the touch was fixed by this, wifi is still not operational.

I did try the kernel brcmfmac module and even the broadcom-wl way but no luck

It is a sdio card and I am pretty much lost here I do think that there is even an error initializing it:

    [    1.029473] sdhci: Secure Digital Host Controller Interface driver
    [    1.029479] sdhci: Copyright(c) Pierre Ossman
    [    1.030999] sdhci-acpi 80860F14:00: No vmmc regulator found
    [    1.031007] sdhci-acpi 80860F14:00: No vqmmc regulator found
    [    1.034755] mmc0: SDHCI controller on ACPI [80860F14:00] using ADMA
    [    1.036037] sdhci-acpi INT33BB:00: No vmmc regulator found
    [    1.036043] sdhci-acpi INT33BB:00: No vqmmc regulator found
    [    1.039308] mmc1: SDHCI controller on ACPI [INT33BB:00] using ADMA
    [    1.039644] sdhci-acpi 80860F14:02: failed to setup card detect gpio
    [    1.040660] sdhci-acpi 80860F14:02: No vmmc regulator found
    [    1.040664] sdhci-acpi 80860F14:02: No vqmmc regulator found
    [    1.043932] mmc2: SDHCI controller on ACPI [80860F14:02] using ADMA

Full dmesg


It is a neat and quite cheap device which I expected to be able to work thanks to being mostly Intel chip based and expected only the Broadcom to be the hickup. How true that proved to be.

I did install full Gnome 3.14.2 on the device which worked pretty good(after I installed the Intell Driver big_smile).

Also I did compile the 4.0 kernel on the device(It takes for ages and I ran out of battery more than once)

All and all if I managed to get the Boot and Wifi working I would be happy with the device. I have another week to try but my hopes are not high.

If anybody has any ideas how to make the BCM4330 work or how to convince the UEFI to recognise the bootloaders throw them this way.


Board footer

Powered by FluxBB