You are not logged in.

#1 2006-03-21 21:57:49

honzor
Member
Registered: 2005-12-18
Posts: 42

[SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

Since the update to 2.6.16, my soundcard (on a i915 board) is not working anymore... modules loaded correctly, channels unmuted, but still im getting no sound... anyone with some hint?

Offline

#2 2006-03-21 22:30:31

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

if you used alsaconf for setup remove the lines in modprobe.conf

Offline

#3 2006-03-22 09:45:29

honzor
Member
Registered: 2005-12-18
Posts: 42

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

Thanx for the reply, but i never configured it with alsaconf so there are no alsaconf lines in modprobe.conf

Offline

#4 2006-03-22 09:58:09

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

do you have the oss comatibility modules in modprobe.conf?

Offline

#5 2006-03-22 11:40:43

honzor
Member
Registered: 2005-12-18
Posts: 42

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

Nope, what exactly are they for and what lines should i add?

Offline

#6 2006-03-22 12:52:05

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

could you post your modprobe.conf?

Offline

#7 2006-03-22 14:32:30

honzor
Member
Registered: 2005-12-18
Posts: 42

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

Here it is... i played arounds with the alias directives but no luck...

#
# /etc/modprobe.conf (for v2.6 kernels)
#
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-card-0
options libata atapi_enabled=1

Offline

#8 2006-03-22 14:35:18

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

how about commenting these lines? the ata stuff is not needed since we patch our kernel to use it by default

Offline

#9 2006-03-22 15:02:10

honzor
Member
Registered: 2005-12-18
Posts: 42

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

Well ok but that doesnt/didnt solve the problem...

Offline

#10 2006-03-22 19:42:52

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

Did it work with 2.6.15 without passing some

options snd-hda-intel model=something

and the problem is encountered just now?


Microshaft delenda est

Offline

#11 2006-03-22 19:53:19

honzor
Member
Registered: 2005-12-18
Posts: 42

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

exactly, it did work flawlessy (apart from the headphone jack not muting the speakers) without any special configuration.

Offline

#12 2006-03-23 00:03:11

honzor
Member
Registered: 2005-12-18
Posts: 42

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

UPDATE: Running hwd -s tells me that hwd doesnt even recognize any soundcard...

Offline

#13 2006-03-23 07:03:57

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

you have the correct devices in /dev?
if yes then perhaps the intel-hda module activates a special feature of your card like 3d sound or someting like that.
just try everything with a mixer app, like kmix if you use kde.

Offline

#14 2006-03-23 07:24:29

honzor
Member
Registered: 2005-12-18
Posts: 42

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

yes, i have the correct devices in /dev.... dsp soft linked to /sound/dsp which exists too... played around with module configurations but no luck... Strange, as, as i said, it worked flawlessy with 2.6.15

Offline

#15 2006-03-24 08:56:46

strike_anywhere
Member
Registered: 2005-12-24
Posts: 9

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

Hi
I've compiled now kernel version 2.6.16, with new ArchCK Patchset (2.6.16-archck1), and sounds works good
I've just compiled it without any driver module in the Sound Section, and then i've installed separetly latest AlsaCVS drivers from source (or try
to install new alsa-driver-rc4 sources, i think it includes hda-intel patch-fix)
Just my 2 Cents

Offline

#16 2006-03-24 12:11:17

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

please try kernel 2.6.16-5 updated the alsa subsystem to rc4

Offline

#17 2006-03-24 13:37:16

honzor
Member
Registered: 2005-12-18
Posts: 42

Re: [SOLVED]snd_hda_intel not working anymore with kernel 2.6.16

Works great now! Thanx for fast and kind support smile

Offline

Board footer

Powered by FluxBB