You are not logged in.

#1 2015-04-10 12:38:05

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 336
Website

KF5.9 and plasma-nm

We have KDE Frameworks 5.9 in testing now. We should have plasma-nm 5.2.2 with this http://quickgit.kde.org/?p=plasma-nm.gi … 34&o=plain patch in testing too. In other case, there are unresolved dependency conflicts between modemmanager-qt, libmm-qt and plasma-nm or when we unistall plasma-nm (and libmm-qt) we haven't got networkmanager applet.

Offline

#2 2015-04-10 15:07:03

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 2,129

Re: KF5.9 and plasma-nm

What is the exact issue here? modemmanager-qt won't be needed until Plasma 5.3

Offline

#3 2015-04-10 16:04:20

Loose_Control
Member
From: Germany
Registered: 2011-01-11
Posts: 136

Re: KF5.9 and plasma-nm

according to https://www.kde.org/announcements/kde-f … -5.9.0.php:
"Note that Plasma-NM 5.2.x needs a patch in order to build and work with this version of ModemManagerQt. plasma-nm patch."

So i guess something isn't working properly without this patch. (why else mention it in the release announcement...)

Last edited by Loose_Control (2015-04-10 16:06:46)

Offline

#4 2015-04-10 16:29:43

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 336
Website

Re: KF5.9 and plasma-nm

Ok, sorry, it's my fault. This "error" exist only when somebody try to install kf5 group from testing, not when we upgrade system via pacman -Syu.
BTW: NMQt and MMQt works perfectly with yours plasma-nm-git.

@Loose_Control: Yes, plasma-nm not works with modemmanager-qt (with networkmanager-qt works with little changing in PKGBUILD). But, when we upgrade system, networkmanager-qt and modemmanager-qt aren't intended to istnall, that this "error" as I explain in first post, doesn't exist.
I run: pacman -S kf5, which want to install all packages in those group, with networkmanager-qt and modemmanager-qt - in those case, there is dependency conflict with plasma-nm.
As I said: it's my fault.

Last edited by pb (2015-04-10 16:34:39)

Offline

Board footer

Powered by FluxBB