You are not logged in.

#1 2006-03-02 22:09:37

isofluran
Member
From: Berlin, Germany
Registered: 2005-10-19
Posts: 25

[Solved/Workaround] Kernel panic with archck

I have a new archlinux installation on an ibm t40p laptop. As done on two other (desktop) systems I like to switch to archck to get the 1400x1050 frambuffer running.
With pacman I installed the archck kernel and build the initramfs file with the "mkinitramfs full kernel_version=2.6.16-archck" command (I also tried the auto option but it makes no difference.)

Booting the archck kernel with grub always ends with this message:

mount: Mounting /dev/root on /new_root failed: No such device or address
umount: /initrd: No such file or directory
umount: /initrd: No such file or directory
chroot: cannot execute /bin/sh: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

I hopefully found this thread (http://bbs.archlinux.org/viewtopic.php?t=18782)
but it does not solve my problem, because the menu.1st is edited correctly AFAIK.

The menu.1st section for the standard and the archck kernel:

# (0)
title           Archlinux
root           (hd0,4)
kernel        /vmlinuz26 root=/dev/hda7 vga=795 ro
initrd          /initrd26.img

# (1)
title           ArchlinuxCK
root            (hd0,4)
kernel          /vmlinuz26archck root=/dev/hda7 video=vesafb:ywrap,mtrr,1400x1050-32@50 ro
initrd          /initramfs-2.6.15-archck.img

BTW the standard kernel is booting without any errors.

Any ideas?

Offline

#2 2006-03-02 22:42:07

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: [Solved/Workaround] Kernel panic with archck

isofluran wrote:

With pacman I installed the archck kernel and build the initramfs file with the "mkinitramfs full kernel_version=2.6.16-archck"

This probably isn't the solution, but you should use "full" OR "kernel_version=etc" - not both.

Offline

#3 2006-03-03 05:48:47

isofluran
Member
From: Berlin, Germany
Registered: 2005-10-19
Posts: 25

Re: [Solved/Workaround] Kernel panic with archck

This isn't really a solution.
None of the different initramfs files work. I tried the full, auto and kernel_version options in all possible combinations (and I changed the initrd line from initramfs-2.6.15-archck.img to initramfs-full.img).

Still waiting for any hints ...

Offline

#4 2006-03-03 08:22:00

isofluran
Member
From: Berlin, Germany
Registered: 2005-10-19
Posts: 25

Re: [Solved/Workaround] Kernel panic with archck

There is maybe a problem mounting the root partition because of its filesystem: The root partition is xfs. Is it possible that there is a problem with the xfs module?
I'm not firm with these things because I never had any problems with the kernel of archlinux (neither standard nor archck), so this is a new experience to me.

Offline

#5 2006-03-03 08:43:50

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: [Solved/Workaround] Kernel panic with archck

what versions of archck and mkinitramfs do you have, check in pacman.

iphitus

Offline

#6 2006-03-03 10:06:44

isofluran
Member
From: Berlin, Germany
Registered: 2005-10-19
Posts: 25

Re: [Solved/Workaround] Kernel panic with archck

mkinitramfs  1.2-2
kernel26archck 2.6.15.archck4-2

Offline

#7 2006-03-04 08:55:22

isofluran
Member
From: Berlin, Germany
Registered: 2005-10-19
Posts: 25

Re: [Solved/Workaround] Kernel panic with archck

I did a complete new installation first with the same fs (xfs) and this gives me the same kernel panic. Now I changed the root partition to ext3 and all is fine. Maybe it is really a problem related to the xfs module.
So this is not a true solution but a good workaround for me.

Offline

#8 2006-03-20 03:01:52

STiAT
Member
From: Vienna, Austria
Registered: 2004-12-23
Posts: 603

Re: [Solved/Workaround] Kernel panic with archck

Can confirm a problem like this exists.
I freshly updated my system ... now i'm stuck with this kernel panic...

Failed to execute /init
Kernel panic - not syncing: No init found. Try passing init= option to kernel.

Ability is nothing without opportunity.

Offline

#9 2006-03-22 01:46:28

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: [Solved/Workaround] Kernel panic with archck

Are you passing any init= options at the bootloader? remove them if you are.

iphitus

Offline

#10 2006-03-22 16:13:31

STiAT
Member
From: Vienna, Austria
Registered: 2004-12-23
Posts: 603

Re: [Solved/Workaround] Kernel panic with archck

No, i'm not.

My bootloader lines (grub)

root (hd0,6)
kernel /vmlinuz26archck root=/dev/hda9 video=vesafb:ywrap,mtrr,1024x768-32@60 splash=verbose,theme:darch ro
initrd /initramfs-2.6.15-archck.img

Since i didn't know if you also meant the initrd line, i removed the initrd line for a small test, but as expected:

VFS: Cannot open root device "hda9" or unknown-block(0,0)
Please append a correct "root=" bootoption
Kernel panic - not syncing: VFS: Unable to mount root fs on uknown-block(0,0)

Ability is nothing without opportunity.

Offline

#11 2006-03-22 22:05:50

gunnix
Member
Registered: 2005-11-11
Posts: 102
Website

Re: [Solved/Workaround] Kernel panic with archck

STiAT wrote:

No, i'm not.

My bootloader lines (grub)

root (hd0,6)
kernel /vmlinuz26archck root=/dev/hda9 video=vesafb:ywrap,mtrr,1024x768-32@60 splash=verbose,theme:darch ro
initrd /initramfs-2.6.15-archck.img

Since i didn't know if you also meant the initrd line, i removed the initrd line for a small test, but as expected:

VFS: Cannot open root device "hda9" or unknown-block(0,0)
Please append a correct "root=" bootoption
Kernel panic - not syncing: VFS: Unable to mount root fs on uknown-block(0,0)

Hey, I've got exactly the same problem! Did you find any solution yet?


As is true for most people I know, I've always loved learning. As is also true for most people I know, I always hated school. Why is that?

Offline

#12 2006-03-23 10:06:14

STiAT
Member
From: Vienna, Austria
Registered: 2004-12-23
Posts: 603

Re: [Solved/Workaround] Kernel panic with archck

No, i didn't find any solution yet.

Still playin' around.


Ability is nothing without opportunity.

Offline

#13 2006-03-23 10:31:59

gunnix
Member
Registered: 2005-11-11
Posts: 102
Website

Re: [Solved/Workaround] Kernel panic with archck

Yea me too.. I've tried some stuff but nothing worked.


As is true for most people I know, I've always loved learning. As is also true for most people I know, I always hated school. Why is that?

Offline

#14 2006-03-23 10:49:33

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: [Solved/Workaround] Kernel panic with archck

what sort of setup do you guys have?

what filesystem is your / fs on?
can I get some context, something like the whole 10 lines before the error?

iphitus

Offline

#15 2006-03-23 11:15:39

gunnix
Member
Registered: 2005-11-11
Posts: 102
Website

Re: [Solved/Workaround] Kernel panic with archck

Sure! smile

I have 2 partitions (+1 swap)
/dev/hdb1  which is /boot  --> ext2
and /dev/hdb3  which is /    --> ext3

lines before including error:

Suspend2 Core.
Suspend2 Compression Driver loading.
Suspend2 Encryption Driver loading.
Suspend2 Swap Writer loading.
Suspend2 FileWriter loading.
ACPI wakeup devices:
PCI0 USB0 USB1 USB2 USB6 USB7 USB8 USB9 LAN0 MC97 UAR1 ECP1
ACPI: (supports S0 S1 S4 S5)
Freeing unused kernel memory: 196k freed
Failed to execute /init
Kernel panic - not syncing: No init found. Try passing init= option to kernel.

The vesa framebuffer starts at boot now, but before I upgraded I never had the framebuffer starting.


As is true for most people I know, I've always loved learning. As is also true for most people I know, I always hated school. Why is that?

Offline

#16 2006-03-23 11:25:45

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: [Solved/Workaround] Kernel panic with archck

That sheds some more light

Could I get your /etc/mkinitramfs.conf and any commands you used to generate your initramfs?

iphitus

Offline

#17 2006-03-23 15:15:27

gunnix
Member
Registered: 2005-11-11
Posts: 102
Website

Re: [Solved/Workaround] Kernel panic with archck

Well I did try

mkinitramfs auto
mkinitramfs full

I did adjust menu.lst correctly.

This are the versions I have installed, I run arch from current and extra repositories:
kernel26archck 2.6.15.archck7-4
mkinitramfs 1.3-5

My /etc/mkinitramfs.conf (I did not edit anything there actually):

# Initial Ramdisk setup
# Attention:
# You need only the stuff to be able to mount your root device!
# USB/FW are only needed if you boot from such devices!

# REMOVE_IDE:           removes the complete IDE subsystem
# REMOVE_SCSI:          removes the complete SCSI subsystem
# REMOVE_SATA:          removes the complete SATA subsystem
# REMOVE_CDROM:         removes cdrom support
# REMOVE_USB:           removes the complete USB subsystem
# REMOVE_FW:            removes the complete Firewire subsystem
# REMOVE_RAID:          removes the complete Software RAID subsystem
# REMOVE_DM:            removes the complete device-mapper/LVM subsystem
# REMOVE_FS:            removes the complete Filesystems
#                       (you have to include the filesystem in kernel then!)
# AUTODETECT:           enables Arch Linux autodetection 
# HOSTCONTROLLER_*:     specify the modules you need to setup the subsystem "moduleX moduleY",
#                       empty means all modules are included
# FILESYSTEMS:          specify your filesystem modules here, eg. "ext3 reiserfs"
#                       empty means all modules are included
# USB_TIMEOUT:          value means  seconds to wait for bringing up usb disks
# CRYPT_DEVICE:         the path to your encrypted root device, if you use one
# RAID_DEVICES:         a space-delimited list of the devices belonging in
#                       your /dev/md0 (root) RAID array
#                           (eg, "/dev/hda3 /dev/hdc3")
#
# ADD_MODULE:           adds modules e.g. "moduleX moduleY"
# REMOVE_MODULE:        removes modules e.g. "moduleX moduleY"
#
# To rebuild initramfs for archck kernel just rerun 'mkinitramfs auto'



# Disable whole subsystems by setting to "1"
REMOVE_IDE=
REMOVE_SCSI=
REMOVE_SATA=
REMOVE_CDROM=
REMOVE_USB=1
REMOVE_FW=1
REMOVE_RAID=1
REMOVE_DM=1
REMOVE_FS=

# Enable auto-detection of HOSTCONTROLlER and FILESYSTEMS (set to "1")
#   (NOTE: This is still experimental, so it is disabled by default)
AUTODETECT=0

# To use fbsplash/gensplash, you need to install gensplashutils and initscripts-gensplash from community.
# Add a theme to enable fbsplash, Try 'darch', it's included in the gensplashutils.
FBSPLASH_THEME=

# Resolution to use, 1024x768 will be used if left blank. Format is '1024x768'
FBSPLASH_RES=

# Custom DSDT support can be included if you include the FULL path to the DSDT file here
# If left empty, it will not be included. If unsure, leave empty.
DSDT=

# Define which modules are needed by adding "moduleX moduleY"
# If left empty, all modules are included if they are not disabled above
HOSTCONTROLLER_IDE=
HOSTCONTROLLER_SCSI=
HOSTCONTROLLER_SATA=
HOSTCONTROLLER_USB=
FILESYSTEMS=

# Number of seconds to wait for USB devices to settle
USB_TIMEOUT=5

# If you have an encrypted root filesystem, set it here (eg, /dev/hda4)
CRYPT_DEVICE=

# If you use software RAID for your root device then list all the devices
# that belong to your root array here.  If your root RAID device is
# something other than md0, then change the RAID_ROOT_ARRAY setting.
#    eg, RAID_ROOT_DEVICES="/dev/hda3 /dev/hdc3"
RAID_ROOT_ARRAY="md0"
RAID_ROOT_DEVICES=

# If you use LVM on your root device, then specify it here
#    eg, LVM_ROOT="/dev/vg_root/lv_root"
LVM_ROOT=

# Define additional modules here
ADD_MODULE=
REMOVE_MODULE=

Now I have another error message, but it panics about on the same point where it can't find the root filesystem.

I'm going to try to add ext3 manually.
I was mistaken about my filesystem before, this is my fstab:
----------
/dev/hdb3 / ext3 defaults 0 1
/dev/hdb1 /boot ext2 defaults 0 1
/dev/hdb2 swap swap defaults 0 0

/dev/hda1 /mnt/hda1 ext3 defaults 0 1
-------------

Well thanks for reading this.


As is true for most people I know, I've always loved learning. As is also true for most people I know, I always hated school. Why is that?

Offline

#18 2006-03-25 20:38:38

STiAT
Member
From: Vienna, Austria
Registered: 2004-12-23
Posts: 603

Re: [Solved/Workaround] Kernel panic with archck

I ordered a new cdr drive to be able to get a working console. Since it's a notebook it's not that easy....

Should be about a week till i can give you proper information about this.
As i remember i have a matching setup
a /boot partition (ext2 or ext3, dont remember ... the system was updated since 0.7 ... so a quite long time ago since i did the setup on that machine smile)
a /root partition, reiserfs
a /home partition, reiserfs

Since i changed job recently it's not a problem to do a new setup. But i'd prefer to get it running without setting up the whole machine again....

I think since gunnix has exactly the same problem it may also is the same solution in the end.

// STi


Ability is nothing without opportunity.

Offline

#19 2006-03-26 10:13:56

gunnix
Member
Registered: 2005-11-11
Posts: 102
Website

Re: [Solved/Workaround] Kernel panic with archck

To add some more info, this is my menu.lst:

# (0) Arch Linux
title  Arch Linux hdb3  [/boot/vmlinuz26archck]
root   (hd1,0)
kernel /vmlinuz26archck root=/dev/hdb3 ro
initrd /initramfs-2.6.15-archck.img

# (0) Arch Linux
title  Arch Linux hdb3  [/boot/vmlinuz26]
root   (hd1,0)
kernel /vmlinuz26 root=/dev/hdb3 ro
initrd /initrd26.img

# (0) Arch Linux
title  Arch Linux hdb3  [/boot/vmlinuz26archck]
root   (hd1,0)
kernel /vmlinuz26archck root=/dev/hdb3 ro
initrd /initramfs-full.img


I usually used the upper one, the others I added to try getting the system to boot but those won't work either. I always get a problem where it can't find root.

---------

In DSL these are the modules needed for my computer, lsmod:
Module                  Size  Used by    Not tainted
ext3                   64388   2 (autoclean)
jbd                    46804   2 (autoclean)  [ext3]
nls_iso8859-1           2844   0 (autoclean)
mousedev                3832   0 (unused)
hid                    22788   0 (unused)
input                   3168   0 [mousedev hid]
af_packet              13608   0 (autoclean)
via82cxxx_audio        20888   1
ac97_codec             12140   0 [via82cxxx_audio]
uart401                 6052   0 [via82cxxx_audio]
sound                  55276   0 [via82cxxx_audio uart401]
soundcore               3428   4 [via82cxxx_audio sound]
via-rhine              12368   1
mii                     2240   0 [via-rhine]
crc32                   2816   0 [via-rhine]
serial                 52228   0 (autoclean)
ieee1394              183300   0
pcmcia_core            39840   0
ide-cd                 28768   0
rtc                     7036   0 (autoclean)
cloop                  39204   2
usb-storage            61952   0 (unused)
ehci-hcd               16456   0 (unused)
usb-uhci               21516   0 (unused)
usbcore                58016   1 [hid usb-storage ehci-hcd usb-uhci]
ide-scsi                9040   0


via82cxxx is my chipset driver


As is true for most people I know, I've always loved learning. As is also true for most people I know, I always hated school. Why is that?

Offline

#20 2006-05-06 07:17:35

Kin
Member
From: Oberfranken / Europe
Registered: 2004-01-23
Posts: 137

Re: [Solved/Workaround] Kernel panic with archck

Hi,

just wanted to test the beyond and archck kernel. I have similar problems. But what to do exactly ?

Offline

Board footer

Powered by FluxBB