You are not logged in.

#1 2015-03-22 18:35:03

hudgengt
Member
Registered: 2014-03-12
Posts: 4

[Solved] New install - invalid of corrupted package (PGP signature)

I have been using Arch for some time now and I have never ran into this issue.  I am trying to reinstall arch on my Acer c720 after flashing it with the John Lewis firmware. I get 5 packages (dhcpcd, lzo, libarchive, libaio, and groff) that give me the following error.

error: dhcpcd: signature from "Anatol Pomozov <anatol.pomozov@gmail.com>" is unknown trust
:: File /mnt/var/cache/pacman/pkg/dhcpcd-6.7.1-1-x86_64.pkg.tar.xz is corrupter (invalid of corrupted package (PGP signature)).

I get this same error for all 5 packages listed above.  I have tried doing this install from the February iso twice and once from the March iso.  While in the arch iso I have updated the (pacman-keyring) and also ran (pacman-key --init; pacman-key --populate archlinux) but still receive the same error.  I also copied these 5 packages from my desktop but also get the same error from those as well.

I you have any ideas or need more information please let me know.

Thanks

edit: Spelling.

Last edited by hudgengt (2015-03-22 19:00:53)

Offline

#2 2015-03-22 18:47:59

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [Solved] New install - invalid of corrupted package (PGP signature)

Is your time set correctly? Have you tried adding the key manually? http://pgp.mit.edu:11371/pks/lookup?op= … ED753E0F1F
Are other packages installing OK?

Offline

#3 2015-03-22 19:00:20

hudgengt
Member
Registered: 2014-03-12
Posts: 4

Re: [Solved] New install - invalid of corrupted package (PGP signature)

Fixing the time solved it.

Thanks

Offline

#4 2015-04-07 22:26:12

larso
Member
Registered: 2015-04-07
Posts: 1

Re: [Solved] New install - invalid of corrupted package (PGP signature)

Hi I'm trying to install arch on my laptop and get this excact problem. I have tried a lot fixing the time with timedatectl and setting the correct timezone (Europe/Oslo) but no matter what I do, these 5 packages:
- dhcpd
- lzo
- libarchive
- libaio
- libatomic_ops
all fail to install with this error:
signature from "Anatol Pomozov <anatol.pomozov@gmail.com>" is unknown trust
:: File [...] is corrupted (invalid or corrupted package (PGP signature)).

and then pacstrap -i /mnt base base-devel fails with "Errors occurred, no packages were upgraded"

I actually installed arch on another laptop a couple of weeks ago and that worked fine. Maybe it has to do with daylight savings time march 29? I thought correct timezone would take care of DST.

Offline

#5 2015-04-14 14:59:56

rajat
Member
Registered: 2013-10-10
Posts: 10

Re: [Solved] New install - invalid of corrupted package (PGP signature)

I found this https://bbs.archlinux.org/viewtopic.php?id=190380 and there is a fix mentioned there which is Run the following command as root

dirmngr </dev/null

Followed by

pacman-key --populate archlinux
pacman-key --refresh-keys

Then
pacstrap -i /mnt base base-devel

Last edited by rajat (2015-04-16 06:48:14)


Linux is easy.. People are Difficult

Offline

#6 2015-05-15 17:08:50

benob
Member
Registered: 2008-11-11
Posts: 187

Re: [Solved] New install - invalid of corrupted package (PGP signature)

This should be added to the install media instructions.

Offline

#7 2016-07-11 05:45:47

cmuxed
Member
Registered: 2016-07-11
Posts: 1

Re: [Solved] New install - invalid of corrupted package (PGP signature)

Thanks @rajat!!

This worked for me on my existing system. 

I abandoned this problem about a year ago after working on it for hours.  A quick search today in frustration when I couldn't use pacman rendered this post.
I did try the populate/refresh commands last time, but not dirmngr </dev/null.

Offline

#8 2017-01-16 07:47:59

Malvineous
Member
From: Brisbane, Australia
Registered: 2011-02-03
Posts: 175
Website

Re: [Solved] New install - invalid of corrupted package (PGP signature)

Just ran into this issue myself.  Time was correct and recreating the keyring didn't help.  In the end manually downloading the offending key did the trick:

pacman-key -r 0xFC1B547C8D8172C8

I got the key from the end of the URL after going to http://pgp.mit.edu:11371/ and putting "Levente Polyak" into the search box (the name of the key that wasn't working for me).

Offline

#9 2017-01-16 12:22:52

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,081
Website

Re: [Solved] New install - invalid of corrupted package (PGP signature)

Thanks for sharing, Malvineous. I'm going to close this old thread now.

Closing.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB