You are not logged in.

#1 2015-04-20 17:45:21

Basic-Master
Member
Registered: 2007-10-30
Posts: 21

[SOLVED] KDE/Plasma 5 stuck on splashscreen

Hi,

I'm having difficulties getting Plasma to work. I can use SDDM to launch XFCE4 sessions without problems, however every time I try to create a new Plasma session the splashscreen gets stuck somewhere between 60%-90%. When this happens I can still terminate the Xorg session using CTRL+ALT+BKSP and move the cursor so I don't think this is an Xorg problem. So far I have tried the following:

- Remove ~/.config and ~/.cache
- Deleted any .kde* entries from my home directory

Apart from that I've tried to launch a new Plasma session from a VT using startx / .xinitrc. My current xinitrc looks like this:

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

exec startkde

But when I try to start Plasma from a VT, I can see the splashscreen for a couple of seconds and then the screen turns entirely black. Yet I can move the mouse and kill the Xorg session again via CTRL+ALT+BKSP.

A while ago I was faced a similar problem (i.e. Plasma getting stuck while loading), but after a few retries it somehow recovered and then I was able to use Plasma perfectly well. I've really run out of ideas. Has anyone else experienced a similar issue or is there any way to figure out which component gets stuck? I'd really appreciate any advice on this topic.

Many thanks.

Last edited by Basic-Master (2015-04-20 19:08:55)

Offline

#2 2015-04-20 18:03:09

Xabre
Member
From: Serbia
Registered: 2009-03-19
Posts: 738

Re: [SOLVED] KDE/Plasma 5 stuck on splashscreen

Delete any kde related .lock file in .config, .local, and .cache, preferably clean .cache.

Offline

#3 2015-04-20 18:34:50

Basic-Master
Member
Registered: 2007-10-30
Posts: 21

Re: [SOLVED] KDE/Plasma 5 stuck on splashscreen

Thanks, tried that but it doesn't make a difference.

Offline

#4 2015-04-20 18:43:09

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,848

Re: [SOLVED] KDE/Plasma 5 stuck on splashscreen

Do you use zsh?

Offline

#5 2015-04-20 19:08:43

Basic-Master
Member
Registered: 2007-10-30
Posts: 21

Re: [SOLVED] KDE/Plasma 5 stuck on splashscreen

No, my user shell is fish - I've been happy with that one. Changing it back to good ol' bash it didn't help.

But I have good news, I've finally managed to resolve this - it looks like this problem was caused by a faulty kscreen configuration (don't know why though). Once I removed ~/.local/share/kscreen I could log back into my Plasma session - now everything appears to be working well again. I'll disable the KScreen 2 background service though, I really don't want this to happen again in the future (xrandr should work either way). Next time I'll try to move away .local first, I didn't know some KDE components store values in that directory as well.

Thanks again for your suggestions smile

Offline

Board footer

Powered by FluxBB