You are not logged in.

#1 2015-04-25 07:41:02

Registered: 2011-07-28
Posts: 85

[SOLVED] xf86-input-cmt-xorg cannot move cursor

UPDATE: This turned out to be a driver configuration issue. Starting from the 'samus' (chromebook pixel) configuration, I increased the vertical and horizontal resolution by about 10x, and now the cursor movement is functional and smooth. Still needs a bit of tweaking, but seems to work nicely now.

I have a fresh install of Arch on a 13in Retina MBP (model 11,1), with little but Xorg, slim, and dwm. I've just installed xf86-input-cmt-xorg (which is a much nicer alternative to synaptics), and the pointer responds very oddly. If I click physically, a click will register. However, any touch input that would ordinarily move the pointer instead causes it to jump to the top left corner. On some occasions, touch input is just ignored.

Here's what I know:

I have 20-mouse.conf and 40-touchpad-cmt.conf in /usr/share/X11/xorg.conf.d, so I believe all the configuration files are in place.

I've added my user to the 'input' group.

bcm5974, which is associated with the Macbook touchpad, appears in the output of 'xinput list'; Xorg.0.log shows the line

Using input driver 'cmt' for 'bcm5974'

So the driver is loaded correctly here. I think its output isn't being interpreted properly, because later it says

663: ABBS_MT[30] = 24 : value out of range [-1946583904 .. -1946584096] 

I presume that the above error results in the mouse being defaulted to (0,0) on the screen. That's also a very weird-looking range... Perhaps it's set incorrectly? I don't know.

I've seen a similar error before on Linux Mint 17, where the solution was to install kernel 3.19 or higher (3.19+ had patches needed for the cmt driver). However, I'm already on 3.19.3 on Arch here (and have also tried 4.0 from testing), so I don't know what could be causing this. What other diagnostics could I perform to figure out the source of this issue?

Last edited by DrKillPatient (2015-04-26 00:17:50)


Board footer

Powered by FluxBB