You are not logged in.

#1 2006-03-27 04:20:02

tubasoldier
Member
Registered: 2006-03-25
Posts: 8

aRts and KDE sounds are horrible!

I am trying to get my Soundblaster Audigy working properly. I do not know why but I keep getting these errors:

Loading driver...
:: Saving ALSA Levels                                                    [BUSY] /usr/sbin/alsactl: save_state:1163: No soundcards found...
                                                                         [FAIL]
:: Restoring ALSA Levels                                                 [BUSY] /usr/sbin/alsactl: load_state:1236: No soundcards found...
                                                                         [FAIL]
Setting default volumes...

I get these errors but it will still allow me to open alsamixer and set the volume levels as well as store those volume levels with alsactl store.
I am at a loss and do not know where to go from here.
I have followed the wiki on configuring alsa and still no luck. Any information, ideas, or help would be greatly appriciated.


Now before you ask me if it is plugged in tightly with a good connection please know that it works in every other distribution that I have installed on my system.

Offline

#2 2006-03-27 05:07:34

tubasoldier
Member
Registered: 2006-03-25
Posts: 8

Re: aRts and KDE sounds are horrible!

I must have glanced over this little tidbit here:
"If you have a Dell computer equipped with a Creative Labs Sound Blaster Live! card, you will need to compile ALSA manually."

I have neither a Dell or a Sound Blaster Live. I have an Audigy.

Anyways I thought it couldn't hurt. So I uninstalled all alsa packages with pacman.
Downloaded the source. Compiled it and viola! Working sound system.
This is the first distro that I have had to do that with. I have had to add "modprobe snd-emu10k1" to a few rc.local files in the past, but never a recompile from source.

It still will not start at boot. Is there something I have to add to modprobe.conf or something? Every time I boot I have to open a terminal and do a modprobe for all the sound devices.
modprobe snd-emu10k1
modprobe snd-emu10k1-synth
modprobe snd-pcm-oss

The KDE sounds are non-existent. I tried the "Test Sound" under the kcmshell and it sounded horrible! It was very jumpy and was all over the place in terms of distortion.

If anyone could help me with these two new issues that would be great!
How do I set it to load at boot? I have soundcore and alsa in the Daemons.
How do I get the KDE sounds to work and sound decent?

Thanks!

Offline

#3 2006-03-27 13:50:04

stingray
Member
From: Lima, Peru SA
Registered: 2006-03-24
Posts: 188

Re: aRts and KDE sounds are horrible!

tubasoldier wrote:

It still will not start at boot. Is there something I have to add to modprobe.conf or something? Every time I boot I have to open a terminal and do a modprobe for all the sound devices.
modprobe snd-emu10k1
modprobe snd-emu10k1-synth
modprobe snd-pcm-oss

Try adding those to the MODULES:

ALSA Setup Wiki wrote:

Add snd-pcm-oss and 'snd-NAME-OF-MODULE' to the list of MODULES in '/etc/rc.conf'

MODULES(snd-emu10k1 snd-emu10k1-synth snd-pcm-oss)

And then add "alsa" to the DEAMONS:

ALSA Setup Wiki wrote:

Edit '/etc/rc.conf' and add 'alsa' to the list of daemons to start on bootup

I missed both those steps the first dosen times I worked through the ALSA Setup wiki...  I'm very new to Linux and Arch

Offline

#4 2006-03-27 17:49:52

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,421

Re: aRts and KDE sounds are horrible!

A friend of mine has an SB Audigy ZS and yesterday i did an ftp-install installed of AL for him on a dualboot system.

All i needed to do was to get sound out of it was installing alsa-oss, alsa-lib and alsa-utils, run alsaconf, comment the alias lines in modprobe.conf and add alsa to the daemons.
This was with the stock kernel.

What kernel are you using and have you done pacman -Syu recently ?


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Online

#5 2006-03-27 20:50:11

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: aRts and KDE sounds are horrible!

Also, you might want to try turning off aRTs (uncheck "Enable Sound System" in KDE's "Sound System" config panel).

Offline

Board footer

Powered by FluxBB