You are not logged in.

#1 2015-05-03 10:06:08

mikerhiggins
Member
Registered: 2012-12-22
Posts: 17

[Solved] Error in system upgrade (ruby-glib2)

Hi there, I tried to upgrade my system but have encountered this problem:

[mike@mike-pc ~]$ sudo pacman -Syu
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace libnm-gtk with extra/nm-connection-editor? [Y/n] y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: ruby-gdkpixbuf2: requires ruby-glib2=2.2.4
[mike@mike-pc ~]$ sudo pacman -Sy ruby-glib2
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: ruby-atk: requires ruby-glib2=2.2.4
:: ruby-gdkpixbuf2: requires ruby-glib2=2.2.4
:: ruby-pango: requires ruby-glib2=2.2.4
[mike@mike-pc ~]$ 

I can't seem to upgrade ruby-glib2 to the latest version, which seems to be required for the update! How can I fix this?

Last edited by mikerhiggins (2015-05-03 12:34:46)

Offline

#2 2015-05-03 10:14:03

Raynman
Member
Registered: 2011-10-22
Posts: 1,312

Re: [Solved] Error in system upgrade (ruby-glib2)

Did you get that ruby-gdkpixbuf2 from the AUR before it was renamed to ruby-gdk_pixbuf2? You are responsible for managing AUR packages yourself.

But in this case, ruby-gdk_pixbuf2 is now in [community], so you can install that one (assuming it's a proper replacement for the one you currently one).

Last edited by Raynman (2015-05-03 10:14:21)

Offline

#3 2015-05-03 10:22:32

mikerhiggins
Member
Registered: 2012-12-22
Posts: 17

Re: [Solved] Error in system upgrade (ruby-glib2)

Fair enough, that's entirely possible! To that end, I tried the following:

[mike@mike-pc ~]$ sudo pacman -R ruby-gdkpixbuf2
[sudo] password for mike: 
checking dependencies...

Packages (1) ruby-gdkpixbuf2-2.2.4-2

Total Removed Size:  0.05 MiB

:: Do you want to remove these packages? [Y/n] y
(1/1) removing ruby-gdkpixbuf2                     [######################] 100%
[mike@mike-pc ~]$ sudo pacman -S ruby-gdk_pixbuf2
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: ruby-atk: requires ruby-glib2=2.2.4
:: ruby-pango: requires ruby-glib2=2.2.4

So that's not brought me much further forward. Anything more I can try?

Offline

#4 2015-05-03 10:37:27

Raynman
Member
Registered: 2011-10-22
Posts: 1,312

Re: [Solved] Error in system upgrade (ruby-glib2)

Don't do partial upgrades. You had already synced (-y) but the upgrade (-u) was canceled because of the dependency issue. Fix that first or at the same time as installing ruby-gdk_pixbuf2.

Last edited by Raynman (2015-05-03 10:38:22)

Offline

#5 2015-05-03 10:41:40

bhrgunatha
Member
Registered: 2009-12-16
Posts: 89

Re: [Solved] Error in system upgrade (ruby-glib2)

mikerhiggins wrote:

Fair enough, that's entirely possible! To that end, I tried the following:

[mike@mike-pc ~]$ sudo pacman -R ruby-gdkpixbuf2
[sudo] password for mike: 
checking dependencies...

Packages (1) ruby-gdkpixbuf2-2.2.4-2

Total Removed Size:  0.05 MiB

:: Do you want to remove these packages? [Y/n] y
(1/1) removing ruby-gdkpixbuf2                     [######################] 100%
[mike@mike-pc ~]$ sudo pacman -S ruby-gdk_pixbuf2
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: ruby-atk: requires ruby-glib2=2.2.4
:: ruby-pango: requires ruby-glib2=2.2.4

So that's not brought me much further forward. Anything more I can try?

I had the same problem:

I had to reinstall ruby-gtk2 which fixed ruby-atk and ruby-pango.
Then I was able to upgrade normally.

pacman -S ruby-gtk2
pacman -Syu 

Offline

#6 2015-05-03 12:28:57

johnpiers
Member
From: Somerset West, Cape Town
Registered: 2012-07-22
Posts: 31

Re: [Solved] Error in system upgrade (ruby-glib2)

I had the same problem:

I had to reinstall ruby-gtk2 which fixed ruby-atk and ruby-pango.
Then I was able to upgrade normally.

pacman -S ruby-gtk2
pacman -Syu 

This does not work. Pretty much gives the same error. Anyone who can help?

Last edited by johnpiers (2015-05-03 12:29:45)

Offline

#7 2015-05-03 12:34:32

mikerhiggins
Member
Registered: 2012-12-22
Posts: 17

Re: [Solved] Error in system upgrade (ruby-glib2)

Raynman wrote:

Don't do partial upgrades. You had already synced (-y) but the upgrade (-u) was canceled because of the dependency issue. Fix that first or at the same time as installing ruby-gdk_pixbuf2.

Thanks Raynman, I think I now have this sorted.

Offline

#8 2015-05-03 14:19:27

bhrgunatha
Member
Registered: 2009-12-16
Posts: 89

Re: [Solved] Error in system upgrade (ruby-glib2)

johnpiers wrote:

I had the same problem:

I had to reinstall ruby-gtk2 which fixed ruby-atk and ruby-pango.
Then I was able to upgrade normally.

pacman -S ruby-gtk2
pacman -Syu 

This does not work. Pretty much gives the same error. Anyone who can help?

Aaah, I'm sorry I missed out the first step.

pacman -R ruby-atk ruby-pango
pacman -S ruby-gtk2
pacman -Syu 

Offline

#9 2015-05-03 18:00:09

johnpiers
Member
From: Somerset West, Cape Town
Registered: 2012-07-22
Posts: 31

Re: [Solved] Error in system upgrade (ruby-glib2)

Aaah, I'm sorry I missed out the first step.

pacman -R ruby-atk ruby-pango
pacman -S ruby-gtk2
pacman -Syu 

Thanks, had to remove a few other things as well, but came right in the end! Thanks again!

Offline

Board footer

Powered by FluxBB