You are not logged in.

#1 2015-05-27 12:43:53

mmjam22
Member
Registered: 2015-05-27
Posts: 5

[SOLVED] Gtk overscroll overlay issue on gtk-theme-flatstudio

Hi,

I find the gtk theme gtk-theme-flatstudio in AUR and I apply it.
When I scroll in gtk application such as evince and rhythmbox, opaque bar appears top and bottom.

http://www.pixentral.com/pics/170zqsCOf … b7lGD1.png

Same report on AUR comment and I search fix, but I can't find...
That problem doesn't appears Adwaita.
So I want to remove that opaque bar and replace by transparent effect like Adwaita.
Any ideas for fix?

Mod note: Please read the etiquette regarding pasting images -- https://wiki.archlinux.org/index.php/Fo … s_and_code --  WorMzy

Last edited by mmjam22 (2015-09-06 03:04:59)

Offline

#2 2015-05-28 12:07:38

Malkymder
Member
Registered: 2015-05-13
Posts: 258

Re: [SOLVED] Gtk overscroll overlay issue on gtk-theme-flatstudio

that theme has not been updated in a few years .... might be best to use a more recent theme

Offline

#3 2015-05-28 17:48:21

mmjam22
Member
Registered: 2015-05-27
Posts: 5

Re: [SOLVED] Gtk overscroll overlay issue on gtk-theme-flatstudio

I see. I'll search other theme and read etiquette.
Thanks a lot!

Offline

#4 2015-05-28 20:06:56

Chazza
Wiki Maintainer
From: United Kingdom
Registered: 2013-06-02
Posts: 506

Re: [SOLVED] Gtk overscroll overlay issue on gtk-theme-flatstudio

This may not be a satisfactory fix for your problem, but you can disable the overlay scrollbars if you so wish: https://wiki.archlinux.org/index.php/GT … scrollbars

Offline

#5 2015-05-31 13:57:42

eddy_hunter
Member
Registered: 2015-03-21
Posts: 5

Re: [SOLVED] Gtk overscroll overlay issue on gtk-theme-flatstudio

mmjam22 wrote:

Same report on AUR comment and I search fix, but I can't find...

That was me, it's been driving me crazy since the update.

Chazza wrote:

This may not be a satisfactory fix for your problem, but you can disable the overlay scrollbars if you so wish: https://wiki.archlinux.org/index.php/GT … scrollbars

I would be fine with disabling it, but I don't think that's what the wiki is referring to. The issue isn't that the scrollbar doesn't show unless hovered over, it's with the overscroll shading being opaque.

Using a different theme is always an option, but flatstudio just looks so nice...

Edit:

I just figured out a workaround. Pasting the following into ~/.config/gtk-3.0/gtk.css:

https://gist.github.com/epedroni/03e605 … le-gtk-css

restores the stock Adwaita overshoot look (dark).

To get rid of it completely, use this instead:

https://gist.github.com/epedroni/746d75 … le-gtk-css

It's a bit of a nasty hack, but it solves the issue. I don't know enough about GTK3 theming to fix FlatStudio itself and I don't have the time to look into it right now unfortunately, but I hope this helps anyone who has this problem in the future.

Last edited by eddy_hunter (2015-05-31 14:59:38)

Offline

#6 2015-09-06 03:03:22

mmjam22
Member
Registered: 2015-05-27
Posts: 5

Re: [SOLVED] Gtk overscroll overlay issue on gtk-theme-flatstudio

eddy_hunter wrote:

Edit:

I just figured out a workaround. Pasting the following into ~/.config/gtk-3.0/gtk.css:

https://gist.github.com/epedroni/03e605 … le-gtk-css

restores the stock Adwaita overshoot look (dark).

To get rid of it completely, use this instead:

https://gist.github.com/epedroni/746d75 … le-gtk-css

It's a bit of a nasty hack, but it solves the issue. I don't know enough about GTK3 theming to fix FlatStudio itself and I don't have the time to look into it right now unfortunately, but I hope this helps anyone who has this problem in the future.

These work fine! Thanks!

Offline

Board footer

Powered by FluxBB