You are not logged in.

#1 2015-06-09 05:55:03

Zygote
Member
Registered: 2013-01-15
Posts: 77

Plasma wont set Chromium as default browser

Im running KDE + Plasma 5 on a number of Arch Linux systems and they all have the same issue. Chromium never sees itself as the default browser and I get the dialog asking me whether I want to make it default every time I start up Chromium.

Anyone have a fix for this?

Cheers!

Offline

#2 2015-06-09 12:15:28

Soukyuu
Member
Registered: 2014-04-08
Posts: 845

Re: Plasma wont set Chromium as default browser

You could try going to settings->applications and change the default for web browser to chromium instead of "use application based on link contents". Also, maybe setting chromium as default for html will make it see itself as default.


[ Arch x86_64 | linux | ThinkPad X220 | Intel Core i5 2540M@3.3Ghz | Intel HD3000 | 16GB RAM | Main, docked to 2 Monitors ]
[ Arch x86_64 | linux-ck-k10 | Custom-built | AMD Phenom II X4@3,5Ghz | nVidia 260 GTX | 12GB RAM | Retired ]
[ Arch x86_64 | linux | Custom-built | Intel Celeron G3920@2,99Ghz | iGPU | 8GB RAM | Home server ]

Offline

#3 2015-06-10 06:58:04

Zygote
Member
Registered: 2013-01-15
Posts: 77

Re: Plasma wont set Chromium as default browser

Soukyuu wrote:

You could try going to settings->applications and change the default for web browser to chromium instead of "use application based on link contents". Also, maybe setting chromium as default for html will make it see itself as default.

Tried that already. Doesnt seem to make much of a difference.

Offline

#4 2015-08-06 22:18:53

chardo137
Member
From: Prineville, Oregon
Registered: 2015-07-04
Posts: 1

Re: Plasma wont set Chromium as default browser

I get the same issue even though Chromium is essentially the only browser. My system also has two Avahi server browsers, and KNetAttach. Even though Chromium says that it is not the default browser, Chromium is what the system uses by default. I suspect that this may be an issue with Chromium. The constant warnings are annoying, but everything else seems to work as it should.


Always remember; No matter where you go, there you are.

                                                          -Buckaroo Banzai

Offline

#5 2015-08-09 00:07:17

Soukyuu
Member
Registered: 2014-04-08
Posts: 845

Re: Plasma wont set Chromium as default browser

I think I just told it to not remind me again, and thus am not seeing the warning anymore.


[ Arch x86_64 | linux | ThinkPad X220 | Intel Core i5 2540M@3.3Ghz | Intel HD3000 | 16GB RAM | Main, docked to 2 Monitors ]
[ Arch x86_64 | linux-ck-k10 | Custom-built | AMD Phenom II X4@3,5Ghz | nVidia 260 GTX | 12GB RAM | Retired ]
[ Arch x86_64 | linux | Custom-built | Intel Celeron G3920@2,99Ghz | iGPU | 8GB RAM | Home server ]

Offline

#6 2015-09-05 03:22:06

jeroenvlek
Member
Registered: 2014-09-16
Posts: 7

Re: Plasma wont set Chromium as default browser

I have the same thing. I tried "Set as default" and "Don't ask again" both, repeatedly. Doesn't work. Smells like a permission issue.

/edit, btw:
Chromium  45.0.2454.85
Plasma 5.4

Last edited by jeroenvlek (2015-09-05 03:25:08)

Offline

#7 2015-09-05 04:28:52

Fixxer
Member
From: Sosnowiec/Poland
Registered: 2011-08-29
Posts: 158
Website

Re: Plasma wont set Chromium as default browser

Settings may be written in two files:

~/.config/mimeapps.list
~/.local/share/applications/mimeapps.list

Post output fo command:

xdg-mime query default x-scheme-handler/http

Last edited by Fixxer (2015-09-05 04:29:17)


marcin82

Offline

#8 2015-09-17 10:46:04

darkbasic
Member
Registered: 2015-06-22
Posts: 28

Re: Plasma wont set Chromium as default browser

$ xdg-mime query default x-scheme-handler/http
chromium.desktop

But it still complains it isn't the default browser. Plasma 5.4.1 here.

Offline

#9 2015-09-20 15:15:25

fxlgore
Member
Registered: 2015-09-05
Posts: 30

Re: Plasma wont set Chromium as default browser

What the hell, this happen me as well :S, and i can see there is no solution yet, anyway i can live with this issue but it's strange.

Offline

#10 2015-09-21 08:40:33

darkbasic
Member
Registered: 2015-06-22
Posts: 28

Re: Plasma wont set Chromium as default browser

There must be a solution, because I don't have this issue on Gentoo: only on Arch.

Offline

#11 2015-09-22 21:26:16

fxlgore
Member
Registered: 2015-09-05
Posts: 30

Re: Plasma wont set Chromium as default browser

Well, fixed to me, i don't know how it happened lol, Just the last 2 days chromium doesn't ask me set as default, hope you too folks.

Offline

#12 2015-10-06 15:57:16

Holden Caulfield
Member
Registered: 2014-11-01
Posts: 5

Re: Plasma wont set Chromium as default browser

I have the same problem after installing kdebase-konqueror. "xdg-settings set default-web-browser chromium.desktop" exits with error code 4 (action failed). "xdg-settings get default-web-browser" returns "kfmclient_html.desktop". Chromium button "Make Chromium the default browser" doesn't work (it's still "Chromium is not currently your default browser").

Last edited by Holden Caulfield (2015-10-06 20:05:57)

Offline

#13 2015-10-06 16:27:11

ksolsim
Member
Registered: 2012-06-26
Posts: 35

Re: Plasma wont set Chromium as default browser

The same problem happens to me every now and then on plasma and gnome shell.

Offline

#14 2015-10-29 08:24:30

mukl
Member
From: Vienna, Austria
Registered: 2008-01-30
Posts: 43

Re: Plasma wont set Chromium as default browser

I deleted/renamed ~/.local/applications/mimeapps.list then the message for setting the default browser was gone.

Seems like Chromium cant override ~/.local/applications/mimeapps.list

EDIT: never mind, didn't work.

Last edited by mukl (2015-10-29 15:08:45)

Offline

#15 2015-11-15 15:25:14

repicajo
Member
Registered: 2015-11-14
Posts: 1

Re: Plasma wont set Chromium as default browser

When I'm looking at the file...

~/.local/share/applications/mimeapps.list

... after my fix, I have to admit it's not the most elegant way.

You can bypass the dialog by Settings -> Applications -> File Associations --> search for "text/html" -> Chromium all the way up -> Apply.

Offline

#16 2016-04-08 20:19:42

ZeroLinux
Member
Registered: 2011-10-07
Posts: 131

Re: Plasma wont set Chromium as default browser

Yes, renaming this file works

mv ~/.local/share/applications/mimeapps.list  ~/.local/share/applications/mimeapps.list.backup 

Offline

#17 2016-10-08 10:04:02

sadesyllas
Member
Registered: 2016-10-08
Posts: 1

Re: Plasma wont set Chromium as default browser

What has worked for me is go to `Settings -> Applications -> File Associations` and there, filter with `html`. Then for the entries `xhtml+xml` and `html`, you can move `Google Chrome` to the first position of the preference order.

Offline

#18 2017-05-18 14:22:13

dpecos
Member
Registered: 2017-04-13
Posts: 2

Re: Plasma wont set Chromium as default browser

sadesyllas wrote:

What has worked for me is go to `Settings -> Applications -> File Associations` and there, filter with `html`. Then for the entries `xhtml+xml` and `html`, you can move `Google Chrome` to the first position of the preference order.

This worked for me! Thx a lot!

Offline

#19 2017-05-18 18:58:09

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,283
Website

Re: Plasma wont set Chromium as default browser

I'm glad it helped dpecos, but please leave old threads as they are:
https://wiki.archlinux.org/index.php/Co … bumping.22

Closed.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

Board footer

Powered by FluxBB