You are not logged in.

#1 2006-03-26 17:50:23

efourseven
Member
Registered: 2005-07-03
Posts: 71

kernel system timer problem

I recently installed Rosegarden midi-sequencer on my arch system. I am having a problem now which I think is linked to the Kernel System Timer being 250HZ in the kernel, when Rosegarden need's it at 1000HZ.

Everytime I start up Rosegarden, I get message that says the kernel system timer is too low. When I record some guitar parts into an audio track, it records fine, but when I go to playback the track I just recorded, Rosegarden gives me another error where I can't play the track back and I have to restart Rosegarden to get sound to playback. This will be an endless cycle of recording and not getting to hear playback from recorded tracks.

Do I have to customize my kernel to set the kernel system timer to 1000HZ? If so, how do I customize that one thing in the kernel? I have not yet built a custom kernel.

Offline

#2 2006-03-26 19:42:17

sh__
Member
Registered: 2005-07-19
Posts: 271

Re: kernel system timer problem

You might want to try out the archck kernel, the timer frequency is set to 1000 Hz in it.

Offline

#3 2006-03-26 21:57:05

efourseven
Member
Registered: 2005-07-03
Posts: 71

Re: kernel system timer problem

Just did that and rosegarden wont start up... It's start screen pops up for about half a minute and it crashes.

EDIT: I just needed to load the snd-seq and snd-seq-midi modules. It starts up now and I am still getting the same problem??

I did a pacman -S kernel26archck

Offline

#4 2006-03-26 22:12:26

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,835

Re: kernel system timer problem

efourseven wrote:

I did a pacman -S kernel26archck

... and presumably amended your grub/lilo setup as required?

Offline

#5 2006-03-26 22:22:45

lumiwa
Member
Registered: 2005-12-26
Posts: 712

Re: kernel system timer problem

tomk wrote:
efourseven wrote:

I did a pacman -S kernel26archck

... and presumably amended your grub/lilo setup as required?

Why is better to set up kernel timer to 250Hz, please (by default)?

Offline

#6 2006-03-26 23:12:48

efourseven
Member
Registered: 2005-07-03
Posts: 71

Re: kernel system timer problem

my lilo.conf now looks like this:

image=/boot/vmlinuz26archck
        label=archCK
        root=/dev/hda4
        read-only
        initrd=/boot/initramfs-2.6.15-archck.img

That should be good right?

Offline

#7 2006-03-26 23:43:35

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,835

Re: kernel system timer problem

As long as you've run lilo after making the changes.

lumiwa wrote:

Why is better to set up kernel timer to 250Hz, please (by default)?

Unless a dev drops in to this thread, you'r more likely to get an answer by submitting a Feature Request for 1000Hz. My understanding is that 250 is set to accommodate Arch as a server.

Offline

#8 2006-03-26 23:56:57

efourseven
Member
Registered: 2005-07-03
Posts: 71

Re: kernel system timer problem

I dont think arckck has it set to 1000HZ because i am still getting this error on startup, and I am running archCK. Is there a way to find out for sure if it's set to 1000HZ in the kernel now?

Offline

#9 2006-03-27 07:03:35

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,835

Re: kernel system timer problem

ArchCK definitely has 1000 set - have a look in /boot/kconfig26archck and you'll see it.

Offline

#10 2006-03-27 09:03:34

efourseven
Member
Registered: 2005-07-03
Posts: 71

Re: kernel system timer problem

Your right, it definetly does have it set to 1000HZ ...

 
# CONFIG_HZ_100 is not set
# CONFIG_HZ_250_NODEFAULT is not set
CONFIG_HZ_1000=y
CONFIG_HZ=1000
CONFIG_PHYSICAL_START=0x100000

Is it definetly using that config file? (kconfig26archck)

Offline

#11 2006-04-01 02:00:17

efourseven
Member
Registered: 2005-07-03
Posts: 71

Re: kernel system timer problem

I have rosegarden working without the error. The problem was I had archck installed, but didn't setup my lilo.conf correctly to load the archck kernel. All is well with that now.

My only problem now is getting jack-audio-connection-kit working in realtime as a user in the audio group. I checked the wiki 'Realtime for Users", and changed the settings like it says... no dice. It seems others are having this same problem. I hope I can get this working soon, I'm so close to have a nice DAW on Arch.

Offline

Board footer

Powered by FluxBB