You are not logged in.

#1 2006-04-02 03:44:08

From: Chicago, IL
Registered: 2006-02-11
Posts: 132

alsa trouble - cant get 2 programs to play sound

im having some trouble here, and ive followed the several wiki pages relating to sound and this is a problem i havent experienced before. ive done several arch installs and have followed the wiki pages to get sound, and then to get multiple applications to use sound. this time i cant get it.

i opened up gaim and rhythmbox in terminals to find out what might be causing some problems, and heres what ive found:

[brian@schi6068dap ~]$ rhythmbox

** (rhythmbox:2261): WARNING **: Could not connect to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory

2261: arguments to dbus_connection_send_with_reply_and_block() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 2752.
This is normally a bug in some application using the D-BUS library.


[brian@schi6068dap ~]$ gaim
ALSA lib pcm_dmix.c:819:(snd_pcm_dmix_open) unable to open slave

i just picked those two as they are two i commonly use. totem and gaim, and totem and rhythmbox combinations also do not work.

i used to have the modules in rc.conf, but i took them out and it worked on my last install, so ive tried those both ways.  i used, and didnt use the asound.conf file from the wiki page, and that didnt change anything. ive left in, and taken out the OSS compatibility stuff in in modprobe.conf, ive messed with the alsamixer, a few alsactl stores after all of these various combinations of changes in files, and cant get it going.

if those small outputs mean anything to anyone, let me know. ive never had this problem before and i havent been able to fix it


Board footer

Powered by FluxBB