You are not logged in.

#1 2014-10-28 13:37:48

yochaigal
Member
From: Boston
Registered: 2011-02-06
Posts: 202

x2go desktop sharing / desktop shadowing help

I have a 64bit Arch setup on my media center.
I'm able to get x2goserver running without any issue; I can correctly login to a new XFCE session without error;  but I cannot get x2go desktop sharing to work (connect to the running profile).

I have:
Setup SSH/using a key on a custom port.
Installed x2goserver & x2godesktopsharing (from AUR). I've created the sqlite database (although I am unable to list users) and added myself to the appropriate group.
I also launched the x2godesktopsharing application as my user from the session I want to connect to.

When I try to login to "local desktop" on x2go client, it says "no available desktop found" and boots me off. If I run th x2godesktopsharing application as root,  I can hook into my root session (but it screws up, for obvious display reasons).  I can switch the profile to an XFCE session and it connects without issue.

Basically, what am I missing? I would love some desktop shadowing!

Thanks

Offline

#2 2015-03-27 16:10:34

guille
Member
Registered: 2015-03-27
Posts: 2

Re: x2go desktop sharing / desktop shadowing help

Hi,
I have exactly the same problem .
I tested some other distributions (debian ) and desktop sharing works with the same versions .
I think it is a right's problem.
Did you find the solution?
thank you
William

Offline

#3 2015-03-27 16:12:25

yochaigal
Member
From: Boston
Registered: 2011-02-06
Posts: 202

Re: x2go desktop sharing / desktop shadowing help

I did not. I actually updated to the latest AUR version last night; tested the same.
I've even posted on their IRC and on the german forum (I don't speak it) and not gotten any response.
You say debian works, though? That's a clue. Must be something with how Arch handles the package. Hmm!
Maybe the AUR maintainer can help?

Offline

#4 2015-03-30 08:03:22

guille
Member
Registered: 2015-03-27
Posts: 2

Re: x2go desktop sharing / desktop shadowing help

I installed the following versions on Debian :
x2goagent: 3.5.0.31
x2godesktopsharing: 3.1.1.2
x2goserver: 4.0.1.19
x2goserver-extensions: 4.0.1.19
x2goserver-xsession: 4.0.1.19

I do not know ARCH, I m beginner.

Thank for help.

Offline

#5 2015-04-15 07:07:31

MilanKnizek
Member
Registered: 2005-12-13
Posts: 78

Re: x2go desktop sharing / desktop shadowing help

As a first step, check that your /etc/group has a group name "x2godesktopshare" and you are member of it. If it does not resolve the problem, read further:

There is a difference between Debian and Arch in the maximal group name length, Arch has a shorter limit. Upstream considers this as Arch specifics, hence it is up to the Arch maintainer to resolve it.

See the sharetray.cpp.patch1, which replaces "x2godesktopsharing" with "x2godesktopshare" group name: it used to work in the past.

I have not tested the recent version of x2godesktopsharing and may have a look at the code in the near future to see if there is anything new related to the group name. I would not oppose any help, should anyone be willing to dig in the code.


--
Milan Knizek
http://knizek.net

Offline

#6 2015-04-17 12:59:38

MilanKnizek
Member
Registered: 2005-12-13
Posts: 78

Re: x2go desktop sharing / desktop shadowing help

It seems that despite the information in 'man groupadd', the max length limit on group name has been relaxed up to 32 from the original 16.

in x2godesktopsharing 3.1.1.2-2, I have removed the Arch specific patch for 'x2godesktopsharing' to 'x2godesktopshare' group renaming, which was in place to comply with the old limit. Hence now it should be the same as in upstream.

Please upgrade, retest and let me know if it does not work.

P.S. The reason why it stopped working in prior version could be that the relatively recently added script /usr/bin/x2gostartagent (part of x2goserver package) also checks for existence of user's membership in 'x2godesktopsharing' group, which obviously had to fail until now.


--
Milan Knizek
http://knizek.net

Offline

#7 2015-04-17 15:53:49

yochaigal
Member
From: Boston
Registered: 2011-02-06
Posts: 202

Re: x2go desktop sharing / desktop shadowing help

I upgraded, I added my user to the group, logged out, restarted the service & launched x2godesktopsharing. Same issue.

Offline

#8 2015-04-17 17:07:26

MilanKnizek
Member
Registered: 2005-12-13
Posts: 78

Re: x2go desktop sharing / desktop shadowing help

It works for me just fine. (server: x86_64, client Lubuntu arm).

I am not sure I fully understand your first post, this is how I tested it:

Let's have users foo and bar, both have user account on the server.
The server's /etc/group lists _both_ foo and bar as users of group "x2godesktopsharing".

User foo is currently logged on local console of the server (DISPLAY is :0).
User foo starts x2godesktopsharing (e.g. from xterm to see the std out) - an icon should appear in his systray. The icon has a blue frame and a green "check" mark.

User bar tries to connect to the server from client, the session type is "Local desktop" - a list of server's local desktops should be displayed (i.e. just that one run by user foo on DISPLAY :0).
User bar can choose "View Only" after highligting the single item of "foo on DISPLAY :0".

User foo is asked if he agrees with the incoming connection and can "grant" the user bar to access his desktop also in the future.

That's it.

P.S. You may also want to test to connect to the server as the user foo for connection type "local desktop": in such a case, x2godesktopsharing does not even have to run and the desktop should be shadowed to client.


--
Milan Knizek
http://knizek.net

Offline

#9 2015-04-17 17:50:38

yochaigal
Member
From: Boston
Registered: 2011-02-06
Posts: 202

Re: x2go desktop sharing / desktop shadowing help

I have it running as a daemon via systemd; which runs as root. I run x2godesktopsharing as my user, and the "granted" portion is faded out.

Offline

#10 2015-04-17 18:59:47

MilanKnizek
Member
Registered: 2005-12-13
Posts: 78

Re: x2go desktop sharing / desktop shadowing help

The only daemon I am aware of is probably the x2goserver - technically, this does not have any impact on whether x2go client can connect or not, because the daemon only takes care about "cleaning" of stale sessions.

Untill you grant some user a permanent connection approval (this is done during the first connection by that user), the option "Granted" is greyed out. This is standard behaviour.

As which user do you try to connect to the local desktop running on the server? The same? If so, it should work even if you do not run x2godesktopsharing at all. (See Misc notes on x2go.org wiki re. x2godesktopsharing.)

Anyway:
Try to add a new user to your server (see Arch Linux wiki).
Test if you can connect from a client computer to newuser@server through standard ssh 'myuser@client$ ssh newuser@server'.
Add the new user to x2godesktopsharing group on the server 'root@server# gpasswd -a newuser x2godesktopsharing'.
And finally try to connect with x2go client from the client computer as "newuser@server" with connection type "local desktop".

P.S. If you want help, pls be more specific. It is hard to guess what you did and what not and on which computer.


--
Milan Knizek
http://knizek.net

Offline

#11 2015-04-17 20:16:07

yochaigal
Member
From: Boston
Registered: 2011-02-06
Posts: 202

Re: x2go desktop sharing / desktop shadowing help

Sorry, I'll try to be more specific.

On the server: I have

/usr/bin/perl /usr/sbin/x2gocleansessions - running as root.

And x2godesktopsharing is running as my regular user.

I regularly SSH into this server, and I use VNC with SSH tunneling every day.
I have already created a new user and was unsuccessful, but that was before this update.
I am unable to approve users from the x2godesktopsharing application on the desktop.

On my client, I am using "X2go client" to connect. I am able to connect to "new" desktops (e.g. XFCE) with my user with NO problem. When I use the "local desktop" option, my client receives the errors I mentioned in the first post.

Offline

#12 2015-04-18 06:53:10

MilanKnizek
Member
Registered: 2005-12-13
Posts: 78

Re: x2go desktop sharing / desktop shadowing help

Try different than "my user" for x2go connection.
Despite my past experience and x2go wiki, the x2godesktopsharing behaviour seems to be modified now and I cannot access the running local session of the same user, which connects remotely through x2go.


--
Milan Knizek
http://knizek.net

Offline

#13 2015-04-18 19:01:16

yochaigal
Member
From: Boston
Registered: 2011-02-06
Posts: 202

Re: x2go desktop sharing / desktop shadowing help

I create a new user (with a home directory) and confirmed I could SSH as that user.
No change - I still get the "no accessible desktop found" error.

When I launch the x2godesktopsharing application from my server, it looks like:





-- mod edit: read the Forum Etiquette and only post thumbnails http://wiki.archlinux.org/index.php/For … s_and_Code [jwr] --

Offline

#14 2015-04-20 20:34:45

yochaigal
Member
From: Boston
Registered: 2011-02-06
Posts: 202

Re: x2go desktop sharing / desktop shadowing help

Sorry, I should have posted a thumbnail:
image356884.png

Last edited by yochaigal (2015-04-20 21:16:43)

Offline

#15 2015-04-20 20:41:46

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,812

Re: x2go desktop sharing / desktop shadowing help

yochaigal wrote:

Sorry, I should have posted a link (not sure how to create a thumbnail here):

Like this: (remove the spaces I added in oder to break the tags)

[ url=/path/to/the/big/picture.jpg][ img]/path/to/the/smaller/thumbnail/picture.jpg[ /img][ /url]

That will display the thumbnail and, if the reader clicks on it, will open the big picture.  People on slow or metered connections appreciate this smile


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#16 2015-04-23 03:44:37

javum
Member
Registered: 2009-07-31
Posts: 18

Re: x2go desktop sharing / desktop shadowing help

I have the same problem (no available desktop found). And I posted this bug: http://bugs.x2go.org/799
So I need to edit /bin/x2golistdesktops and replace

ss -lxu

by

ss -x

Offline

#17 2015-04-23 11:42:29

yochaigal
Member
From: Boston
Registered: 2011-02-06
Posts: 202

Re: x2go desktop sharing / desktop shadowing help

javum's suggestion worked for me.

Offline

#18 2015-06-30 18:38:06

kullfar
Member
Registered: 2013-04-22
Posts: 2

Re: x2go desktop sharing / desktop shadowing help

just "ss -lx" is enough
thanks javum

I think it will be great to have such patch in AUR package

Last edited by kullfar (2015-06-30 18:40:52)

Offline

#19 2015-07-05 20:39:29

MilanKnizek
Member
Registered: 2005-12-13
Posts: 78

Re: x2go desktop sharing / desktop shadowing help

@kullfar and others: the patch affects x2goserver, not x2godesktopsharing. If you believe it is Arch Linux specific, report the bug here:

https://www.archlinux.org/packages/extr … 2goserver/


--
Milan Knizek
http://knizek.net

Offline

Board footer

Powered by FluxBB