You are not logged in.

#1 2015-07-09 06:56:04

Marvix
Member
Registered: 2013-10-08
Posts: 117

[SOLVED] Mounted TrueCrypt files and folders in Greek are shown as ?

When I mount TrueCrypt files, the contained files, in them, with greek characters are shown as ?

My loclaes are (with the locale -a)

C
el_GR.utf8
en_GB.utf8
en_US.utf8
POSIX

How can it be fixed the issue?

Last edited by Marvix (2017-11-02 17:12:38)

Offline

#2 2015-07-09 08:12:01

headkase
Member
Registered: 2011-12-06
Posts: 1,883

Re: [SOLVED] Mounted TrueCrypt files and folders in Greek are shown as ?

What is the file-system of the TrueCrypt container?  If it is say an NTFS volume then you may need additional encodings.

Also, TrueCrypt is depreciated, you should use something like: VeraCryptAUR

The reason TrueCrypt was depreciated is widely believed to be because unnamed agencies were trying to insert a backdoor into the program.  The depreciation was a "canary," or a signal that that had happened but not officially stated.  Google it.

Edit: VeraCrypt is a fork of the TrueCrypt code-base that was started after TrueCrypt was depreciated.  VeraCrypt is compatible with TrueCrypt.  Read its documentation for details.

Last edited by headkase (2015-07-09 08:14:34)

Offline

#3 2015-07-09 13:10:01

Marvix
Member
Registered: 2013-10-08
Posts: 117

Re: [SOLVED] Mounted TrueCrypt files and folders in Greek are shown as ?

The filesystem is FAT. The files where created on Windows 7 OS.

I've tried both VeraCrypt and CipherShed and I've had the same results like TrueCrypt.

I think it have be with encoding or font issues.

Offline

#4 2015-07-09 14:02:56

headkase
Member
Registered: 2011-12-06
Posts: 1,883

Re: [SOLVED] Mounted TrueCrypt files and folders in Greek are shown as ?

It is very likely that the encoding isn't being translated properly then.  Try this potential solution:

http://askubuntu.com/questions/31863/cr … -truecrypt

And dump TrueCrypt - it will never be updated again - and use VeraCrypt as a drop-in replacement.

Offline

#5 2015-07-09 14:29:32

Marvix
Member
Registered: 2013-10-08
Posts: 117

Re: [SOLVED] Mounted TrueCrypt files and folders in Greek are shown as ?

I've tried what you find and posted and it worked.

Thank you very much.

P.S. The TrueCrypt incident has drown too much attention to the public and mostly to privacy-conscious people. No one knows really what was all this. I hope the replacement forks will not be a backdoor part of the agency.

The solution in case the website is down or be removed.

The truecrypt volume you created was most likely formatted as FAT32. When mounting FAT in Linux default charset is iso8859-1, although long filenames in Windows are stored on disk in Unicode format.

Solution: specify iocharset=utf8 in Truecrypt for Mount options (globally in preferences or for specific volume in advanced options).

Last edited by Marvix (2015-07-09 14:31:36)

Offline

#6 2015-07-09 14:33:02

headkase
Member
Registered: 2011-12-06
Posts: 1,883

Re: [SOLVED] Mounted TrueCrypt files and folders in Greek are shown as ?

Right on, you're welcome.

Remember to mark your post [Solved] by editing the first post in this thread and pre-pending "[Solved]" without the quotes to the title.

smile

Offline

Board footer

Powered by FluxBB