You are not logged in.

#1 2015-07-01 08:40:05

flying sheep
Member
Registered: 2012-02-29
Posts: 86

Help with finally getting those debug symbols built

Hi,

i filed FS#38755 to basically fix FS#20921, i.e. to get debug symbol packages built.

but apparently nobody is interested in helping KDE and other projects getting useful bug reports.

is there anyone who knows how to approach this?

Last edited by flying sheep (2015-07-15 07:49:46)

Offline

#2 2015-07-16 00:29:56

davidm
Member
Registered: 2009-04-25
Posts: 370

Re: Help with finally getting those debug symbols built

I don't know.  I largely switched to gentoo to be able to get debugging symbols easily.  I believe you would need to start your own debugging repo where the packages would be compiled as they are officially except with the exception of debugging symbols being available.  You could probably just offer the KDE packages like this if you wanted.

About every six months someone does come along who cares about the issue however for one reason or another it never gets completed by anyone.  In my case it would have been a ton of work and time.  I also just have one core 2 quad so compiling every kde package once a week would be a big chore.
https://bbs.archlinux.org/viewtopic.php?id=174250

I hope you can be the one to get it done. smile

Offline

#3 2015-07-16 00:59:44

Allan
Member
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,939
Website

Re: Help with finally getting those debug symbols built

We need two things done:
1) devtools: alter to build debug packages by default and sign/upload them to our server with the other packages
2) dbscripts: recognise a debug package and add it to the foo-debug repo when the main package is being added to foo.

I don't think either of these would be overly difficult to implement.  It is just altering some bash scripts...

Offline

Board footer

Powered by FluxBB