You are not logged in.

#1 2015-06-29 16:15:21

wba072
Member
Registered: 2010-11-11
Posts: 33

[SOLVED] Unlocking with LightDM/Light-locker results in blank screen

Running Arch on Acer C720 Chromebook with xfce and lightdm. After some time when the system is idle the screen locks and then turns off. This part is normal. However, when I move the mouse or press any keys the LightDM gtk greeter shows up and I log in, and then the screen goes blank again. I can't seem to do anything at this point. If I let it sit for a little while I'll see that the screen locks again, and, once again, I am able to login but get a black screen again.

This effect occurs whether I manually lock the screen, or if I allow the screen to turn off and lock, or even if I close the laptop lid and have it suspend.

This behavior didn't start until today. Before today, unlocking with LightDM brought me back to xfce.

Edit: The screen doesn't just turn blank. It seems to be turning off.

Edit2: I'm using light-locker. This may be the culprit.

Last edited by wba072 (2015-07-01 00:02:10)

Offline

#2 2015-06-30 18:23:06

wba072
Member
Registered: 2010-11-11
Posts: 33

Re: [SOLVED] Unlocking with LightDM/Light-locker results in blank screen

Seems to be bug: https://bugs.launchpad.net/ubuntu/+sour … ug/1259339

I just ended up uninstalling lightdm and light-locker and using slock instead.

Offline

#3 2015-07-02 18:08:55

Photor
Member
Registered: 2013-05-28
Posts: 11

Re: [SOLVED] Unlocking with LightDM/Light-locker results in blank screen

Hello,

Lenovo Thinkpad with Arch Linux (Xfce and lightdm) here. Same behaviour after update last days. I downgraded upower package (to 0.99.2-2) which "cured" it. Package set to "hold" for the moment.

Ciao,

Photor

Offline

#4 2015-07-24 21:01:23

henriquemaia
Member
From: Recife, PE
Registered: 2015-07-24
Posts: 1
Website

Re: [SOLVED] Unlocking with LightDM/Light-locker results in blank screen

Hope this helps someone with the same issue. I have found by accident that one can workaround this issue by issuing the command:

xset dpms force off

.
How? By setting a shortcut. If the backlight refuses to start, you just press the shortcut, type something (the password, for instance, in the case of screen locking) or move the mouse around and the light will be on again.

Not a perfect solution, but it works, at least in my case (a Dell Inspiron 3342).

Offline

#5 2015-07-27 17:20:36

jonnybel
Member
Registered: 2011-11-21
Posts: 20

Re: [SOLVED] Unlocking with LightDM/Light-locker results in blank screen

I have the same issue and I can confirm that the workaround given by henriquemaia has worked for me.

A temporary solution though, I hope the bug gets fixed soon (not sure if the source of the problem is light-dm, light-locker or upower, as said above).

Offline

#6 2015-11-01 16:51:24

rohansftw
Member
Registered: 2011-12-09
Posts: 8

Re: [SOLVED] Unlocking with LightDM/Light-locker results in blank screen

I have the same problem and I also confirm the provided workaround works for me .
Strangely this problem happen on my new laptop , my old thinkpad runs fine .

Offline

#7 2015-11-15 19:38:38

msierks
Member
Registered: 2015-11-15
Posts: 1

Re: [SOLVED] Unlocking with LightDM/Light-locker results in blank screen

Same problem with my Lenovo T450s. henriquemaia's workaround works for me as well.

Edit: downgrading upower to 0.99.2-2 did not work for me.

Last edited by msierks (2015-11-15 19:40:04)

Offline

#8 2015-11-24 17:42:44

myk1985
Member
Registered: 2015-11-24
Posts: 5

Re: [SOLVED] Unlocking with LightDM/Light-locker results in blank screen

Hi guys,

I have the same or a very similar issue with my Acer ES1-111 equipped with Intel HD Graphics (Bay Trail).
My system is running XFCE, LightDM, and Light Locker.

As far as I understand, this is what happens:
- The session is locked by Light Locker for any reason (E. g., being idle)
- To lock the session Light Locker switches to another vt (virtual terminal), starts X server on that vt and starts an instance of LightDM in that X server.
(As a side note, I'm not sure why Light Locker has to performs vt switching to lock a session but it is just the way Light Locker works -- take a look at the first comment on this issue https://bugs.launchpad.net/ubuntu/+sour … g/1336647)
- When the user unlocks the session Light Locker shuts down the X server it started (as described above).
- On the X server shutdown a bug in X server's intel video driver kicks in -- "Screen turned off after X server exits" (https://bugs.launchpad.net/ubuntu/+sour … ug/1501941 and https://bugs.freedesktop.org/show_bug.cgi?id=92457)


One workaround is to create

/etc/X11/xorg.conf.d/20-intel.conf

with the following content

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod" "uxa"
EndSection

Take a look at https://wiki.archlinux.org/index.php/Intel_graphics for details.

Please notice, I actually had this file autogenrated for me and it contains many more sections and options than is shown above! So please be careful if you decide to just copy the above example as is.

But the key here is to set the "AccelMethod" option's value to "uxa" instead of "sna". The "sna" value is used by the driver by default (even if it is not explicitely set in the config).

This works very well for me. I don't have to press any shortcut to enable the screen when I unlock my session. I also haven't noticed any side effects from using the "uxa" acceleration method. Although admittedly it hasn't been a very long time since I switched to "uxa".

Another workaround may be adding Ubuntu's patch (see the link to Launchpad's bug 1336647 for details) to the deriver package, rebuilding it yourself, and installing it with pacman -U. But I did not try this myself.

Hope this helps.

Last edited by myk1985 (2015-11-24 18:11:06)

Offline

#9 2015-11-28 08:57:44

mruj
Member
Registered: 2015-11-28
Posts: 2

Re: [SOLVED] Unlocking with LightDM/Light-locker results in blank screen

I solved the issue with solution by myk1985.

Added 20-intel.conf file with the same content, and now I'm able to log off / log in again.

Thanks!

Offline

Board footer

Powered by FluxBB