You are not logged in.

#1 2015-07-21 02:16:35

tyudemetry
Member
Registered: 2015-07-21
Posts: 5

Problems with the Installation ygopro on Arch Linux

I tried to install ygopro game on my Arch Linux, but this messsenge is shown when I run the executable file "ygopro64":

 ./ygopro64: error while loading shared libraries: liblua5.2.so.0: cannot open shared object file: No such file or directory 

I installed lua (pacman -S lua), but the problem continued.

Could someone help me please?

Last edited by tyudemetry (2015-07-21 02:27:14)

Offline

#2 2015-07-21 02:45:05

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,046
Website

Re: Problems with the Installation ygopro on Arch Linux

What does "tried to install" mean? How? What steps did you take?


Moving to AUR Issues...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2015-07-21 03:13:43

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: Problems with the Installation ygopro on Arch Linux

Offline

#4 2015-07-25 18:31:02

RaphaelLamperouge
Member
Registered: 2015-07-25
Posts: 16

Re: Problems with the Installation ygopro on Arch Linux

sudo pacman -S lua52
cd /usr/lib
sudo ln -s liblua5.2.so liblua5.2.so.0
And it's installed.
It will install the lua package you actually need (you can pacman -Rns lua) and symlink it to the library YGOPRO is looking for. ((1))

But you're probably missing gnutls, to check head to your ygopro folder and

ldd ygopro64
This will check if you're missing any libraries

If it says it can't find gnutls, you'll have to get a package from the AUR, unfortunately there's an issue with the checksums...

cd /tmp
wget https://aur.archlinux.or...ls/libcurl-gnutls.tar.gz
tar xvf libcurl-gnutls.tar.gz
cd libcurl-gnutls
makepkg -S --skipchecksums --skippgpcheck
makepkg -i --skipchecksums --skippgpcheck
This will download the AUR package and install it without security checks, it's your account and risk but I don't think there's any problem, the compile flags were safe and the source link was correct.

With this, I managed to install YGOPRO


((1)) -- I'm suffering from some graphical glitches, it's probably the liblua hack, it's a bit annoying. I also can't play on fullscreen but apparently it's because I'm missing something.
Back to top

Offline

#5 2015-07-25 22:15:59

fsckd
Forum Fellow
Registered: 2009-06-15
Posts: 4,173

Re: Problems with the Installation ygopro on Arch Linux

Hi tyudemetry, please do not cross-post. I assume you prefer Poruguese and am closing this thread. If you prefer English, please let me or one of the other moderators know and we'll reopen this thread (and close the other). Good luck. Continue here.


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

Board footer

Powered by FluxBB