You are not logged in.

#1 2015-05-19 21:19:35

From: Valencia (Spain)
Registered: 2013-03-02
Posts: 11

Clevo P650SE - No headphone sound


I have ArchLinux up to date on my Clevo P650SE model laptop (dual boot with Win 8.1). The headphone jack does not appear to work (sound continues through the speakers) in ArchLinux only.

Running alsamixer shows two cards:

- HDMI (Intel Haswell HDMI) 
- PCH (Realtek ALC892)

PCH has the following items:

- Master
- Speaker
- Mic
- Mic Boost
- S/PDIF Default PCM
- Auto-Mute Mode

Running amixer gives:

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Front Left: Playback 39328 [60%] [on]
  Front Right: Playback 39328 [60%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 1 [0%] [on]
  Front Right: Capture 1 [0%] [on]

Running aplay -l:

**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Running aplay -L:

    Discard all samples (playback) or generate zero samples (capture)
    PulseAudio Sound Server
    Default ALSA Output (currently PulseAudio Sound Server)
    HDA Intel HDMI, HDMI 0
    HDMI Audio Output
    HDA Intel HDMI, HDMI 1
    HDMI Audio Output
    HDA Intel HDMI, HDMI 2
    HDMI Audio Output
    HDA Intel PCH, ALC892 Analog
    Default Audio Device
    HDA Intel PCH, ALC892 Analog
    Front speakers
    HDA Intel PCH, ALC892 Analog
    2.1 Surround output to Front and Subwoofer speakers
    HDA Intel PCH, ALC892 Analog
    4.0 Surround output to Front and Rear speakers
    HDA Intel PCH, ALC892 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
    HDA Intel PCH, ALC892 Analog
    5.0 Surround output to Front, Center and Rear speakers
    HDA Intel PCH, ALC892 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    HDA Intel PCH, ALC892 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    HDA Intel PCH, ALC892 Digital
    IEC958 (S/PDIF) Digital Audio Output

Running lsmod | grep snd:

snd_hda_codec_realtek    65536  1 
snd_hda_codec_generic    65536  1 snd_hda_codec_realtek
snd_hda_codec_hdmi     53248  1 
snd_hda_intel          28672  15 
snd_hda_controller     28672  1 snd_hda_intel
snd_hda_codec         114688  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              16384  1 snd_hda_codec
snd_pcm                90112  7 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_timer              28672  1 snd_pcm
snd                    69632  35 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
soundcore              16384  2 snd,snd_hda_codec

Does anyone have any ideas how to fix this?

I have tried many things, but I can't fix... sad


Last edited by Visp (2015-05-19 21:21:53)


#2 2015-08-26 03:43:33

Registered: 2015-08-26
Posts: 1

Re: Clevo P650SE - No headphone sound

Hi Visp,

I just registered me an account here to answer you.
Maybe you already fixed that but I struggled with the same problem in Linux Mint with my Clevo P655SE and it took me some time...
So my hint is: Did you try the S/PDIF jack? ;-)

I love my Clevo banging my headset <3



#3 2015-08-26 05:46:51

From: Kentucky
Registered: 2003-07-07
Posts: 19

Re: Clevo P650SE - No headphone sound

I also recently picked up a P650SE and can't get the amplified headphone jack working under Linux.

The line out does work, but it is not very powerful, and almost certainly designed to drive several-hundred-ohm line level loads, not low-impedance devices like headphones, so that isn't a good long-term solution.

It's pretty clear ALSA has no idea about the amplifier, there is an init headphone script (also in AUR) that supports some recent Clevo headphone amps, and comes with/acts as some documentation that I'm taking hints from, but does not seem to work with this model.

If I follow the suggestion to set


in my kernel line I can see a "SMBus I801 adapter at f040" hanging off the internal i2c bus (via `cat /sys/bus/i2c/devices/i2c-*/name` or such) which is apparently likely to be the headphone amplifier.  I can pass SMBus traffic to it and get responses back but unfortunately it doesn't seem to respond to the set of commands init headphone tries, and I haven't found any information on the device to experiment further.

There is also a small annoyance that the version of dmidecode Arch ships warns and exits uncleanly on SMBIOS >2.7 systems, (These are 2.8), and it takes a little fussing to get init headphone to run anyway.

I need to shove a Windows install on the extra SSD I put in to see if I can sniff out what the vendor-provided drivers there do, but haven't yet had time.   Out of curiosity, in dmidecode, what is your Product Name field?  Mine identifies as a "P65_P67SE."

Last edited by PAPPPmAc (2015-08-26 05:58:43)


#4 2015-08-30 15:31:12

From: Kentucky
Registered: 2003-07-07
Posts: 19

Re: Clevo P650SE - No headphone sound


0. Install alsa-tools from extra, and init-headphone from AUR.

1. Set`acpi_enforce_resources=lax`in the kernel line to get the i2c amplifier controller onto the internal smbus.  This takes a reboot, but so does a later step, so keep reading.

2.  Find the headphone port, on my P650SE, the headphone jack sense wire is attached to pin 0x1b.  This is done by running `sudo hda-verb /dev/snd/hwC0D0 0xNN GET_PIN_SENSE 0` on every unconnected pin (NN) listed in hdajackretask, looking for a change with the headphones unplugged and plugged into the headphone jack. 

3. Armed with that knowledge, use hdajackretask to set Pin 0x1b (or whatever you found in a different model) to put channel group 3 channel Front (default except for attaching it to headphones, this worked for me, I suspect some other configurations would also work).  You will have to check the "Show unconnected pins" and "Advanced override" scary switches in hdajackretask to do so.  I had to "Install boot override" and reboot to apply, even though fuser couldn't find any processes touching my audio control devices, hdajackretask whined about devices in use when trying to apply on the fly - if it works you'll want to "Install boot override" anyway to keep it working.  You will get a new headphone control in alsamixer at this point, and plugging in the headphones will cut off the speakers, but the headphones still won't work.

4. Run the aforementioned `init-headphone -f` (-f because of dmidecode whinging about versions and printing garbage in the model check string comparison) to turn on the headphone amp, our amplifier does accept the same commands as the ones other recent Clevo models.

5. Crisp, powerfully driven sound on the headphone port!

The AUR version of init-headphone comes with an init-headphone.service systemd unit that will automagically run it on boot and wake when enabled, it'll need the -f edited in to the ExecStart line because of the dmidecode problem.

Last edited by PAPPPmAc (2015-08-30 15:50:08)


Board footer

Powered by FluxBB