You are not logged in.

#1 2015-08-23 14:02:32

rehono
Member
Registered: 2015-06-15
Posts: 16

[SOLVED] xfce4 polkit not working

I read the polkit and xfce wiki a couple of times and I still can't figure out what the problem is.

It says that in xfce everything should work automagically, unfortunately that is not true in my case.



Under Settings Manager > Session and Statup > Application Autostart
PolicyKit Authentication Agent is checked to autostart.

I also tried xfce-polkit-git from aur and during install removed polkit-gnome because of conflict.
It worked great after installation but after reboot I get error dialog and it stops working again.
The error just says "error xfce policykit agent" and I clicked ok on the dialog.
The error did not appear when I unchecked /usr/lib/xfce-polkit/xfce-polkit in xfce autostart menu but I still didn't username/password popup when starting gparted from menu or trying to mount hdd (w/ gvfs) within thunar.
I went back to polkit-gnome, still not working but no error popup on login.

In the past I haven't had this issue and I don't know why it started with this install of arch.
From searching everywhere I can't find a solution. Maybe I need to configure something but I don't know what.

systemctl status polkit.service
● polkit.service - Authorization Manager
   Loaded: loaded (/usr/lib/systemd/system/polkit.service; static; vendor preset: disabled)
   Active: active (running) since Fri 2015-08-21 10:11:58 PDT; 1 day 20h ago
     Docs: man:polkit(8)
 Main PID: 511
   CGroup: /system.slice/polkit.service
           └─511 n/a

Aug 21 10:50:33 corn polkitd[511]: Registered Authentication Agent for unix-process:3121:244360 (system bus name :1.27 [/usr/bin/pkttyagent --notify-fd 5 --fallback], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.utf8)
Aug 21 10:50:33 corn polkitd[511]: Unregistered Authentication Agent for unix-process:3121:244360 (system bus name :1.27, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.utf8) (disconnected from bus)
Aug 21 10:50:37 corn polkitd[511]: Registered Authentication Agent for unix-process:3187:244729 (system bus name :1.28 [/usr/bin/pkttyagent --notify-fd 5 --fallback], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.utf8)
Aug 21 10:50:37 corn polkitd[511]: Unregistered Authentication Agent for unix-process:3187:244729 (system bus name :1.28, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.utf8) (disconnected from bus)
Aug 21 10:50:44 corn polkitd[511]: Registered Authentication Agent for unix-process:2224:142928 (system bus name :1.29 [pkexec --user root gparted], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Aug 21 10:50:47 corn polkitd[511]: Unregistered Authentication Agent for unix-process:2224:142928 (system bus name :1.29, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
Aug 21 10:50:47 corn polkitd[511]: Operator of unix-process:2224:142928 FAILED to authenticate to gain authorization for action org.archlinux.pkexec.gparted for unix-process:2224:142928 [bash] (owned by unix-user:b)
Aug 21 10:50:57 corn polkitd[511]: Registered Authentication Agent for unix-process:2224:142928 (system bus name :1.30 [pkexec --user root gparted], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Aug 21 10:50:58 corn polkitd[511]: Unregistered Authentication Agent for unix-process:2224:142928 (system bus name :1.30, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
Aug 21 10:50:58 corn polkitd[511]: Operator of unix-process:2224:142928 FAILED to authenticate to gain authorization for action org.archlinux.pkexec.gparted for unix-process:2224:142928 [bash] (owned by unix-user:b)
/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1
(polkit-gnome-authentication-agent-1:7121): polkit-gnome-1-WARNING **: Unable to determine the session we are in: No session for pid 7121
gparted_polkit
Error executing command as another user: No authentication agent found.

Last edited by rehono (2015-09-06 21:28:54)

Offline

#2 2015-08-23 15:23:32

toz
Member
Registered: 2011-10-28
Posts: 458

Re: [SOLVED] xfce4 polkit not working

IIRC, some time ago, there was an issue where gnome-polkit changed and would only autostart in gnome. This caused issues for non-gnome users. It was suggested to use lxpolkit as an alternative. Since then, lxpolkit has been absorbed into the lxsession package.

I currently have lxsession installed and it provides lxpolkit which is autostarted in the startup applications and provides an authentication agent.

Offline

#3 2015-08-23 15:30:04

Alad
Wiki Admin/IRC Op
From: Bagelstan
Registered: 2014-05-04
Posts: 2,239
Website

Re: [SOLVED] xfce4 polkit not working

gnome-polkit works for me under XFCE, both with xinitrc and SDDM. How do you login to your session?


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby

Offline

#4 2015-08-23 17:00:12

rehono
Member
Registered: 2015-06-15
Posts: 16

Re: [SOLVED] xfce4 polkit not working

toz wrote:

IIRC, some time ago, there was an issue where gnome-polkit changed and would only autostart in gnome. This caused issues for non-gnome users. It was suggested to use lxpolkit as an alternative. Since then, lxpolkit has been absorbed into the lxsession package.

I currently have lxsession installed and it provides lxpolkit which is autostarted in the startup applications and provides an authentication agent.


I will try out lxpolkit and report back. edit: i get "polkit no session for pid" error on login. So not working.


Alad wrote:

gnome-polkit works for me under XFCE, both with xinitrc and SDDM. How do you login to your session?

I use lightdm.

edit:
comment #1 on launchpad bug report suggests:

Djordje Marjanovic (djordje-m) wrote:

I filed this bug because I have tried all known workarounds, but failed to resolve the problem:

- appended to /etc/pam.d/lightdm
       session required pam_loginuid.so
       session required pam_systemd.so

- ran 'sudo pam-auth-update --force'

- reinstalled policykit-1 and libpam packages

- reinstalled 'sudo' package

- removed Skype

I don't know what arch equivalent of pam-auth-update --force is.

Last edited by rehono (2015-08-24 08:16:53)

Offline

#5 2015-09-03 13:38:27

qwerty12
Member
From: London
Registered: 2011-06-20
Posts: 34

Re: [SOLVED] xfce4 polkit not working

On the ArchWiki Security page, there's a section on a kernel feature called hidepid. If you followed the instructions there, undo the steps.

Offline

#6 2015-09-03 14:17:18

Chazza
Wiki Maintainer
From: United Kingdom
Registered: 2013-06-02
Posts: 506

Re: [SOLVED] xfce4 polkit not working

toz wrote:

IIRC, some time ago, there was an issue where gnome-polkit changed and would only autostart in gnome. This caused issues for non-gnome users. It was suggested to use lxpolkit as an alternative. Since then, lxpolkit has been absorbed into the lxsession package.

I currently have lxsession installed and it provides lxpolkit which is autostarted in the startup applications and provides an authentication agent.

That's not the issue here. The polkit-gnome autostart file was indeed removed upstream some time ago but the Arch xfce4-session package now provides an autostart file for polkit-gnome instead - that's why the wiki says everything should work automagically.

Last edited by Chazza (2015-09-03 14:24:59)

Offline

#7 2015-09-03 14:44:56

toz
Member
Registered: 2011-10-28
Posts: 458

Re: [SOLVED] xfce4 polkit not working

Chazza wrote:
toz wrote:

IIRC, some time ago, there was an issue where gnome-polkit changed and would only autostart in gnome. This caused issues for non-gnome users. It was suggested to use lxpolkit as an alternative. Since then, lxpolkit has been absorbed into the lxsession package.

I currently have lxsession installed and it provides lxpolkit which is autostarted in the startup applications and provides an authentication agent.

That's not the issue here. The polkit-gnome autostart file was indeed removed upstream some time ago but the Arch xfce4-session package now provides an autostart file for polkit-gnome instead - that's why the wiki says everything should work automagically.

Yes. The desktop file is included as a patch in the Arch package. I'm running the git version of Xfce and upstream's xfce4-session doesn't have that addition (I've been using lxpolkit since the polkit-gnome autostart file was removed). My bad.

Offline

#8 2015-09-06 21:26:25

rehono
Member
Registered: 2015-06-15
Posts: 16

Re: [SOLVED] xfce4 polkit not working

qwerty12 wrote:

On the ArchWiki Security page, there's a section on a kernel feature called hidepid. If you followed the instructions there, undo the steps.


Thank you.

Last edited by rehono (2015-09-06 21:29:53)

Offline

Board footer

Powered by FluxBB