You are not logged in.

#1 2006-04-10 00:58:38

occam
Member
From: Melbourne, Australia
Registered: 2005-01-16
Posts: 82

Installer error? - cannot find files

I am running Arch 0.7 on one computer, and was going to install it on another.  However, the CDROM installation stopped with the messages
error: /mnt/var/lib/pacman/current/kbd-12.1-1/desc: Nosuch file o
error: /mnt/var/lib/pacman/current/kbd-12.1-1/desc: Nosuch file o
error: cannot resolve dependencies for "autoconf":
mawk is not in the package set

I was loading 'base' only, all packages.  What I have tried so far:
check MD5sum - is ok
reburn the arch 07 CD - no difference
download, MD5check and burn the base-only version - no difference
use another CDreader - no difference

Since I KNOW that it all works ok (or I would not have arch running on one computer) I am stumped.  I would have suspected a hardware error if the target computer was not running an old (10.1) Slackware ok, and has shown no strange symptoms, nor has any tests shown any problems.

Any suggestions of what to do next?


Moduli non sunt multiplicandi praeter necessitatem

Offline

#2 2006-04-10 03:32:00

McQueen
Member
From: Arizona
Registered: 2006-03-20
Posts: 382

Re: Installer error? - cannot find files

What happens if you install the base from the FTP instead of CD?


/path/to/Truth

Offline

#3 2006-04-10 05:33:31

occam
Member
From: Melbourne, Australia
Registered: 2005-01-16
Posts: 82

Re: Installer error? - cannot find files

That worked.  Thanks!
(but why the heck did not CD install work..)


Moduli non sunt multiplicandi praeter necessitatem

Offline

#4 2006-04-10 13:19:20

McQueen
Member
From: Arizona
Registered: 2006-03-20
Posts: 382

Re: Installer error? - cannot find files

IMO that is about the only assured method to install Arch right now due to the amount of changes in the the package repos. This is somewhat unfortunate since it is a rather unwelcome hindrance to what is otherwise a superb distro. Hopefully, some type of installer can be incorporated into the recently adopted Archie project that will allow better support for adapting to changes in Arch, and how those changes impact user installations.


/path/to/Truth

Offline

#5 2006-11-11 15:33:08

noobohno
Member
Registered: 2006-11-11
Posts: 13

Re: Installer error? - cannot find files

occam wrote:

error: /mnt/var/lib/pacman/current/kbd-12.1-1/desc: Nosuch file o
error: cannot resolve dependencies for "autoconf":
mawk is not in the package set

Got the same problem installing base packages from newly downloaded CD-Rom. The first install worked fine; a renewed install gave error:

db_read: error: /mnt/var/lib/pacman/current/xorg-fonts-75dpi-1.0.0
error: cannot resolve dependencies for "file":
"zlib" is not in the package set
Package Installation FAILED.

Why is that, and why would the problem arise in one install and not the other?

Offline

#6 2006-11-11 15:57:31

noobohno
Member
Registered: 2006-11-11
Posts: 13

Re: Installer error? - cannot find files

McQueen wrote:

What happens if you install the base from the FTP instead of CD?

I'm trying do do that, but I've got problems there too (as well as my earlier post on CD-rom install). Selecting 'Configure Network' and 'Probe' succeeds in finding the network card, saying the network module is loaded.   But answering 'Yes' to 'Do you want to use DHCP?' returns the error 'Failed to run dhcpcd.'  So I answer 'no',  and declare my IP address, netmask, external gateway and DNS server. I open another TTY console with Alt-F2. Typing 'ifconfig' shows up my network card as eth0, with the appropriate IP address. but pinging another host returns nothing.

Am I doing something fundamentally wrong here?

Thanks for help.

Offline

#7 2006-11-11 17:30:52

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: Installer error? - cannot find files

Offline

#8 2006-11-11 17:31:11

noobohno
Member
Registered: 2006-11-11
Posts: 13

Re: Installer error? - cannot find files

noobohno wrote:

Am I doing something fundamentally wrong here?


Just did, thanks. Seems there's a problem with the 0.7.2 installer from the Arch website.   Explained at  http://bbs.archlinux.org/viewtopic.php?t=25236.

Got the unreleased new FTP installer ISO as the above suggests from http://www.archlinux.org/~tpowa/newisos/  Burned the 17mB iso to CD and loaded it. Had kernel panic, but was sorted by adding boot options:

boot:  arch noapic

Following on from that, network card installed with DHCP, could ping the WLAN, and installed base files via FTP.

All working!

Offline

Board footer

Powered by FluxBB