You are not logged in.

#1 2015-09-13 11:58:27

rata
Member
Registered: 2006-04-10
Posts: 46

pkgbuild for pd-extended doesn't work (makepkg issue)

Hello everyone,

I have made a package for pd-extended (http://puredata.info/downloads/pd-extended) after being able to compile it by hand. However, when running the same commands from the pkgbuild the package doesn't compile. It reports the following error:

checking whether we are cross compiling... configure: error: in `/home/rhz/aur/pd-extended/src/pd-extended/externals/zexy':
configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details

And the config.log contains:

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by zexy configure 2.2.5.1pdextended, which was
generated by GNU Autoconf 2.69.  Invocation command line was

  $ ./configure --disable-library --with-extension=pd_linux --prefix=/usr --libdir=/usr/lib/pd-extended/extra --with-pd=/home/rhz/aur/pd-extended/src/pd-extended/pd

## --------- ##
## Platform. ##
## --------- ##

hostname = rhz-thinkpad
uname -m = x86_64
uname -r = 4.1.4-1-ARCH
uname -s = Linux
uname -v = #1 SMP PREEMPT Mon Aug 3 21:30:37 UTC 2015

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = unknown
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /home/rhz/.rbenv/shims
PATH: /home/rhz/.rbenv/bin
PATH: /bin
PATH: /usr/bin
PATH: /sbin
PATH: /usr/sbin
PATH: /opt/grass7-svn/bin
PATH: /usr/lib/jvm/default/bin
PATH: /usr/bin/site_perl
PATH: /usr/bin/vendor_perl
PATH: /usr/bin/core_perl
PATH: /home/rhz/.cabal/bin
PATH: /home/rhz/bin
PATH: /home/rhz/.rvm/bin
PATH: /home/rhz/.cabal/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2318: checking for a BSD-compatible install
configure:2386: result: /bin/install -c
configure:2397: checking whether build environment is sane
configure:2452: result: yes
configure:2603: checking for a thread-safe mkdir -p
configure:2642: result: /bin/mkdir -p
configure:2649: checking for gawk
configure:2665: found /bin/gawk
configure:2676: result: gawk
configure:2687: checking whether make sets $(MAKE)
configure:2709: result: yes
configure:2738: checking whether make supports nested variables
configure:2755: result: yes
configure:2910: checking build system type
configure:2924: result: x86_64-unknown-linux-gnu
configure:2944: checking host system type
configure:2957: result: x86_64-unknown-linux-gnu
configure:2998: checking how to print strings
configure:3025: result: printf
configure:3058: checking for style of include used by make
configure:3086: result: GNU
configure:3157: checking for gcc
configure:3173: found /bin/gcc
configure:3184: result: gcc
configure:3413: checking for C compiler version
configure:3422: gcc --version >&5
gcc (GCC) 5.2.0
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:3433: $? = 0
configure:3422: gcc -v >&5
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-unknown-linux-gnu/5.2.0/lto-wrapper
Target: x86_64-unknown-linux-gnu
Configured with: /build/gcc-multilib/src/gcc-5.2.0/configure --prefix=/usr --libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=https://bugs.archlinux.org/ --enable-languages=c,c++,ada,fortran,go,lto,objc,obj-c++ --enable-shared --enable-threads=posix --enable-libmpx --with-system-zlib --with-isl --enable-__cxa_atexit --disable-libunwind-exceptions --enable-clocale=gnu --disable-libstdcxx-pch --disable-libssp --enable-gnu-unique-object --enable-linker-build-id --enable-lto --enable-plugin --enable-install-libiberty --with-linker-hash-style=gnu --enable-gnu-indirect-function --enable-multilib --disable-werror --enable-checking=release --with-default-libstdcxx-abi=gcc4-compatible
Thread model: posix
gcc version 5.2.0 (GCC) 
configure:3433: $? = 0
configure:3422: gcc -V >&5
gcc: error: unrecognized command line option '-V'
gcc: fatal error: no input files
compilation terminated.
configure:3433: $? = 1
configure:3422: gcc -qversion >&5
gcc: error: unrecognized command line option '-qversion'
gcc: fatal error: no input files
compilation terminated.
configure:3433: $? = 1
configure:3453: checking whether the C compiler works
configure:3475: gcc -DPD -DHAVE_G_CANVAS_H -DZEXY_LIBRARY -I/home/rhz/aur/pd-extended/src/pd-extended/pd/src -Wall -W -ggdb -I/home/rhz/aur/pd-extended/src/pd-extended/externals/Gem -I/home/rhz/aur/pd-extended/src/pd-extended/externals/pdp/include -DUNIX -Dunix -DDL_OPEN -fPIC -D_FORTIFY_SOURCE=2  -Wl,--export-dynamic  -shared -fPIC conftest.c  >&5
configure:3479: $? = 0
configure:3527: result: yes
configure:3530: checking for C compiler default output file name
configure:3532: result: a.out
configure:3538: checking for suffix of executables
configure:3545: gcc -o conftest -DPD -DHAVE_G_CANVAS_H -DZEXY_LIBRARY -I/home/rhz/aur/pd-extended/src/pd-extended/pd/src -Wall -W -ggdb -I/home/rhz/aur/pd-extended/src/pd-extended/externals/Gem -I/home/rhz/aur/pd-extended/src/pd-extended/externals/pdp/include -DUNIX -Dunix -DDL_OPEN -fPIC -D_FORTIFY_SOURCE=2  -Wl,--export-dynamic  -shared -fPIC conftest.c  >&5
configure:3549: $? = 0
configure:3571: result: 
configure:3593: checking whether we are cross compiling
configure:3601: gcc -o conftest -DPD -DHAVE_G_CANVAS_H -DZEXY_LIBRARY -I/home/rhz/aur/pd-extended/src/pd-extended/pd/src -Wall -W -ggdb -I/home/rhz/aur/pd-extended/src/pd-extended/externals/Gem -I/home/rhz/aur/pd-extended/src/pd-extended/externals/pdp/include -DUNIX -Dunix -DDL_OPEN -fPIC -D_FORTIFY_SOURCE=2  -Wl,--export-dynamic  -shared -fPIC conftest.c  >&5
In file included from /usr/include/stdio.h:27:0,
                 from conftest.c:11:
/usr/include/features.h:328:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
 #  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
    ^
configure:3605: $? = 0
configure:3612: ./conftest
./configure: line 3614: 24717 Segmentation fault      (core dumped) ./conftest$ac_cv_exeext
configure:3616: $? = 139
configure:3623: error: in `/home/rhz/aur/pd-extended/src/pd-extended/externals/zexy':
configure:3625: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=x86_64-unknown-linux-gnu
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=set
ac_cv_env_CFLAGS_value='-DPD -DHAVE_G_CANVAS_H -DZEXY_LIBRARY -I/home/rhz/aur/pd-extended/src/pd-extended/pd/src -Wall -W -ggdb -I/home/rhz/aur/pd-extended/src/pd-extended/externals/Gem -I/home/rhz/aur/pd-extended/src/pd-extended/externals/pdp/include -DUNIX -Dunix -DDL_OPEN -fPIC'
ac_cv_env_CPPFLAGS_set=set
ac_cv_env_CPPFLAGS_value=-D_FORTIFY_SOURCE=2
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_LDFLAGS_set=set
ac_cv_env_LDFLAGS_value=' -Wl,--export-dynamic  -shared -fPIC'
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_LT_SYS_LIBRARY_PATH_set=
ac_cv_env_LT_SYS_LIBRARY_PATH_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=x86_64-unknown-linux-gnu
ac_cv_path_install='/bin/install -c'
ac_cv_path_mkdir=/bin/mkdir
ac_cv_prog_AWK=gawk
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_make_make_set=yes
am_cv_make_support_nested_variables=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /home/rhz/aur/pd-extended/src/pd-extended/externals/zexy/missing aclocal-1.15'
AMDEPBACKSLASH='\'
AMDEP_FALSE='#'
AMDEP_TRUE=''
AMTAR='$${TAR-tar}'
AM_BACKSLASH='\'
AM_DEFAULT_V='$(AM_DEFAULT_VERBOSITY)'
AM_DEFAULT_VERBOSITY='1'
AM_V='$(V)'
ANDROID_FALSE=''
ANDROID_TRUE=''
AR=''
ARCH_FLAG=''
AS=''
AUTOCONF='${SHELL} /home/rhz/aur/pd-extended/src/pd-extended/externals/zexy/missing autoconf'
AUTOHEADER='${SHELL} /home/rhz/aur/pd-extended/src/pd-extended/externals/zexy/missing autoheader'
AUTOMAKE='${SHELL} /home/rhz/aur/pd-extended/src/pd-extended/externals/zexy/missing automake-1.15'
AWK='gawk'
BSD_FALSE=''
BSD_TRUE=''
CC='gcc'
CCDEPMODE=''
CFLAGS='-DPD -DHAVE_G_CANVAS_H -DZEXY_LIBRARY -I/home/rhz/aur/pd-extended/src/pd-extended/pd/src -Wall -W -ggdb -I/home/rhz/aur/pd-extended/src/pd-extended/externals/Gem -I/home/rhz/aur/pd-extended/src/pd-extended/externals/pdp/include -DUNIX -Dunix -DDL_OPEN -fPIC'
CPP=''
CPPFLAGS='-D_FORTIFY_SOURCE=2'
CYGPATH_W='echo'
CYGWIN_FALSE=''
CYGWIN_TRUE=''
DEFS=''
DEPDIR='.deps'
DLLTOOL=''
DSYMUTIL=''
DUMPBIN=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
EXTENSION=''
EXTRA_LTFLAGS=''
FGREP=''
GREP=''
HURD_FALSE=''
HURD_TRUE=''
INCLUDES=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='$(install_sh) -c -s'
IPHONEOS_FALSE=''
IPHONEOS_TRUE=''
IRIX_FALSE=''
IRIX_TRUE=''
LD=''
LDFLAGS=' -Wl,--export-dynamic  -shared -fPIC'
LIBOBJS=''
LIBRARY_FALSE=''
LIBRARY_TRUE=''
LIBS=''
LIBTOOL=''
LIBTOOL_DEPS=''
LINUX_FALSE=''
LINUX_TRUE=''
LIPO=''
LN_S=''
LPT_FALSE=''
LPT_TRUE=''
LTLIBOBJS=''
LT_SYS_LIBRARY_PATH=''
MACOSX_FALSE=''
MACOSX_TRUE=''
MAKEINFO='${SHELL} /home/rhz/aur/pd-extended/src/pd-extended/externals/zexy/missing makeinfo'
MANIFEST_TOOL=''
MINGW_FALSE=''
MINGW_TRUE=''
MKDIR_P='/bin/mkdir -p'
NM=''
NMEDIT=''
OBJDUMP=''
OBJEXT=''
OTOOL64=''
OTOOL=''
PACKAGE='zexy'
PACKAGE_BUGREPORT='zmoelnig@iem.at'
PACKAGE_NAME='zexy'
PACKAGE_STRING='zexy 2.2.5.1pdextended'
PACKAGE_TARNAME='zexy'
PACKAGE_URL='http://get.puredata.info/zexy'
PACKAGE_VERSION='2.2.5.1pdextended'
PATH_SEPARATOR=':'
RANLIB=''
SED=''
SET_MAKE=''
SHELL='/bin/sh'
SINGLEOBJECTS_FALSE=''
SINGLEOBJECTS_TRUE=''
STRIP='echo'
VERSION='2.2.5.1pdextended'
WINDOWS_FALSE=''
WINDOWS_TRUE=''
ac_ct_AR=''
ac_ct_CC='gcc'
ac_ct_DUMPBIN=''
am__EXEEXT_FALSE=''
am__EXEEXT_TRUE=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__include='include'
am__isrc=''
am__leading_dot='.'
am__nodep='_no'
am__quote=''
am__tar='$${TAR-tar} chof - "$$tardir"'
am__untar='$${TAR-tar} xf -'
bindir='${exec_prefix}/bin'
build='x86_64-unknown-linux-gnu'
build_alias=''
build_cpu='x86_64'
build_os='linux-gnu'
build_vendor='unknown'
datadir='${datarootdir}'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
dvidir='${docdir}'
exec_prefix='NONE'
host='x86_64-unknown-linux-gnu'
host_alias=''
host_cpu='x86_64'
host_os='linux-gnu'
host_vendor='unknown'
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh='${SHELL} /home/rhz/aur/pd-extended/src/pd-extended/externals/zexy/install-sh'
libdir='/usr/lib/pd-extended/extra'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
mandir='${datarootdir}/man'
mkdir_p='$(MKDIR_P)'
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='/usr'
program_transform_name='s,x,x,'
psdir='${docdir}'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

/* confdefs.h */
#define PACKAGE_NAME "zexy"
#define PACKAGE_TARNAME "zexy"
#define PACKAGE_VERSION "2.2.5.1pdextended"
#define PACKAGE_STRING "zexy 2.2.5.1pdextended"
#define PACKAGE_BUGREPORT "zmoelnig@iem.at"
#define PACKAGE_URL "http://get.puredata.info/zexy"
#define PACKAGE "zexy"
#define VERSION "2.2.5.1pdextended"

configure: exit 1

So the configure script segfaults when running conftest. This error doesn't occur when compiling by hand. That tells me that makepkg must be the source of the problem (or a program that makepkg is running). This problem has been encountered before (https://bbs.archlinux.org/viewtopic.php?id=86689) but no solution was found. The only thing that's clear in that thread is that fakeroot isn't the problem.

I hope I can get some help on this.

Cheers,
Ricardo

Offline

#2 2015-09-13 11:59:49

rata
Member
Registered: 2006-04-10
Posts: 46

Re: pkgbuild for pd-extended doesn't work (makepkg issue)

The PKGBUILD is:

pkgname=pd-extended
pkgver=0.43.4
pkgrel=1
pkgdesc="The Pure Data real-time music and multimedia environment (with additional libraries and extensions)"
arch=('i686' 'x86_64')
url="http://puredata.info/"
license=('custom:BSD')
depends=('jack' 'tk' 'fftw')
provides=('puredata')
source=("http://downloads.sourceforge.net/project/pure-data/pd-extended/0.43.4/Pd-extended_0.43.4-source.tar.bz2")

build() {
  # cd "$srcdir/pd-extended/pd"
  # ./autogen.sh
  # ./configure --prefix=/usr \
  #             --enable-alsa \
  #             --enable-jack \
  #             --disable-portaudio \
  #             --enable-fftw
  cd "$srcdir/pd-extended/doc"
  sed -i 111s/^ifneq/ifeq/ Makefile
  cd "$srcdir/pd-extended/externals/loaders/tclpd"
  sed -i s/8\.5/8.6/ Makefile
  cd "$srcdir/pd-extended/externals/Gem"
  sed -i 98s/INCLUDES/AM_CPPFLAGS/ configure.ac
  sed -i '117s/^dnl //' configure.ac
}

package() {
  cd "$srcdir/pd-extended/packages/linux_make"
  make DESTDIR="${pkgdir}" install prefix=/usr
}

md5sums=('c19606f1eee2ee83802317ee1eaeaec3')

Thanks

Offline

#3 2015-09-13 12:58:27

shulamy
Member
From: israel
Registered: 2010-09-11
Posts: 440

Re: pkgbuild for pd-extended doesn't work (makepkg issue)

maybe you meant

  arch=('any')

ezik

Offline

#4 2015-09-13 13:18:14

rata
Member
Registered: 2006-04-10
Posts: 46

Re: pkgbuild for pd-extended doesn't work (makepkg issue)

That doesn't make any difference.

Offline

#5 2015-09-13 23:05:51

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,764

Re: pkgbuild for pd-extended doesn't work (makepkg issue)

configure:3433: $? = 0
configure:3422: gcc -V >&5
gcc: error: unrecognized command line option '-V'
gcc: fatal error: no input files
compilation terminated.

Looks like it has problems with gcc 5.2 .
Last release is from january 2013.

If they have  a development version, try that one.
Or try building with older gcc version, 4.3.x upto 4.9.x are in aur.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#6 2015-09-14 17:07:04

rata
Member
Registered: 2006-04-10
Posts: 46

Re: pkgbuild for pd-extended doesn't work (makepkg issue)

Thanks for your reply Lone_Wolf smile

If the problem were the version of gcc, it shouldn't compile by hand either right? This problem only happens when I run the compile instructions from the PKGBUILD with makepkg.

Offline

#7 2015-09-15 12:38:14

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,764

Re: pkgbuild for pd-extended doesn't work (makepkg issue)

Good point, i missed that.

makepkg does have a different environment then that of the user that runs it, so some path is porbably different then configure expects .

You'll prob have to dig into the configure script to figure out where/why it goes wrong.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#8 2015-09-15 16:10:02

Stefan Husmann
Member
From: Germany
Registered: 2007-08-07
Posts: 1,232

Re: pkgbuild for pd-extended doesn't work (makepkg issue)

The first thing I would try is having

options=('!makeflags')

in the PKGBUILD.

Offline

#9 2015-09-15 22:09:49

Allan
Pacman
From: Brisbane, AU
Registered: 2007-06-09
Posts: 11,123
Website

Re: pkgbuild for pd-extended doesn't work (makepkg issue)

options=(!buildflags) would do it.   The actual error is a segfaulting binary that it creates.  I'd guess the difference is the CFLAGS/CPPFLAGS.

Offline

#10 2015-09-16 18:06:39

rata
Member
Registered: 2006-04-10
Posts: 46

Re: pkgbuild for pd-extended doesn't work (makepkg issue)

Thanks Allan! That worked smile

Offline

Board footer

Powered by FluxBB