You are not logged in.

#1 2015-09-29 08:11:30

Registered: 2015-02-25
Posts: 9

[SOLVED] GDM and Gnome take >30sec to start


I'm not entirely sure when this started happening, but on my desktop GDM and Gnome take ages to start up.
GDM takes around 30 seconds from "systemctl start gdm" to seeing a login screen, and from typing my password to the gnome shell takes another 60 seconds.
During the wait, I just see a black screen, not even a cursor.

I've tried a lot of things, but I have yet to find anything that fixes it.

Here's what I know so far:
- I'm running the nVidia 340.93 drivers.
- "systemctl start lightdm" starts up within a second, as does "startx".
- Starting a gnome session from lightdm will also trigger the delay, but starting for example XMonad does not.
- When in XMonad, most Gnome utilities (mostly tested with gedit) take ages to start up. Chrome also seems to be affected with about 30 second delay before it'll show up.
- /var/log/Xorg.0.log and Xorg.1.log don't show any errors, but complain about my monitors not supporting nvidia 3d vision multiple times, with the 30second delay clearly visible (first message with timestamp x, second message with x + 30)
- Disabling Stereo will not get rid of this message, but given that lightdm and most other X stuff works, I'm not convinced this could be a driver problem.

Would anyone be able to suggest other methods of troubleshooting?

Last edited by Frans-Willem (2015-09-29 21:02:17)


#2 2015-09-29 08:56:14

Wiki Maintainer
From: United Kingdom
Registered: 2013-06-02
Posts: 506

Re: [SOLVED] GDM and Gnome take >30sec to start

Perhaps these might help:
* … _GDM_login
* … rg_backend

Last edited by Chazza (2015-09-29 08:57:08)


#3 2015-09-29 21:02:03

Registered: 2015-02-25
Posts: 9

Re: [SOLVED] GDM and Gnome take >30sec to start

Thanks for the suggestions, Chazza. Unfortunately neither fixed the issue.

However, after more debugging, I've found the culprit: apparently the upgrade to pulse 7.0 broke things.
I'm running Pulse in system mode as I have some system services that need access to sound, and apparently the systemd user services can't handle that anymore since pulse 7.0.

A quick fix would be just deleting /usr/lib/systemd/user/pulseaudio.service and /usr/lib/systemd/user/pulseaudio.socket.
However, I'm not a big fan of just deleting stuff.

It appears the pulsaudio.socket points to /var/run/user/<userid>/pulse/native, but this file/socket does not exist. Instead a system wide version exists in /var/run/pulse/native.
I created a systemd drop in snippet with the following contents:
File: /etc/systemd/user/pulseaudio.socket.d/00-system-mode.conf (you'll have to create the directory)


After a reboot, everything is working. System-wide sound works, and user sounds work too smile


Board footer

Powered by FluxBB