You are not logged in.

#1 2015-05-16 22:07:16

brittyazel
Member
From: Davis, CA
Registered: 2013-05-11
Posts: 162

[Solved]Bluetooth headphones only working in mono

Hi guys, over the weekend I bought some Sentey Bluetooth B-trek H9 headphones, which sound incredible and work beautifully with bluetooth on Android and Windows, but on Archlinux they pair perfectly but only register as mono and the sound is terrible. I have read all over about editing alsarc files, but nothing I do is seeming to help.

Also, I tried to pair a set of my girlfriends phillips bt headphones and the same thing happened. Any advice?

I should also note I have all the bluez stuff installed as well as the pulseaudio bluetooth packages. And to reiterate, the sound does work, it just sounds like dirt and is only mono.

Maybe a hint is that is says paired as "headset", and it's trying to treat it as a little bluetooth phone mic?

Last edited by brittyazel (2015-05-17 19:13:32)


I don't really know what I'm doing.

Offline

#2 2015-05-17 04:57:04

brittyazel
Member
From: Davis, CA
Registered: 2013-05-11
Posts: 162

Re: [Solved]Bluetooth headphones only working in mono

So looking at the problem more closely, the issue was a2dp_sink failing to load. For some reason pulseaudio/bluez was being informed that the headset was not a2dp capable. I came across this workaround:

Bug and possible solution: actually I found a bug in that make the headset unusable, it seems that the pulse audio module: module-bluetooth-discover works only if started after the X11 session is up. So I have a workaround.
Edit the file:
/etc/pulse/default.pa
and comment out (with an # at the beginning of the line) the following line:
#load-module module-bluetooth-discover
now edit the file:
/usr/bin/start-pulseaudio-x11
and after the lines:
   if [ x”$SESSION_MANAGER” != x ] ; then
        /usr/bin/pactl load-module module-x11-xsmp “display=$DISPLAY session_manager=$SESSION_MANAGER” > /dev/null
    fi
add the following line:
    /usr/bin/pactl load-module module-bluetooth-discover
This way the Pulse audio’s Bluetooth modules will not be downloaded at boot time but after x11 is started.

After this, I was able to do:

pacmd ls

I looked for the index that my bluetooth device was on, and then did:

pacmd set-card-profile 4 a2dp_sink

Although, perhaps the a2dp was auto set by the above code. I just did it for good measure.


I don't really know what I'm doing.

Offline

#3 2015-05-17 05:11:12

brittyazel
Member
From: Davis, CA
Registered: 2013-05-11
Posts: 162

Re: [Solved]Bluetooth headphones only working in mono

Hopefully they can fix this somehow. The solution above seems a bit to hacky for my taste

Last edited by brittyazel (2015-05-17 05:18:53)


I don't really know what I'm doing.

Offline

#4 2015-05-17 10:47:46

Soukyuu
Member
Registered: 2014-04-08
Posts: 845

Re: [Solved]Bluetooth headphones only working in mono

I wonder why that doesn't happen to me. Do you have pulseaudio-bluetooth installed (if using pulseaudio)? Which DE are you using?
I'm on KDE and my headphones only paired itself as headset once, but after setting the a2dp profile, it has worked fine since.


[ Arch x86_64 | linux | ThinkPad X220 | Intel Core i5 2540M@3.3Ghz | Intel HD3000 | 16GB RAM | Main, docked to 2 Monitors ]
[ Arch x86_64 | linux-ck-k10 | Custom-built | AMD Phenom II X4@3,5Ghz | nVidia 260 GTX | 12GB RAM | Retired ]
[ Arch x86_64 | linux | Custom-built | Intel Celeron G3920@2,99Ghz | iGPU | 8GB RAM | Home server ]

Offline

#5 2015-05-17 19:12:40

brittyazel
Member
From: Davis, CA
Registered: 2013-05-11
Posts: 162

Re: [Solved]Bluetooth headphones only working in mono

Yes I have pulseaudio-bluetooth, and I am running gnome 3.16. Perhaps gdm using Wayland is causing this? Maybe that is why the command never runs


I don't really know what I'm doing.

Offline

#6 2015-05-17 22:39:16

Soukyuu
Member
Registered: 2014-04-08
Posts: 845

Re: [Solved]Bluetooth headphones only working in mono

I saw some other posts stating troubles with bluetooth + gnome, so that's probably gnome doing something wrong.


[ Arch x86_64 | linux | ThinkPad X220 | Intel Core i5 2540M@3.3Ghz | Intel HD3000 | 16GB RAM | Main, docked to 2 Monitors ]
[ Arch x86_64 | linux-ck-k10 | Custom-built | AMD Phenom II X4@3,5Ghz | nVidia 260 GTX | 12GB RAM | Retired ]
[ Arch x86_64 | linux | Custom-built | Intel Celeron G3920@2,99Ghz | iGPU | 8GB RAM | Home server ]

Offline

#7 2015-10-16 08:17:35

skiwi
Member
Registered: 2012-11-28
Posts: 30

Re: [Solved]Bluetooth headphones only working in mono

This thread is old, but just wanted to say thanks. The fix proposed works perfectly.
It suffices to reboot after making the changes to the config files.

See also this reated topic https://bbs.archlinux.org/viewtopic.php?id=196689.

Last edited by skiwi (2015-10-16 08:18:38)

Offline

#8 2015-10-30 09:14:48

msx
Member
From: solar.system/earth/ar/bue/mdp
Registered: 2010-08-08
Posts: 184
Website

Re: [Solved]Bluetooth headphones only working in mono

Passing by to thank OP (you saved my night, @brittyazel) and let you know that this is still happening on GNOME 3.18.1, I will scan their Bugzilla for related issues and eventually rise a ticket ASAP.


Enjoying i3wm w/ lifebar + j4-dmenu-desktop + tab_windows / fish shell / Emacs / tmux / Konsole / KDE apps
Arch + Linux-libre kernel: ParabolaGNULinux.org

Offline

#9 2016-07-14 11:11:18

amonra
Member
Registered: 2016-07-14
Posts: 1

Re: [Solved]Bluetooth headphones only working in mono

this problem is still happen on 4.6.3-1 with gnome-shell 3.20.2, and the workaround works perfectly.
Hei,~~ @brittyazel, thanks for sharing the fix, that really helps me.~~~~~!

Offline

#10 2016-07-14 15:21:11

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,853

Re: [Solved]Bluetooth headphones only working in mono

amonra,

Welcome to Arch Linux -- glad it worked for you.

Using this opportunity to close this old thread


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB