You are not logged in.

#1 2015-05-27 13:28:33

Registered: 2015-05-08
Posts: 13

[SOLVED] LibreOffice, insufficient user rights when saving/opening


Getting error message prompt when I am trying to save or open documents.
I am using LibreOffice v4.4.3.2 from the Arch repository(libreoffice-fresh)

Error prompt
Error saving the document :
Object not accessible.
The object cannot be accessed due to insufficient user rights.


$ chmod -R 755 ~/.config/libreoffice

Owner and Group is my user, 755 permissions have been successfully applied.

Also tried deleting the config folder with its contents followed by restarting libreoffice to create new configs but did not help with the problem. I am getting the error message regardless of the save destination and the directory permissions of the destination.
Tried libreoffice-still, did not help either.


$ libreoffice

in console does not print any error messages.

Saving and opening works running as root and as another user with

user $ xhost +
user $ su - testuser
testuser $ libreoffice

Please help me so that I dont have to run it as another user account:(

Last edited by nomeed (2015-10-27 15:51:27)


#2 2015-10-27 15:51:07

Registered: 2015-05-08
Posts: 13

Re: [SOLVED] LibreOffice, insufficient user rights when saving/opening

It was inherently no permissions problem.

Solved by changing my environment variable in .bashrc from




Libreoffice was using the environment variable $TMP for its temporary path saving, which was set to "TMP". Thus libreoffice was creating TMP folders in its current working  directory which it had no permissions for...

Found out after looking in menu and since it was related to only this user account:
Tools | Options -> LibreOffice -> Paths
Temporary files Path was blank and not changeable.

Last edited by nomeed (2015-10-27 15:52:30)


Board footer

Powered by FluxBB