You are not logged in.

#1 2015-11-12 16:06:27

Kyras
Member
Registered: 2015-03-19
Posts: 6

Mouse stopped working: cant' add hid device: -71

Hello,
i was using Arch linux for about three month and mouse[1] worked properly. About week ago mouse started to sttuter and recently stopped working completely (about 1~2 minutes after boot). Tried some of Google answers, but didn't work sad .
After Disconnecting and Connecting journalctl produce:

nov 12 16:49:17 Vergil kernel: usbhid 3-6:1.1: can't add hid device: -71
nov 12 16:49:17 Vergil kernel: usbhid: probe of 3-6:1.1 failed with error -71

Today I tried to install Manjaro instead of Arch, but problem persisted and generate same usbhid error.
Mouse works properly on (doualboot) Windows10 and friends Fedora.

lsusb:

Bus 002 Device 002: ID 8087:8000 Intel Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 003 Device 006: ID 0cf3:3004 Atheros Communications, Inc. AR3012 Bluetooth 4.0
Bus 003 Device 009: ID 1bcf:0824 Sunplus Innovation Technology Inc.
Bus 003 Device 003: ID 0bda:5728 Realtek Semiconductor Corp.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

dmesg:

[ 1288.606258] usb 3-2: USB disconnect, device number 2
[ 1296.456543] usb 3-6: new full-speed USB device number 7 using xhci_hcd
[ 1296.635459] input: SunplusIT SmartMouse as /devices/pci0000:00/0000:00:14.0/usb3/3-6/3-6:1.0/0003:1BCF:0824.0002/input/input18
[ 1296.686923] hid-generic 0003:1BCF:0824.0002: input,hidraw0: USB HID v1.00 Keyboard [SunplusIT SmartMouse] on usb-0000:00:14.0-6/input0
[ 1296.689231] usbhid 3-6:1.1: can't add hid device: -71
[ 1296.689251] usbhid: probe of 3-6:1.1 failed with error -71
[ 2396.987541] xhci_hcd 0000:00:14.0: URB transfer length is wrong, xHC issue? req. len = 0, act. len = 4294967288
[ 3252.679267] usb 3-6: USB disconnect, device number 7
[ 3254.357144] usb 3-6: new full-speed USB device number 8 using xhci_hcd
[ 3254.534909] input: SunplusIT SmartMouse as /devices/pci0000:00/0000:00:14.0/usb3/3-6/3-6:1.0/0003:1BCF:0824.0003/input/input19
[ 3254.587569] hid-generic 0003:1BCF:0824.0003: input,hidraw0: USB HID v1.00 Keyboard [SunplusIT SmartMouse] on usb-0000:00:14.0-6/input0
[ 3254.591325] usbhid 3-6:1.1: can't add hid device: -71
[ 3254.591337] usbhid: probe of 3-6:1.1 failed with error -71
[ 3408.535492] usb 3-6: USB disconnect, device number 8
[ 3518.281156] usb 3-6: new full-speed USB device number 9 using xhci_hcd
[ 3518.457872] usb 3-6: can't set config #1, error -71


[1] http://www.connectit-europe.com/en/prod … biohazard/

Offline

#2 2015-11-12 16:19:13

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,515

Re: Mouse stopped working: cant' add hid device: -71

Try a different mouse?
Does the mouse work on Windows machines?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Online

#3 2015-11-12 16:21:12

Kyras
Member
Registered: 2015-03-19
Posts: 6

Re: Mouse stopped working: cant' add hid device: -71

ewaller wrote:

Try a different mouse?
Does the mouse work on Windows machines?

Yes.
I currently have Dualboot Manjaro/W10. On Windows it works properly.
Also tried it on my friends notebook with Fedora, worked properly.

EDIT [12.11.2015]:
Unfortunately, currently i don't have other mouse with me.

EDIT [13.11.2015]:
Tested other mouse. Worked properly.

Last edited by Kyras (2015-11-13 06:32:27)

Offline

#4 2015-11-13 18:15:04

Kyras
Member
Registered: 2015-03-19
Posts: 6

Re: Mouse stopped working: cant' add hid device: -71

Today I tried to reinstall XOrg mouse drivers, which done absolutely nothing....
But after removing xf86-input-joystick driver, it started working, but after about 5 minutes

[15165.214682] hid-generic 0003:1BCF:0824.0005: input,hidraw1: USB HID v1.00 Mouse [SunplusIT SmartMouse] on usb-0000:00:14.0-2/input1
[15176.994229] usb 3-2: reset full-speed USB device number 8 using xhci_hcd
[15178.706169] usb 3-2: reset full-speed USB device number 8 using xhci_hcd
[15179.180067] usb 3-2: reset full-speed USB device number 8 using xhci_hcd
[15185.156606] usb 3-2: reset full-speed USB device number 8 using xhci_hcd
[15187.078787] usb 3-2: reset full-speed USB device number 8 using xhci_hcd
[15190.348996] usb 3-2: reset full-speed USB device number 8 using xhci_hcd
[15190.702750] usb 3-2: reset full-speed USB device number 8 using xhci_hcd
[15196.462268] usb 3-2: reset full-speed USB device number 8 using xhci_hcd
[15219.924979] usb 3-2: reset full-speed USB device number 8 using xhci_hcd

Offline

#5 2015-11-15 12:21:35

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,587

Re: Mouse stopped working: cant' add hid device: -71

Kyras,

not sure if is related but your USB 003 bus seems rather full.

Have you tried other usb ports to have it use another bus ?

lsusb -t combined with plain lsusb helps with figuring out which bus a device uses.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#6 2015-11-15 13:33:42

Kyras
Member
Registered: 2015-03-19
Posts: 6

Re: Mouse stopped working: cant' add hid device: -71

I have three usb ports on my notebook (2x USB3 + 1x USB2).
I tried pluging both mouses (problematic and working) in combinations to them and I noticed that they are always pluged to the same Bus.
lsusb (working mouse pluged into USB2, problematic pluged into one of USB3 - no other usb devices plugged):

Bus 004 Device 002: ID 8087:8000 Intel Corp.
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 8087:8008 Intel Corp.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 017: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 001 Device 019: ID 1bcf:0824 Sunplus Innovation Technology Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsusb -t:

/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/14p, 480M
    |__ Port 1: Dev 19, If 0, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 1: Dev 19, If 1, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 6: Dev 17, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
    |__ Port 8: Dev 3, If 0, Class=Vendor Specific Class, Driver=rtsx_usb, 480M

ls /dev/bus/usb/001/ -l:

crw-rw-r-- 1 root root 189,  0 nov 15 09:24 001
crw-rw-r-- 1 root root 189,  2 nov 15 09:24 003
crw-rw-r-- 1 root root 189, 16 nov 15 14:20 017
crw-rw-r-- 1 root root 189, 18 nov 15 14:21 019

Problematic mouse is always there twice
lsusb -v (problematic mouse):

Bus 001 Device 019: ID 1bcf:0824 Sunplus Innovation Technology Inc.
Couldn't open device, some information will be missing
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0         8
  idVendor           0x1bcf Sunplus Innovation Technology Inc.
  idProduct          0x0824
  bcdDevice            5.22
  iManufacturer           1
  iProduct                2
  iSerial                 0
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           59
    bNumInterfaces          2
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         3 Human Interface Device
      bInterfaceSubClass      1 Boot Interface Subclass
      bInterfaceProtocol      1 Keyboard
      iInterface              0
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.00
          bCountryCode            0 Not supported
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength      65
         Report Descriptors:
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval               2
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         3 Human Interface Device
      bInterfaceSubClass      1 Boot Interface Subclass
      bInterfaceProtocol      2 Mouse
      iInterface              0
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.00
          bCountryCode            0 Not supported
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength     116
         Report Descriptors:
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval

Tried to find out how to change usb bus of usb port, but unsuccesfuly

Offline

Board footer

Powered by FluxBB