You are not logged in.

#1 2004-02-23 21:32:34

Registered: 2003-09-05
Posts: 272

error I get at boot with filesystems check process.

Ok this is a fresh install on a brand new pc. I d/l the 0.6 beta iso since the system doesn't have a floppy drive and since the new kernel name change ftp install of the .5 iso won't work. Anyways after install of just base packages I get this odd message when it hits the "Checking Filesystems" section of the boot. This happens right after it mounts rot as read only.

Exaqct message is:

fsck: cannot check /dec/discs/disc0/part4: fsck.reiserfs not found..

I have tried uninstalling reiserfsprogs package and reinstalling it but that still doesn't fix the issue. I am not quite sure what the issue is. This is the first time I have ever come across this issue. Any help or advice twards fixing this would be great..


#2 2004-02-24 11:25:56

From: Slovenia
Registered: 2004-02-08
Posts: 247

Re: error I get at boot with filesystems check process.

If you set up your fstab to check filesystems on boot (the last parameter in a line in fstab) then fsck is called during boot. fsck then calls the appropriate fsck for the filesystem fsck.[your-filesystem], in your case that is fsck.reiserfs. I don't know why but the program in reiserfsprogs is named reiserfsck (at least in arch linux), that's why fsck cannot find it.

You could create a symlink to reiserfsck called fsck.reiserfs, but I am not sure if these are really the same programs with just different names or they really differ. If someone knows more, please explain, I'm also interested in this.


#3 2004-02-24 14:07:27

Registered: 2004-02-04
Posts: 1,185

Re: error I get at boot with filesystems check process.

You don't need to run fsck at boot for Reiserfs.


Board footer

Powered by FluxBB