You are not logged in.

#1 2015-12-24 02:28:12

shallpion
Member
Registered: 2009-12-12
Posts: 63

kde spectacle global key shortcut?

Yesterday I upgraded my Arch computer and I noticed that ksnapshot no longer worked after I pressed printscreen button on my keyboard. A little googling showed that ksnapshot is replaced by a new app called spectacle. However KDE didn't use the same default keyboard shortcut for it. Instead spectacle placed shortcut under System settings-->Shortcuts-->Custom Shortcuts--> and one has to configure it manually.

Though it worked, I wonder if it was intended to have end-users to change the shortcut by themselves or a bug?... Hopefully it weren't the former as it sounded a little weird... Thanks smile

Offline

#2 2015-12-24 07:47:46

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,673

Re: kde spectacle global key shortcut?

It should work for clean users, it won't if you configured your PrtScr key locally to launch ksnapshot in the past. You'll need to remove the assignment from .config/ khotkeysrc

Offline

#3 2015-12-26 03:39:00

shallpion
Member
Registered: 2009-12-12
Posts: 63

Re: kde spectacle global key shortcut?

That is rather strange as I don't think I set the shortcut for ksnapshot...

Offline

#4 2015-12-27 03:59:39

giogziro95
Member
From: Tbilisi, Georgia
Registered: 2015-12-27
Posts: 1
Website

Re: kde spectacle global key shortcut?

Sidenote: I have just signed up. Hello, Arch Linux community! roll

As for the issue, my system (Manjaro) has been affected as well. I solved it by going to the System SettingsShortcutsCustom Shortcuts, expanding Screenshots in the list, clicking the Trigger tab and setting the shortcut to the Print Screen key.

Screenshot:
sfklOzT.png

After selecting the keyboard shortcut, the infobox appeared saying "The shortcut 'Print' conflicts with the following key combination: Shortcut 'Print' in Application KDE Daemon for action PrintScreen":
PdgA9go.png
I clicked Reassign and then Apply. After this, the Print Screen key has started functioning.

But considering the infobox message above, there should be another action in the KDE Daemon settings, so I switched to the Global Keyboard Shortcuts page, selected KDE Daemon in the KDE component drop-down list. As it turns out, there are two separate actions — PrintScreen and Start Screenshot Tool; so my guess is, PrintScreen calls KSnapshot and since it's removed, nothing happens.

So yeah... That's how to fix it. smile

Also, optionally, you can assign Take Full Screen Screenshot and Take Active Window Screenshot action to the hotkeys of your choice (if they're not already). The default ones are Shift+PrtScr and Meta+PrtScr.

Last edited by giogziro95 (2015-12-27 04:52:33)


Where there is a shell, there is a way.

Offline

#5 2016-01-03 18:40:46

firekage
Member
From: Eastern Europe, Poland
Registered: 2013-06-30
Posts: 572

Re: kde spectacle global key shortcut?

Thank you. I just found myself with the same problem.

Offline

Board footer

Powered by FluxBB