You are not logged in.

#1 2006-04-22 18:03:45

crinimal
Member
Registered: 2006-01-09
Posts: 12

harddisk, turning off and on all the time. [solved]

Hi there.

my bios (travelmate 660, bios up to date) likes to switch off my harddisk after one minute of doing nothing on it.
no way to configure it via power managemant in bios setup or operating system.

my solution under windows was to run a little script, creating and deleting a file every 50 seconds. that was enaugh to say the bios not to power off my disk.

now i tried the same in a little shell script on arch-linux, but it doesn't work. my file gets renewed and deleted, but the harddisk turns off anyway. even when i make a new file manually, the harddisk still doesn't power on when it's off before.

so i'm now looking for a command or trick which really uses the harddisk, so that it keeps it running. and it should not use too much  resources...

Offline

#2 2006-04-22 18:58:12

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: harddisk, turning off and on all the time. [solved]

Maybe it's possible to turn off/lengthen the idle time needed to trigger standby with hdparm -S?

Offline

#3 2006-04-22 19:18:13

vacant
Member
From: downstairs
Registered: 2004-11-05
Posts: 799

Re: harddisk, turning off and on all the time. [solved]

If you have a reiserfs file system, the "atime" option causes disk activity every few seconds. Most systems don't need it so we specify "noatime" in fstab but it sounds like you could use it.

Offline

#4 2006-04-22 19:30:30

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: harddisk, turning off and on all the time. [solved]

Yep, you want noatime as a mount option. FWIW, I think that should be made default...

Offline

#5 2006-04-23 10:02:29

vacant
Member
From: downstairs
Registered: 2004-11-05
Posts: 799

Re: harddisk, turning off and on all the time. [solved]

Gullible Jones wrote:

you want noatime as a mount option

In this unusual case I'm suggesting he(?) keeps "atime" as he wants frequent disk activity. As a default, I agree - noatime suits most of us.

Offline

#6 2006-04-23 14:41:58

crinimal
Member
Registered: 2006-01-09
Posts: 12

Re: harddisk, turning off and on all the time. [solved]

lucke wrote:

Maybe it's possible to turn off/lengthen the idle time needed to trigger standby with hdparm -S?

That was the solution! Setting it to 0 disabled the drive's "spin dowd time" and it didn't turn off until now.

Thank you!

Offline

#7 2006-04-23 14:49:33

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: harddisk, turning off and on all the time. [solved]

Remember to add that command to /etc/rc.local, so it'd be executed on every boot.

Offline

#8 2006-04-23 19:41:28

crinimal
Member
Registered: 2006-01-09
Posts: 12

Re: harddisk, turning off and on all the time. [solved]

lucke wrote:

Remember to add that command to /etc/rc.local, so it'd be executed on every boot.

it's already there... (-;

Offline

Board footer

Powered by FluxBB