You are not logged in.

#1 2015-12-29 20:50:34

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,045
Website

[SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

SOLUTION: it seems that without SAL_USE_VCLPLUGIN explicitly set to 'gen' L.O. defaults to using gtk2.  As I didn't have gtk2 installed, this was causing the crash.  Setting SAL_USE_VCLPLUGIN=gen in /etc/profile.d/libreoffice.* fixed this - but this should probably be a package default. (edit: false alarm, not actually solved)

-----

On trying to start libreoffice, I see the splash screen momentarily, then it exits with the following error:

$ loffice
Warning: failed to read path from javaldx
terminate called after throwing an instance of 'com::sun::star::uno::DeploymentException'
Application Error

This happens with a filename provided or as just loffice as above or soffice.

I don't know when this started as I very rarely use libreoffice - the last time I used it was likely a month or so ago and it worked fine.  I'm running libreoffice-fresh 5.0.4-2.  I see that was built more recently than my previous use of libreoffice, so I will try downgrading soon (it's not in my cache).

This seems to be a java related error, but I have nothing java related installed.  Java packages are only optional dependencies for libreoffice, so they should not be needed to start the program (if this has changed, libreoffice should be repackaged).

Based on similar errors found on forums from several years ago, I removed ~/.config/libreoffice for a fresh start, but I had the same error when I tried to start loffice.

Any hints would be appreciated - or if anyone has a non-libreoffice method of reliably converting doc(x)s to pdfs, I'd be all ears.

EDITS FOR UPDATES

- I've just downgraded to 5.0.2-4 and received the same error.  The build date for 5.0.2-4 is almost certainly before my last successful use of libreoffice.  I also tried 5.0.1-3 which would definitely be before my last successful use, but this would require other packages to be downloaded (at least icu).  So this doesn't seem to be a version/update related problem.

- libreoffice-still crashes with the exact same error output.

- Another arch system of mine runs loffice just fine, but it does give the same javaldx warning, so that line might be unrelated.

- Updated title as the first warning message seems benign.  The com::sun part seems to be the problem.

- I've just removed LO with pacman -Rsn to also remove all (otherwise unneeded) deps, cleared my pacman cache, and reinstalled in case of a corrupt package download.  But I still get the same error.

Last edited by Trilby (2016-01-11 16:49:39)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#2 2015-12-30 14:20:19

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 611

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

I know you can disable java from the options menu when you have started libreoffice, but that won't help if it aborts.

Can you change...

~/.config/libreoffice/4/user/config/javasettings_Linux_X86_64.xml

from

<enabled xsi:nil="false">true</enabled>

to

<enabled xsi:nil="false">false</enabled>

When I do this to disable java, I get the "Warning: failed to read path from javaldx" but libreoffice works fine.

This is using libreoffice-fresh 5.0.4-2

Offline

#3 2015-12-30 14:32:08

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,045
Website

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

Thanks for the suggestion.  Unfortunately it was already set to false.  And I have the same problem even if I delete the entire libreoffice config.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#4 2015-12-30 14:44:46

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 611

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

Have you made any changes to the /etc/profile.d/libreoffice-fresh.{c}sh files?

edit: also do you have any libreoffice extensions installed (perhaps remove these if you do) and do you have a language pack installed?

Last edited by paulkerry (2015-12-30 14:49:17)

Offline

#5 2015-12-30 14:52:03

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,045
Website

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

Nope, no changes, no extensions, no language packs.

What baffles me is that I have a nearly identical install on another computer and it runs LO without issue.  I've looked for and removed anything related to libreoffice in ~/.config ~/.local and ~/.cache.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#6 2015-12-30 15:34:17

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 611

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

How about trying as a new user? At least then you will know if it's a per-user or a system problem...

Offline

#7 2015-12-30 16:23:38

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,045
Website

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

Thanks - I tried that too.  I created a new user as per the wiki, logged in, created an xinitrc with a single line "exec urxvt", then I ran startx and attempted to launch loffice from the urxvt window: I received the same error.  There was a new message at the start of javaldx not being able to find an interpreter but this is due to the default config being created without the false setting mentioned in post #2.  When I changed that to false and attempted loffice a second time with the new user, the error was then identical to that for my main user.

I ran strace on soffice.bin once each on the working computer and the one giving the error.  The full strace from the failing machine is here, the tail of it follows:

lstat("/home", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
lstat("/home/jmcclure", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
lstat("/home/jmcclure/.config", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
lstat("/home/jmcclure/.config/libreoffice", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
lstat("/home/jmcclure/.config/libreoffice/4", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
access("/home/jmcclure/.config/libreoffice/4", F_OK) = 0
brk(0x271c000)                          = 0x271c000
poll([{fd=7, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=7, revents=POLLOUT}])
writev(7, [{"\213\5\4\0\21\0\240\0@\0\0\0\0\0\0\0\213\4\5\0&\0\240\0\22\0\240\0*\0\0\0"..., 92}, {"\376\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377\377"..., 112216}, {"", 0}], 3) = 112308
poll([{fd=7, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=7, revents=POLLOUT}])
writev(7, [{"<\5\2\0(\0\240\0\213\4\6\0)\0\240\0'\0\240\0$\0\0\0\1\0\0\0\1\0\0\0"..., 192}, {NULL, 0}, {"", 0}], 3) = 192
recvmsg(7, 0x7fffe60a1760, 0)           = -1 EAGAIN (Resource temporarily unavailable)
open("/usr/lib/libreoffice/program/../program/libcomphelper.so", O_RDONLY|O_CLOEXEC) = 13
read(13, "\177ELF\2\1\1\3\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\320\243\5\0\0\0\0\0"..., 832) = 832
fstat(13, {st_mode=S_IFREG|0755, st_size=1496592, ...}) = 0
close(13)                               = 0
write(2, "terminate called after throwing "..., 48terminate called after throwing an instance of ') = 48
write(2, "com::sun::star::uno::DeploymentE"..., 40com::sun::star::uno::DeploymentException) = 40
write(2, "'\n", 2'
)                      = 2
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
tgkill(5234, 5234, SIGABRT)             = 0
--- SIGABRT {si_signo=SIGABRT, si_code=SI_TKILL, si_pid=5234, si_uid=1000} ---
futex(0x25a00f4, FUTEX_CMP_REQUEUE_PRIVATE, 1, 2147483647, 0x25a0120, 2) = 1
futex(0x25a0120, FUTEX_WAKE_PRIVATE, 1) = 1
futex(0x7fedcc2a69d0, FUTEX_WAIT, 5237, NULL) = 0
write(2, "Application Error\n", 18Application Error
)     = 18
exit_group(1)                           = ?
+++ exited with 1 +++

Finding corresponding sections from the working strace log suggest that the calls on libcomphelper.so are normal, and should be followed by calls on libucb1.so - these are absent from the strace on the failing machine.

libucb1.so is present on both systems and shows an identical checksum value.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#8 2015-12-30 17:47:34

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 611

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

At least you now know it's a system-wide problem. Are you getting anything in dmesg when you run this (thinking of the recent https://bbs.archlinux.org/viewtopic.php?id=206580 relating to Skylake and nvidia)?

Offline

#9 2015-12-30 17:52:50

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,045
Website

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

Nothing in dmesg (or journalctl output) from attempting to run loffice.  The two machines do differ in CPU.  The functional one is a core2duo, the failing is an i7 broadwell.  But they both use intel graphics (if that could be relevant).

Other new info: I'm pretty much useless with gdb, but I ran soffice.bin through gdb.  It crashed, but the splash screen remained on screen suggesting that only one thread had the problem (maybe).  The splash screen only went away when I closed gdb and terminated subprocesses.  I ran it again in gdb and attempted a backtrace and received the following:

(gdb) bt
#0  0x00007ffff758c5f8 in raise () from /usr/lib/libc.so.6
#1  0x00007ffff758da7a in abort () from /usr/lib/libc.so.6
#2  0x00007ffff6c3dadd in __gnu_cxx::__verbose_terminate_handler () at /build/gcc/src/gcc-5.3.0/libstdc++-v3/libsupc++/vterminate.cc:95
#3  0x00007ffff6c3b936 in __cxxabiv1::__terminate (handler=<optimized out>) at /build/gcc/src/gcc-5.3.0/libstdc++-v3/libsupc++/eh_terminate.cc:47
#4  0x00007ffff6c3b981 in std::terminate () at /build/gcc/src/gcc-5.3.0/libstdc++-v3/libsupc++/eh_terminate.cc:57
#5  0x00007ffff6c3bb98 in __cxxabiv1::__cxa_throw (obj=0x14058b0, tinfo=0x7ffff7b81330 <typeinfo for com::sun::star::uno::DeploymentException>, dest=0x7ffff7920c60)
    at /build/gcc/src/gcc-5.3.0/libstdc++-v3/libsupc++/eh_throw.cc:87
#6  0x00007ffff7925296 in ?? () from /usr/lib/libreoffice/program/libsofficeapp.so
#7  0x00007ffff791f35a in ?? () from /usr/lib/libreoffice/program/libsofficeapp.so
#8  0x00007ffff2b0da51 in ?? () from /usr/lib/libreoffice/program/libvcllo.so
#9  0x00007ffff2b0daa2 in SVMain() () from /usr/lib/libreoffice/program/libvcllo.so
#10 0x00007ffff7945742 in soffice_main () from /usr/lib/libreoffice/program/libsofficeapp.so
#11 0x000000000040071b in ?? ()
#12 0x00007ffff7579610 in __libc_start_main () from /usr/lib/libc.so.6
#13 0x0000000000400759 in ?? ()

I'm currently attempting to build from abs with debugging symbols.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#10 2015-12-30 18:10:34

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 611

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

Do you have intel-ucode installed? Clutching at straws now!

edit: have you tried downloading from https://www.libreoffice.org/download/libreoffice-fresh/  extracting to a temporary directory and running from that location just as a test?

Last edited by paulkerry (2015-12-30 18:18:05)

Offline

#11 2015-12-30 18:18:32

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,641

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

Do you use any LibO extension? Any AUR packages you haven't rebuilt since libstdc++ change?

Offline

#12 2015-12-30 18:19:33

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,045
Website

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

@Paul: Yup - but only on the one on which LO fails.  I don't recall if I thought ucode didn't apply for the older machine (where LO works) of if I just never got around to installing it.  But I'm pretty sure the presence of the ucode update would not cause a problem like this.

@Andy, thanks - no extensions, and a fresh user has the same issue.  I double checked that all AUR packages had been rebuilt, and they have.  None of them have any relation to LO anyways.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#13 2015-12-30 18:21:43

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 611

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

AndyRTR wrote:

Do you use any LibO extension?

Asked that already! See #4 and #5

Offline

#14 2015-12-30 18:34:37

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,045
Website

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

OK - this is really silly.  I haven't finished building LO from abs yet, but simply installing all the build deps (there are a crap ton) made the already installed LO work.

This smells like a packaging bug.  Something that is listed only as a makedepends is actually needed.

It looks like gtk2 is a hard dependency.  With gtk2 installed, LO runs fine, without gtk2 (even with all the gtk2 deps) LO crashes.  Is this a packaging bug, or am I missing something else?  Curently gtk2 is listed as Optional.  I don't keep up on much of this, but I thought I heard that LO no longer depends on external toolkits.

EDIT: `SAL_USE_VCLPLUGIN=gen libreoffice` works without gtk2 installed.  It seems in the absence of SAL_USE_VCLPLUGIN LO now defaults to gtk.

Andy, should I open a bug for this?  It seems without SAL_USE_VCLPLUGIN explicitly set in /etc/profile.d files LO defaults to gtk2, and as gtk2 is not a dependency, users could instal a seemingly broken LO.  I think the profile.d files should explicitly set SAL_USE_VCLPLUGIN=gen - or at very least this needs a mention in the wiki that the default settings will fail without gtk2 installed.

EDIT: scratch the above.  Setting SAL_USE_VCLPLUGIN=gen allows loffice to open the initial screen, but it cannot open any documents.  Attempting to open any document leads to a crash without any error message.  Passing a document as a parameter also leads to a crash with no error message.  It seems gtk2 is now a hard dependency regardles of the SAL_USE_VCLPLUGIN setting.  I also get these same results with libreoffice-still.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#15 2015-12-31 10:24:12

kvtb
Member
Registered: 2014-01-11
Posts: 29

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

Trilby, just had the same issue.
Explicitly installing gtk2 "solved" the issue
"solved" betweeen " " because in my opinion it should just work without having legacy gtk2 installed, by just settting
SAL_USE_VCLPLUGIN=gen

Last edited by kvtb (2015-12-31 10:26:46)

Offline

#16 2016-01-11 16:23:34

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 611

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

Trilby - is this sorted by installing gtk2? If so please remember to prepend "[SOLVED]" to your first post.
(I've always wanted to ask that of a moderator ;-) )

Offline

#17 2016-01-11 16:26:15

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,045
Website

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

Installing gtk2 is a workaround.  Is libreoffice *not* supposed to work in the absence of one of the major toolkits?

I do see the gtk2 optdep now lists gtk2 as needed for generic vcl - I don't believe that was indicated before, and as I understand it it should not be required for the generic vcl.

EDIT: worse yet, I also installed kdelibs just for the heck of it and tried to run libreoffice with `SAL_USE_VCLPLUGIN=kde4 loffice`  That also fails unless gtk2 is installed.  So at present it seems gtk2 is a hard dependency.  So no, this is not solved.

After some checking, the libreoffice website does indicate that gtk2 is a dependency: https://www.libreoffice.org/get-help/sy … nts/#Linux  This page indicates that you must have gtk2 (or higher) and on top of that you can either use gnome or kde.

It seems Andreas opened a bug report for this - so I just added this packaging comment there.  So I suppose for forum purposes this can be solved as it is properly taken up elsewhere.

Bug report: https://bugs.archlinux.org/task/46436


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#18 2016-01-11 16:53:50

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 611

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

Trilby wrote:

Installing gtk2 is a workaround.  Is libreoffice *not* supposed to work in the absence of one of the major toolkits?

After some checking, the libreoffice website does indicate that gtk2 is a dependency: https://www.libreoffice.org/get-help/sy … nts/#Linux  This page indicates that you must have gtk2 (or higher) and on top of that you can either use gnome or kde.

I think you've answered your own question there with the details from the libreoffice website. I too had noticed that gtk2 is an optdep, but it really needs to be changed to a hard dependency.

Offline

#19 2016-08-17 08:39:55

osamabinomar
Member
Registered: 2016-05-06
Posts: 4

Re: [SOLVED] Libreoffice fails to open: com::sun::uno::DeploymentException

Yesterday I face the same problem and then I installed the gtk2, as solution suggested by this post but the problem persist then I installed **gtk3** and it was resolved. Maybe the newer libreoffice use **gtk3** as hard dependancy not gtk2. I'm posting this if someone else encountered this problem in future he might be able to resolve it by installing gtk3.

Offline

Board footer

Powered by FluxBB