You are not logged in.

#1 2015-12-30 09:11:20

davy_crockett
Member
Registered: 2015-10-21
Posts: 73

[SOLVED] Steam doesn't work - possible graphics driver issue

Hi there,

I tried running steam for the first time on KDE and I accepted the EULA and then it appeared to be trying to load and then disappeared from my application bar and did nothing. I killed the process by issuing killall steam in the terminal. I then tried running steam from the terminal. I received this response:

frodo@archlaptop /dev/mapper % steam
/home/frodo/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
/home/frodo/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
Running Steam on arch  64-bit
/home/frodo/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: radeonsi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

The output of lspci is this:

frodo@archlaptop /dev/mapper % lspci -k | grep -A 2 -E "(VGA|3D)"                                                                                                            :(
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Heathrow XT [Radeon HD 7870M]
        Subsystem: Dell FirePro M6000
        Kernel driver in use: radeon

I installed the xf86-video-ati driver to get my graphics working when I initially installed arch linux, along with mesa-libgl and lib32-mesa-libgl. What can I do to resolve this and get it working?

Last edited by davy_crockett (2016-01-23 07:35:41)

Offline

#2 2015-12-30 10:11:57

ooo
Member
Registered: 2013-04-10
Posts: 1,607

Re: [SOLVED] Steam doesn't work - possible graphics driver issue

Offline

#3 2015-12-31 00:40:21

davy_crockett
Member
Registered: 2015-10-21
Posts: 73

Re: [SOLVED] Steam doesn't work - possible graphics driver issue

I found this command on another thread:

find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" \) -print -delete

That seemed to do the trick

Offline

#4 2016-04-11 07:32:24

iago
Member
Registered: 2016-04-11
Posts: 2

Re: [SOLVED] Steam doesn't work - possible graphics driver issue

davy_crockett wrote:

I found this command on another thread:

find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" \) -print -delete

That seemed to do the trick

Worked for me too..

Offline

#5 2016-04-11 08:46:18

x33a
Forum Fellow
Registered: 2009-08-15
Posts: 4,585
Website

Re: [SOLVED] Steam doesn't work - possible graphics driver issue

Offline

Board footer

Powered by FluxBB