You are not logged in.

#1 2004-02-19 22:14:40

cbozic
Member
From: Morgantown, WV, USA
Registered: 2004-01-31
Posts: 77

Pacman for older versions

Is there any way to use pacman to get an older release of a package?

Thanks,
Chris

Offline

#2 2004-02-19 22:40:17

farphel
Forum Fellow
From: New Hampshire - USA
Registered: 2003-09-18
Posts: 250
Website

Re: Pacman for older versions

No.  However, you have two options that I can think of off the top of my head.  One would be to use abs.  After syncing your abs tree, you could modify the PKGBUILD(s) to 'downgrade'.  Your other option would be to dig through CVS and find the outdated PKGBUILD that supports the version of software you want.


Follow the link below, sign up, and accept one promotional offer.  If I can get five suckers (err... friends) to do this, I'll get a free iPod.  Then you too can try to get a free iPod. Thanks! http://www.freeiPods.com/?r=11363142

Offline

#3 2004-02-20 09:21:44

Bobonov
Member
From: Roma - Italy
Registered: 2003-05-07
Posts: 295

Re: Pacman for older versions

Just to know, why?

Downgrade pacman can lead to serious problem in package managing, many improvment and bugfix where done in the last months.
And especially which version are you looking for?

Offline

#4 2004-02-20 18:11:26

cbozic
Member
From: Morgantown, WV, USA
Registered: 2004-01-31
Posts: 77

Re: Pacman for older versions

Thanks for the advice farphel and Bobonov.

The reason I'm asking this is because I need to compile some software (currently not in a pacman repository) that requires an older version of a lib I got through pacman.   So it's not an older version of pacman I'm looking for.

Thanks again,
Chris

Offline

#5 2004-02-20 18:20:10

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Pacman for older versions

if you could tell us what you are trying to compile and what library we may be able to take a look at solutions to help you out without downgrading the lib (and potentially breaking packages that may use the lib)


AKA uknowme

I am not your friend

Offline

#6 2004-02-22 21:42:26

cbozic
Member
From: Morgantown, WV, USA
Registered: 2004-01-31
Posts: 77

Re: Pacman for older versions

I'm trying to compile Ardour and I got some information from the Ardour mailing list that suggested I try compiling with an older version of libraptor.  You can check out the thread archives to get some more information here:

http://listserver.dreamhost.com/piperma … 00016.html

Thanks,
Chris

Offline

#7 2004-02-24 16:01:41

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: Pacman for older versions

cbozic wrote:

I'm trying to compile Ardour and I got some information from the Ardour mailing list that suggested I try compiling with an older version of libraptor.  You can check out the thread archives to get some more information here:

http://listserver.dreamhost.com/piperma … 00016.html

Thanks,
Chris

Hi chris.

I just tried to rebuild ardour in the latest version:

# Contributor: Tobias Kieslich <tobias@justdreams.de>

pkgname=ardour
pkgver=0.9beta10.2
pkgrel=1
pkgdesc="Ardour is a multichannel hard disk recorder and digital audio workstation"
depends=('liblrdf' 'libsamplerate' 'jack-audio-connection-kit' 'gtk' 'libart-lgpl')
source=(http://ardour.org/releases/$pkgname-$pkgver.tar.bz2)
md5sums=('573026e8a085f40b7725b86ab7fb4fae')

build() {
    cd $startdir/src/$pkgname-$pkgver
    ./configure --prefix=/usr --sysconfdir=/etc
    make || return 1
    make DESTDIR=$startdir/pkg install
}

I got it build with that latest sources. I think they changed ./configure or
the Makefiles. Sometimes it is a good idea to make symlinks from newer
versions of libs to older ones to make things work. It's no guarantee, though.

bye neri

Offline

#8 2004-02-24 21:29:48

cbozic
Member
From: Morgantown, WV, USA
Registered: 2004-01-31
Posts: 77

Re: Pacman for older versions

Thanks for the PKGBUILD file but I still get the same error I posted on the ardour mailing list mentioned above.  Here is the error I get:

/usr/bin/ld: warning: libraptor.so.0, needed by /usr/lib/liblrdf.so, not found (try using -rpath or -rpath-link)
/usr/lib/liblrdf.so: undefined reference to `raptor_print_locator'
/usr/lib/liblrdf.so: undefined reference to `raptor_free'
/usr/lib/liblrdf.so: undefined reference to `raptor_init'
/usr/lib/liblrdf.so: undefined reference to `raptor_set_statement_handler'
/usr/lib/liblrdf.so: undefined reference to `raptor_set_error_handler'
/usr/lib/liblrdf.so: undefined reference to `raptor_parse_file'
/usr/lib/liblrdf.so: undefined reference to `raptor_finish'
/usr/lib/liblrdf.so: undefined reference to `raptor_new_uri'
/usr/lib/liblrdf.so: undefined reference to `raptor_set_warning_handler'
/usr/lib/liblrdf.so: undefined reference to `raptor_free_uri'
/usr/lib/liblrdf.so: undefined reference to `raptor_new_parser'
collect2: ld returned 1 exit status
make[3]: *** [ardour] Error 1
make[3]: Leaving directory `/var/abs/local/ardour/src/ardour-0.9beta10.2/gtk_ardour'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/abs/local/ardour/src/ardour-0.9beta10.2/gtk_ardour'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/var/abs/local/ardour/src/ardour-0.9beta10.2/gtk_ardour'
make: *** [all-recursive] Error 1
==> ERROR: Build Failed.  Aborting...


Did you have to "downgrade" raptor the way that was suggested to me in the mailing list?   

Thanks,
Chris

Offline

#9 2004-02-25 12:57:23

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: Pacman for older versions

Hi Chris,

miracle resolved, I had a selfcompiled liblrdf on my box which has correct
links. I will inform the maintainer that he shall rebuild liblrdf. Usually it will
be available very soon then. Thanks for pointing that out.
For the time being: I uploaded my ardour to incoming replacing the old
version. Use it carful since it is rebuild against the new liblrdf. I know that
damn thing takes forever to compile.
Here is a liblrdf PKGBUILD if you like to build your own packages:

# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
pkgname=liblrdf
pkgver=0.3.5
pkgrel=1
pkgdesc="liblrdf allows categorizing LADSPA plugins"
url="http://plugin.org.uk/releases/lrdf/"
depends=('raptor' 'ladspa')
source=(http://plugin.org.uk/releases/lrdf/$pkgname-$pkgver.tar.gz)

build() {
  cd $startdir/src/$pkgname-$pkgver
  ./configure --prefix=/usr
  make || return 1
  make prefix=$startdir/pkg/usr install
}

bye neri

Offline

#10 2004-02-25 14:05:09

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,366
Website

Re: Pacman for older versions

TUR/staging:

liblrdf updated
0.3.1-1 -> 0.3.5-s1


The impossible missions are the only ones which succeed.

Offline

#11 2004-03-03 04:24:37

cbozic
Member
From: Morgantown, WV, USA
Registered: 2004-01-31
Posts: 77

Re: Pacman for older versions

I just wanted to thank everybody for all the help!  Using the information provided here, I got everything compiled and running.  I can't believe how helpful this arch community is!

Thanks,
Chris

Offline

Board footer

Powered by FluxBB