You are not logged in.

#1 2016-01-12 19:06:51

raul_l
Member
From: Durham, NC
Registered: 2014-11-04
Posts: 41

KDE won't start with Nouveau

How to properly install the Nvidia open-source driver Nouveau? I have a GeForce 970M. I installed xf86-video-nouveau and mesa-libgl and after booting I'm stuck at

[  OK  ] Started Simple Desktop Display Manager.
     [16.094981]  nouveau 000:01:00.0: gr: failed to load fecs_inst
     [16.094983]  nouveau 000:01:00.0: DRM: Pointer to flat panel table invalid
[  OK  ] Started Network Manager.
[  OK  ] Reahed target Network.
[  OK  ] Started Login Service.
[  OK  ] Reached target Multi-User System.
[  OK  ] Reached target Graphical Interface.

With the proprietary driver I can start KDE (or SDDM, not sure what's correct here) but have other problems (lots of seg faults, can't do anything in System Settings, etc.).


Raul Laasner
Duke University

Offline

#2 2016-01-14 15:33:29

Daniel-HD
Member
Registered: 2015-11-27
Posts: 11

Re: KDE won't start with Nouveau

concerning nouveau, you could try to downgrade qt5-base to version 5.5.1-7; see https://bugs.archlinux.org/task/47728

Offline

#3 2016-01-14 16:00:22

raul_l
Member
From: Durham, NC
Registered: 2014-11-04
Posts: 41

Re: KDE won't start with Nouveau

Thanks, although the symptoms in that link appear to be different. In any case, things seem to be stable now with the proprietary driver and mesa-libgl (not nvidia-libgl).


Raul Laasner
Duke University

Offline

#4 2016-01-14 16:36:16

tom.ty89
Member
Registered: 2012-11-15
Posts: 608

Re: KDE won't start with Nouveau

Pfft. Good luck for using mesa-libgl with nvidia and nvidia-utils.

Offline

#5 2016-01-14 16:45:29

raul_l
Member
From: Durham, NC
Registered: 2014-11-04
Posts: 41

Re: KDE won't start with Nouveau

That's the only combination that works for me. nvidia-ligbl introduces some sort of race condition that leads to constant seg faulting, usually after closing applications. Sorry, I don't know the technical details to describe it any better.  (It's certainly related to multiple threads. There is some conflict between nvidia-libgl and glibc.)

Last edited by raul_l (2016-01-14 16:51:50)


Raul Laasner
Duke University

Offline

#6 2016-01-14 17:02:15

tom.ty89
Member
Registered: 2012-11-15
Posts: 608

Re: KDE won't start with Nouveau

Skylake thing I guess. Just remember this is NOT a combination supposed to work with most things. Consider it as a VERY BAD/LIMITED workaround.

Offline

#7 2016-01-14 17:04:57

raul_l
Member
From: Durham, NC
Registered: 2014-11-04
Posts: 41

Re: KDE won't start with Nouveau

Ok, thanks for cautioning me. I'll keep looking for solutions but for now there haven't been any noticeable problems.


Raul Laasner
Duke University

Offline

#8 2016-01-14 19:07:00

raul_l
Member
From: Durham, NC
Registered: 2014-11-04
Posts: 41

Re: KDE won't start with Nouveau

This issue is covered here. In short, the solution is to recompile glibc without lock elision or try the beta (see the last item in the list) version of the next Nvidia driver.


Raul Laasner
Duke University

Offline

Board footer

Powered by FluxBB