You are not logged in.

#1 2007-01-17 01:10:09

vladuz976
Member
From: Venice, CA
Registered: 2005-11-04
Posts: 108

lpr: Error - no default destination available

Hi,

I set up CUPS via the web interface and I can print from graphical apps. From command line i cannot use lpr and lpq. I get

lpr: Error - no default destination available

Please, can somebody tell me where to set the default destination. I've searched the wiki and forums but haven't found anything. This maybe a silly question for most users, but please just point me to where I can find the answer. I'll be more than happy to rtfm if I only knew where start reading.

Thanks.

Offline

#2 2007-01-17 05:38:50

ploxiln
Member
Registered: 2006-10-27
Posts: 50

Re: lpr: Error - no default destination available

Interestingly enough, I had a similar problem just today. I was trying to share a printer from one linux system to the other, and once one edits /etc/cups/client.conf to include the hostname of the system sharing the printer, the printer should show up when one uses the lpq command... which just wasn't happening, even if I opened my print server up to the world (temporarily). It gave me the exact same complaint it gave you. It seemed to just sort of fix itself after a while though (an hour after I gave up?), now the printer shows up when I issue the lpq command.

I set the same thing up months ago and didn't experience a delay in operation... I wonder if it kicks in after a while for you too?

Maybe try setting that printer as the default with the cups web interface or somehow else?

So, in conclusion, I don't have an explanation for you smile

Offline

#3 2007-01-18 12:10:24

Raniz
Member
From: Lund, Sweden
Registered: 2007-01-11
Posts: 14

Re: lpr: Error - no default destination available

go to http://localhost:631 and look for your printer. You should be able to set it to default there.

Offline

#4 2016-01-16 06:21:19

jwbales
Member
Registered: 2016-01-16
Posts: 1

Re: lpr: Error - no default destination available

To find the available printers, at a terminal type

lpstat -p -d

Then to pick one as the default lpd printer, type at the terminal

lpoptions -d <printer>

You can copy and paste the <printer> from the list given by lpstat -p -d

Then type

lpq

to see if the printer you selected is now the default.

Offline

#5 2016-01-16 07:06:38

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,336
Website

Re: lpr: Error - no default destination available

Hi jwbales,

thanks for a helpful first post. But seeing that the topic you replied is almost a decade old, it is unlikely to be helpful for the ones who started the thread.

Closing.

Offline

Board footer

Powered by FluxBB