You are not logged in.

#26 2016-01-15 10:21:46

Forum Moderator
Registered: 2012-10-16
Posts: 3,009

Re: [SOLVED] SPDIF output Presonus Audiobox VSL1818

Recommended way is adding them at the end of your /etc/pulse/  without the preceeding pacmd command. Like so:

load-module module-remap-sink sink_name="vsl_custom" master="alsa_output.usb-PreSonus_AudioBox_1818_VSL_2209-00.multichannel-output" channels="2" channel_map="front-left,front-right" master_channel_map="aux0,aux1"
set-default-sink vsl_custom

That way they will be loaded whenever pulseaudio starts, so you don't have to special case it should you ever decide to switch WMs.

Last edited by V1del (2016-01-15 10:23:05)


#27 2016-01-15 21:49:30

Registered: 2012-11-15
Posts: 896

Re: [SOLVED] SPDIF output Presonus Audiobox VSL1818

moonlies wrote:

Awesome, you did it!
The first line worked until i rebooted. Now i get "module load failed".
Then i tried the second line and after choosing the remapped stream in pavucontrol it works too.
The second line does still work after rebooting.
Is there a recommended way to make this default or can i just put the 2 lines into the autorun for my wm?

The first line will not work if your device is busy (e.g. being grabbed by the sink created by the profile), so you can try turn off the profile or maybe some other further tinkering in to make sure the original sink won't be enabled/created.
The second one will not suffer from this issue (but instead it rely on its "master"). The extra layer of routing might introduce some latency/side effect, but if you don't see any issue, well, then you can use it.
And yeah `pacmd load-module` is volatile, and V1del has given you the solution.


#28 2016-01-18 21:21:22

Registered: 2016-01-09
Posts: 26

Re: [SOLVED] SPDIF output Presonus Audiobox VSL1818

It works now, i had to disable autoconnect to jack in the to make it work with the first line.
Thank you so much for your time!

Last edited by moonlies (2016-01-18 21:23:42)


Board footer

Powered by FluxBB