You are not logged in.

#1 2016-01-18 05:42:02

eduardomezencio
Member
Registered: 2015-01-29
Posts: 7

[solved] mime type inode/directory opening with wrong application

After installing audacious, the system started using it instead of nautilus to open directories. Then I used xdg-mime to change that. Now when I type

xdg-mime query default inode/directory

it returns

nautilus.desktop

But still, if I use

xdg-open some_directory

it's still opening with audacious, and that's killing me. It also uses audacious when I tell to open a torrent's folder from transmission and when I insert my external hd.

What's happening??

Last edited by eduardomezencio (2016-01-18 23:14:38)

Offline

#2 2016-01-18 15:40:57

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,280

Re: [solved] mime type inode/directory opening with wrong application

You might want to look into the settings provided by your desktop environment (DE) as xdg-open will defer to DE specific tools if it detects a "supported" DE is running.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#3 2016-01-18 16:47:58

eduardomezencio
Member
Registered: 2015-01-29
Posts: 7

Re: [solved] mime type inode/directory opening with wrong application

In Gnome, my DE, I know of 2 ways to deal with this. One is to open properties of a file inside nautilus and looking at the "Open with" tab. But folders don't show that tab. The other way is in the System Settings, inside Details, there's a Default Applications tab, but it includes only a few types, directories not included. So, unless there is a very obscure location for this setting, I don't know if it can really be related to the DE. Any tip on where to search is welcome.

Offline

#4 2016-01-18 17:22:45

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,280

Re: [solved] mime type inode/directory opening with wrong application

Instead of xdg-mime try using gvfs-mime. As far as I can see when the DE is gnome xdg-open calls gvfs-* tools so that might do the trick. I can't be of much help with gnome as I don't use that DE.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#5 2016-01-18 23:07:59

eduardomezencio
Member
Registered: 2015-01-29
Posts: 7

Re: [solved] mime type inode/directory opening with wrong application

Thank you so much!!!! Problem solved!

Offline

#6 2016-01-18 23:13:17

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,280

Re: [solved] mime type inode/directory opening with wrong application

eduardomezencio wrote:

Thank you so much!!!! Problem solved!

Please edit you first post and add [Solved] to the title. This will help others with the same problem in finding a thread with a solution.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

Board footer

Powered by FluxBB