You are not logged in.

#1 2016-01-16 03:28:15

TheSaint
Member
From: my computer
Registered: 2007-08-19
Posts: 1,380

[Solved] Nvidia GTX670 - I cannot switch back to VT once X started

Hello,

There was a time that, even Xorg started, I was able to go back to the virtual terminal by press ALT+CTRL+Fn. After a long waiting time I thought  "Finally I got it solved". Unfortunately, didn't last. I think that since April 2014 had changed, as this mail said. My supposition come from here.
Then I've checked

$ zgrep CONFIG_X86_SYSFB /proc/config.gz
# CONFIG_X86_SYSFB is not set

I think there could be a PKGBUILD, but I'd like to be helped for the necessary patch. From my skill on compiling kernel I think I'll stumble in several kernel panics.

UPDATE
I'm trying to use the PKGBUILD, but I'm facing

 makepkg -s
==> ERROR: install file (linux.install) does not exist or is not a regular file.
==> ERROR: install file (linux.install) does not exist or is not a regular file.
==> ERROR: install file (linux.install) does not exist or is not a regular file

UPDATE
I discovered that i missed to use ABS and its database
Now is compiling......
But problems with signature, which i skipped wink

UPDATE
I compiled the kernel with the enable option, but i makes worst than before. The screen stays blank until Xorg starts up. Also switching back to VT is blank.

$ zgrep CONFIG_X86_SYSFB /proc/config.gz
CONFIG_X86_SYSFB=y

I was afraid about compiling a kernel, but I done it  smile
So, the problem still there. sad

LAST UPDATE

The latest system upgrade solved the issue

$ nvidia-xconfig -v

nvidia-xconfig:  version 361.28  (buildmeister@swio-display-x64-rhel04-04)  Wed Feb
3 16:27:53 PST 2016
$ uname -r
4.4.1-2-ARCH

Last edited by TheSaint (2016-02-13 05:28:29)


do it good first, it will be faster than do it twice the saint wink

Offline

#2 2016-01-16 12:41:54

blablo
Member
Registered: 2011-06-02
Posts: 18

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

What bootloader do you use? MB with UEFI?

Offline

#3 2016-01-16 14:11:19

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,162
Website

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

Which drivers are you using? I now use an nVidia GTX 660 Ti with nvidia-dkms and it works fine here.


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#4 2016-01-16 18:51:22

TheSaint
Member
From: my computer
Registered: 2007-08-19
Posts: 1,380

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

I reverted to the previous kernel.
The booting starts from BIOS via efistub, some time i use gummiboot, because I've an emergency partition (for special cases). Though, the screen is normal before starting th X server.
Driver is nvidia-dkms. Mine is

$ lspci -vnn |grep VGA
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK104M [GeForce GTX 670MX] [10de:11a1] (rev a1) (prog-if 00 [VGA controller]

I just forgot which kernel it was working fine. I guess within mid 2013 and the above mentioned date.
I also put nvidia module in the mkinitcpio.conf, to load. No effects.
I filed the bug report and emailed to nvidia. Whom may interests is at this place


do it good first, it will be faster than do it twice the saint wink

Offline

#5 2016-01-16 19:01:37

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 672

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

I have a GTX670 (NV proprietary driver), and all VTs are available to me.

I'm on a BIOS system (not UEFI) which may be the difference. Latest kernel (from testing) and I haven't encountered this at all. Whilst I can't offer informative help, you almost certainly have a config error somewhere.


[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Nvidia GTX 670 2Gb, AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked) 8GB RAM
Linux user #545703

Offline

#6 2016-01-16 21:24:17

TheSaint
Member
From: my computer
Registered: 2007-08-19
Posts: 1,380

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

My best guess it is about the kernel parameters. But I don't know which.
Perhaps I should have to try booting from a live distro. But, whether it'll work, where's clue ?


do it good first, it will be faster than do it twice the saint wink

Offline

#7 2016-01-16 21:52:39

blablo
Member
Registered: 2011-06-02
Posts: 18

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

Did you try GFXMODE?
Please see (grub):
https://wiki.archlinux.org/index.php/GR … resolution

Last edited by blablo (2016-01-16 21:57:12)

Offline

#8 2016-01-17 02:25:45

TheSaint
Member
From: my computer
Registered: 2007-08-19
Posts: 1,380

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

@blablo
I use direct boot from BIOS. Anyways I set to compile the nvidia into initrd. I'll try to boot via gummiboot and set the command line as you mention.
I read this document, but I doubt it's the right choice.
@ Roken,
As far as I remember, I always started this laptop in UEFI mode, because I bought it with Win8 pre-installed. But for a certain period of time it was possible to use the VTs.
Can you, please, post me your

$ cat /proc/cmdline

UPDATE
I started old setup (an USB disk) with kernel 3.17.2-1-ARCH and X.Org X Server 1.16.2. The driver loaded is nouveau. This condition allows me to see VTs. Sorry friends but I'd deserve better, I think.

Last edited by TheSaint (2016-01-17 04:01:57)


do it good first, it will be faster than do it twice the saint wink

Offline

#9 2016-01-17 03:59:08

Ropid
Member
Registered: 2015-03-09
Posts: 176

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

I have a GTX 680 and use the nvidia drivers. The board uses UEFI to boot. The UEFI BIOS CSM thingy is enabled because my graphics card has no UEFI support. I do absolutely nothing with regards to graphics in the kernel command line and things just work so there is nothing interesting to see in "cat /proc/cmdline".

I use the "nvidia-full-beta-all" AUR package which is currently version 368.18 of the drivers. That package compiles a module for every installed kernel when it is built.

Last edited by Ropid (2016-01-17 03:59:48)

Offline

#10 2016-01-17 04:06:53

TheSaint
Member
From: my computer
Registered: 2007-08-19
Posts: 1,380

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

That's working I have no doubts. Just sometimes I'd like to exit on a TTY to see output, that it could be set to be sent there.
UPDATE

Also this thread describes the same simptoms.

Last edited by TheSaint (2016-01-17 05:47:03)


do it good first, it will be faster than do it twice the saint wink

Offline

#11 2016-01-17 09:16:00

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 672

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

Not sure it will help, but:

BOOT_IMAGE=/vmlinuz-linux root=UUID=xxxxx-xxxx-xxxxxx-xxxxxxxxxx ro nomodeset vga=795 discard


[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Nvidia GTX 670 2Gb, AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked) 8GB RAM
Linux user #545703

Offline

#12 2016-01-17 09:17:31

tom.ty89
Member
Registered: 2012-11-15
Posts: 608

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

Hmm what's that:

discard

Last edited by tom.ty89 (2016-01-17 09:17:42)

Offline

#13 2016-01-17 18:56:32

TheSaint
Member
From: my computer
Registered: 2007-08-19
Posts: 1,380

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

ro yikes yikes . It's very long that's deprecated.

Last edited by TheSaint (2016-01-17 19:07:34)


do it good first, it will be faster than do it twice the saint wink

Offline

#14 2016-01-17 19:12:04

tom.ty89
Member
Registered: 2012-11-15
Posts: 608

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

TheSaint wrote:

ro yikes yikes . It's very long that's deprecated.

No it's not:
https://www.kernel.org/doc/Documentatio … meters.txt

ro		[KNL] Mount root device read-only on boot

Offline

#15 2016-01-17 19:40:11

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 3,859
Website

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

Just to clarify: the kernel image is mounted rw in Arch to allow fsck to be run before mounting the filesystem.

See https://projects.archlinux.org/mkinitcp … 449b3e543c


_0_
__0
000

Offline

#16 2016-01-17 20:22:25

TheSaint
Member
From: my computer
Registered: 2007-08-19
Posts: 1,380

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

OK, clear now. I'm trying to collect some more informations, but my knowledge leads nowhere.
Any further input well appreciated.


do it good first, it will be faster than do it twice the saint wink

Offline

#17 2016-01-17 22:00:28

tom.ty89
Member
Registered: 2012-11-15
Posts: 608

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

Head_on_a_Stick wrote:

Just to clarify: the kernel image is mounted rw in Arch to allow fsck to be run before mounting the filesystem.

I think that is not exactly correct. It's mainly to prevent doing fsck'ing for the root partition twice:

https://github.com/systemd/systemd/blob … ice.in#L13

systemd.unit(5) wrote:

ConditionPathIsReadWrite= is similar to ConditionPathExists= but verifies whether the underlying file system is readable and writable (i.e. not mounted read-only).

FWIW we mostly (if not always) do fsck with the filesystem unmounted. That's how the base hook init script do it as well:
https://projects.archlinux.org/mkinitcp … e/init#n45

P.S. sorry for hijacking the thread tongue

Last edited by tom.ty89 (2016-01-17 22:04:36)

Offline

#18 2016-01-17 23:17:35

TheSaint
Member
From: my computer
Registered: 2007-08-19
Posts: 1,380

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

At the least I'll gather a good audience tongue


do it good first, it will be faster than do it twice the saint wink

Offline

#19 2016-01-20 09:26:31

TheSaint
Member
From: my computer
Registered: 2007-08-19
Posts: 1,380

Re: [Solved] Nvidia GTX670 - I cannot switch back to VT once X started

UPDATE
I think I found something to chew. I'm gonna try a new kernel.


do it good first, it will be faster than do it twice the saint wink

Offline

Board footer

Powered by FluxBB