You are not logged in.

#1 2016-01-20 20:49:32

kinematik
Member
From: Seville, Spain
Registered: 2015-04-07
Posts: 5

Can not change nvidia package from nvidia-304xx to nvidia [SOLVED]

Hi, I have been enjoying my PC with Arch Linux without any issue or glitch for one year and a half. I do really love Arch and its stability.

However I had recently my first issue related to the Graphic nvidia GeForce GT630 graphic card:

quino@PCQuino-Arch [~] $ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)                                                                                                                 
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)                                                                                               
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)                                                                                               
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation Z68 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 630] (rev a1)                                       <----------------------------------------    My Nvidia Card
01:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev a1)
02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
05:00.0 USB controller: VIA Technologies, Inc. VL80x xHCI USB 3.0 Controller (rev 01)

Three weeks ago the kernel was upgraded to version 4.3, and my graphic stack failed after rebooting. I can see there is a bug reported with the same error I have:
FS#47092 - [nvidia-304xx] unknown symbol in modules for Linux 4.3 series
https://bugs.archlinux.org/task/47092?s … &closedto=

Also I realize that in the Monthly newsletter of Kaos Linux, it is announced that support had been dropped for nvidia-304xx driver in Kernel 3.3
http://kaosx.us/kaos-2016-01/

With the move to Linux 4.3.3 came the end of nvidia 304xx as the legacy Nvidia version. It no longer works with the latest kernels so it is time to move to nvidia 340xx as the legacy Nvidia option. This means systems running GeForce 6000/7000 GPUs (graphics cards from around 2004) need to switch to Nouveau.

My error is listed below, but I also realized that I had been using the wrong nvidia package: nvidia-304xx is for legacy cards (2006-08), and mine was bought in 2012. I need to change the nvidia package from nvidia-304xx, to the standar nvidia package with full support.

quino@PCQuino-Arch [~] $ sudo pacman -S nvidia
resolviendo dependencias...
buscando conflictos entre paquetes....
:: nvidia y nvidia-304xx están en conflicto. ¿Quitar nvidia-304xx? [s/N] s
:: nvidia-utils y nvidia-304xx-utils están en conflicto. ¿Quitar nvidia-304xx-utils? [s/N] s
error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
:: nvidia-304xx-libgl: necesita nvidia-304xx-utils
error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
:: nvidia-304xx-libgl: necesita nvidia-304xx-utils

Both nvidia packages seem to be in conflict and blocking any possible upgrade. I also tried uninstalling the nvidia-304xx packages, but it fails because this package seems to be very important and it has a lot of dependencies: almost all my KDE desktop environment packages depends on the existing outdated nvidia-304xx-libgl package.

Is it possible an nvidia package upgrade, or Should I make a fresh install?

Thank you in advanced

Last edited by kinematik (2016-01-25 18:15:33)

Offline

#2 2016-01-20 21:52:30

slithery
Member
Registered: 2013-12-01
Posts: 790

Re: Can not change nvidia package from nvidia-304xx to nvidia [SOLVED]

Offline

#3 2016-01-21 08:51:21

kinematik
Member
From: Seville, Spain
Registered: 2015-04-07
Posts: 5

Re: Can not change nvidia package from nvidia-304xx to nvidia [SOLVED]

Thanks, it worked!.

As always, reliable and with all the information was in the Arch Wiki.

Offline

#4 2016-01-21 09:15:57

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,394
Website

Re: Can not change nvidia package from nvidia-304xx to nvidia [SOLVED]

Please mark the thread as solved. Also, in future, whenever posting command output, always prepend LC_ALL=C to the command so that the output is in english. For example,

$ LC_ALL=C pacman -S nvidia

Offline

Board footer

Powered by FluxBB