You are not logged in.

#1 2016-01-22 15:32:21

Registered: 2016-01-21
Posts: 13

[SOLVED] Apache 2.4.18-1 error 403 with personal DocumentRoot

Hello. I installed apache by

 sudo pacman -S apache 

I want to have my Websites synchronized in Dropbox so I want to move the default DocumentRoot to


To do this I followed  This official tutorial to change the directory where I'll put the websites.

Technically what I did is:

1- Change "Require all denied" to  "Require all granted" in <Directory /> (line 234):

<Directory />
    AllowOverride none
    Require all granted

2- Change  "/srv/http" to "/home/user/Drobox/Web" (lines 249 and 250)

DocumentRoot "/home/user/Dropbox/Web"
<Directory "/home/user/Dropbox/Web">

3- Change the permissions of /home/user/Dropbox/Web:

I tried with the ones that reads in the tutorial but it didn't work. So also I tried with

sudo chmod 755 -R /home/user/Dropbox/Web/


sudo chmod 755 -R /home/user/Dropbox/Web/

Finally this is the last part of /var/log/httpd/error_log:

3)Permission denied: [client] AH00035: access to / denied (filesystem path '/home/user/Dropbox') because search permissions are missing on a component of the path


Last edited by bastri (2016-01-23 15:43:24)


#2 2016-01-22 23:10:54

Registered: 2015-02-26
Posts: 115

Re: [SOLVED] Apache 2.4.18-1 error 403 with personal DocumentRoot

Apache needs execution rights on all directories in the path, chmod -R only change the permissions for the specified directory and the directory's content.
You need to set execution permission on the parent and grandparent directories, check the current permissions first.

The change you made on line: 234 was not necessary, I'd advise reverting it back to:

<Directory />
    AllowOverride none
    Require all denied

as the wiki you referenced, most likely referred to the "Require all granted" which is in the

<Directory "/path/to/DocumentRoot">
    Require all granted



Board footer

Powered by FluxBB