You are not logged in.

#1 2016-01-22 22:15:00

zerophase
Member
Registered: 2015-09-03
Posts: 129

[SOLVED]Can't upgrade Sqlite to 3.10.2-1

I'm on sqlite 3.10.1-1. I can't upgrade any other packages because of the sqlite errors. How should I fix this?

error: failed to commit transaction (conflicting files)
sqlite: /usr/bin/showdb exists in filesystem
sqlite: /usr/bin/showjournal exists in filesystem
sqlite: /usr/bin/showstat4 exists in filesystem
sqlite: /usr/bin/showwal exists in filesystem
sqlite: /usr/bin/sqldiff exists in filesystem
sqlite: /usr/bin/sqlite3 exists in filesystem
sqlite: /usr/include/sqlite3.h exists in filesystem
sqlite: /usr/include/sqlite3ext.h exists in filesystem
sqlite: /usr/lib/libsqlite3.so exists in filesystem
sqlite: /usr/lib/libsqlite3.so.0 exists in filesystem
sqlite: /usr/lib/libsqlite3.so.0.8.6 exists in filesystem
sqlite: /usr/lib/pkgconfig/sqlite3.pc exists in filesystem
sqlite: /usr/share/licenses/sqlite/license.txt exists in filesystem
sqlite: /usr/share/man/man1/sqlite3.1.gz exists in filesystem

Last edited by zerophase (2016-01-23 01:50:10)

Offline

#2 2016-01-22 22:30:57

mpan
Member
Registered: 2012-08-01
Posts: 240
Website

Re: [SOLVED]Can't upgrade Sqlite to 3.10.2-1

What does pacman -Qo /usr/bin/showdb say?


Sometimes I’m a bit harsh on the outside — don’t get offended too easily!
PGP: ACFF9C97

Offline

#3 2016-01-22 22:32:38

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [SOLVED]Can't upgrade Sqlite to 3.10.2-1

When posting configs, code or command output, please use [ code ] tags, not [ quote ] tags https://bbs.archlinux.org/help.php#bbcode

like this

It makes the code more readable and - in case of longer listings - more convenient to scroll through.

https://bbs.archlinux.org/viewtopic.php?id=130138

Offline

#4 2016-01-22 23:34:57

zerophase
Member
Registered: 2015-09-03
Posts: 129

Re: [SOLVED]Can't upgrade Sqlite to 3.10.2-1

pacman -Qo /usr/bin/showdb shows:

error: No package owns /usr/bin/showdb

Offline

#5 2016-01-22 23:39:06

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,269

Re: [SOLVED]Can't upgrade Sqlite to 3.10.2-1

How about:

ls -l /var/lib/pacman/local/sqlite-*
cat /var/lib/pacman/local/sqlite-*/files

Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Online

#6 2016-01-23 00:35:11

zerophase
Member
Registered: 2015-09-03
Posts: 129

Re: [SOLVED]Can't upgrade Sqlite to 3.10.2-1

ls -l /var/lib/pacman/local/sqlite-* shows:

total 0
-rw-r--r-- 1 root root 0 Jan 17 11:33 desc
-rw-r--r-- 1 root root 0 Jan 17 11:33 files
-rw-r--r-- 1 root root 0 Jan 14 09:35 mtree

cat /var/lib/pacman/local/sqlite-*/files shows nothing.

Offline

#7 2016-01-23 01:16:25

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,269

Re: [SOLVED]Can't upgrade Sqlite to 3.10.2-1

From the ls output, it is apparent that all the files containing information about the sqlite package are empty (0 bytes in size). What this means is that you have a corrupted pacman database. What caused this corruption is a possible cause of concern -- it could mean that your filesystem is damaged, or your physical disk is failing, or it could mean that your system simply experienced an unexpected shutdown (e.g. power outage/hard reset). You should investigate this further, particularly if it isn't the latter explanation.

If the disk and filesystem are healthy, then the corruption may be limited to this single package. In this case you should (ideally) repair pacman's database by "reinstalling" the version you currently have installed, then try upgrading again. If you haven't cleared your pacman cache lately, you should be able to repair pacman's db with:

# pacman -U --dbonly /var/cache/pacman/pkg/sqlite-3.10.1-1-$(uname -m).pkg.tar.xz

If your cache has been cleared, you can acquire the relevant package from the ALA.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Online

#8 2016-01-23 01:46:42

zerophase
Member
Registered: 2015-09-03
Posts: 129

Re: [SOLVED]Can't upgrade Sqlite to 3.10.2-1

It's probably the latter explanation. I had to rsync -a my backup from the Arch live disk, after the computer just shut off after an update.  I had one more of sudden shut down happen since then. I think it's that the uncore on my cpu is going bad. It freezes if I don't up the voltage on it at stock settings. I ran memtest for about 2 hours, and couldn't find any memory related errors.

Offline

Board footer

Powered by FluxBB