You are not logged in.

#1 2016-01-24 23:25:54

Thorned_Rose
Member
From: Auckland, New Zealand
Registered: 2015-12-30
Posts: 18

[SOLVED] Purple-facebook/Pidgin IPv6 problem

After updating purple-facebook (now 22-1), Pidgin (2.10.12-1) no longer connects to Facebook. Normally I would post to the purple-facebook author however they have already addressed the exact problem I am having here https://github.com/jgeboski/purple-facebook/issues/33

My issue is that I cannot for the life of me work out what the IPv6 problem is. I'm not wanting to disable IPv6, just fix why purple-facebook is having issue with it.

Running

curl -6I https://b-api.facebook.com

results in

curl: (7) Failed to connect to b-api.facebook.com port 443: Connection timed out

I am using Connman. Possibly because of or related, I was having connection issues (web pages taking several minutes to load) that 'resolved' somewhat after I accidentally left the NetworkManager service going (i.e Connman and Network Manager running at the same time).
If I stop Connman and use NetworkManager instead, the same problem occurs.
Disabling the firewall (ufw) makes no difference.

I'm at a loss at the moment so any help much appreciated!

Last edited by Thorned_Rose (2016-01-25 06:59:26)

Offline

#2 2016-01-25 06:58:35

Thorned_Rose
Member
From: Auckland, New Zealand
Registered: 2015-12-30
Posts: 18

Re: [SOLVED] Purple-facebook/Pidgin IPv6 problem

Ok, well I completely disabled Connman and the applet (lxqt-connman-applet-git); enabled Network Manager plus the nm-applet; rebooted and all is now fine.
As an aside, some of the other flakey behaviour I was experiencing like slow internet speed, pages taking minutes to load and my browser (Firefox) sitting there like a dumb sh*t^ have *touch wood* resolved. I can only chalk it up to ConnMan not liking my network adapter or something else weird going on *shrug*.

Not exactly a solution if you want to continue to use ConnMan and have the same problem but NetworkManager is fine for me!

FYI: My network 'card' is a NVIDIA Corporation MCP51 Ethernet Controller (rev a3)

----
^ I would repeatedly either have to refresh a page multiple times till it loaded or hit enter multiple times in the address bar before it would actually load the page. Or sometimes have to refresh a page before links on that page would work.

Last edited by Thorned_Rose (2016-01-25 07:24:41)

Offline

Board footer

Powered by FluxBB