You are not logged in.

#1 2015-04-20 16:14:23

gentledevil
Member
Registered: 2014-09-17
Posts: 3

DRM Intel i915 errors

Hi,

After going out of blank mode, my external VGA monitor will randomly refuse to work (the primary laptop monitor works fine). This seems to be fixable only by rebooting.

Those errors show up in dmesg just after booting the computer :

[lun. avril 20 09:15:34 2015] [drm:intel_uncore_check_errors [i915]] *ERROR* Unclaimed register before interrupt
[lun. avril 20 09:15:35 2015] [drm:intel_uncore_check_errors [i915]] *ERROR* Unclaimed register before interrupt
[lun. avril 20 09:15:53 2015] [drm:intel_set_cpu_fifo_underrun_reporting [i915]] *ERROR* uncleared fifo underrun on pipe A
[lun. avril 20 09:15:53 2015] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

Those show up every few minutes or so :

[lun. avril 20 12:35:30 2015] [drm:intel_uncore_check_errors [i915]] *ERROR* Unclaimed register before interrupt
[lun. avril 20 12:38:29 2015] [drm:intel_uncore_check_errors [i915]] *ERROR* Unclaimed register before interrupt
[lun. avril 20 13:15:04 2015] [drm:intel_uncore_check_errors [i915]] *ERROR* Unclaimed register before interrupt
[lun. avril 20 13:23:17 2015] [drm:intel_uncore_check_errors [i915]] *ERROR* Unclaimed register before interrupt
[lun. avril 20 13:23:30 2015] [drm:intel_uncore_check_errors [i915]] *ERROR* Unclaimed register before interrupt
[lun. avril 20 13:23:49 2015] [drm:intel_uncore_check_errors [i915]] *ERROR* Unclaimed register before interrupt
[lun. avril 20 13:24:03 2015] [drm:intel_uncore_check_errors [i915]] *ERROR* Unclaimed register before interrupt
[lun. avril 20 13:57:58 2015] [drm:intel_uncore_check_errors [i915]] *ERROR* Unclaimed register before interrupt
[lun. avril 20 13:58:11 2015] [drm:intel_uncore_check_errors [i915]] *ERROR* Unclaimed register before interrupt

When coming out of blank mode, those show up :

[lun. avril 20 14:16:06 2015] [drm:intel_dp_start_link_train [i915]] *ERROR* failed to enable link training
[lun. avril 20 14:16:06 2015] [drm:intel_dp_complete_link_train [i915]] *ERROR* failed to start channel equalization
[lun. avril 20 14:16:07 2015] [drm:intel_uncore_check_errors [i915]] *ERROR* Unclaimed register before interrupt

I've already changed the acceleration method to UXA, without results (although I believe the problem show up less frequently but I'm unsure).

Any idea ?

Thanks in advance

Offline

#2 2015-04-21 06:19:44

mauritiusdadd
Member
From: Benevento, Italy
Registered: 2013-10-27
Posts: 776

Re: DRM Intel i915 errors

Hi gentledevil,

There is a similar thread here https://bbs.archlinux.org/viewtopic.php?id=184857 and also a couple of bug reports [1]  [2]. Unfortunately there is no solution yet.

gentledevil wrote:
[lun. avril 20 12:35:30 2015] [drm:intel_uncore_check_errors [i915]] *ERROR* Unclaimed register before interrupt

Also, searching the kernel bug tracker for the error above leads to the the following report that may be related https://bugzilla.kernel.org/show_bug.cgi?id=90951


registered linux user #588260github

-- When you have eliminated the impossible, whatever remains, however improbable, must be the truth -- Spock | Sherlock Holmes

Offline

#3 2015-04-21 11:40:32

gentledevil
Member
Registered: 2014-09-17
Posts: 3

Re: DRM Intel i915 errors

Thanks for the answer.

Yeah I noticed others have similar problems, but none of them seem exactly identical (some have the problem only at startup, others are able to recover from it with xrand or only have X break but are still able to get a tty...). There is at least one bug (https://bugs.freedesktop.org/show_bug.cgi?id=84038) that seems similar that has been marked as solved... Seems to be a mess.

Anyway I stumbled upon this https://lists.debian.org/debian-kernel/ … 00343.html where I found a workaround to avoid rebooting (just put the laptop into sleep... the screen resurrect at wake up, although I also have to reload gnome-shell).

Offline

#4 2015-05-04 05:42:42

lilydjwg
Member
Registered: 2010-06-20
Posts: 47

Re: DRM Intel i915 errors

gentledevil wrote:

Anyway I stumbled upon this https://lists.debian.org/debian-kernel/ … 00343.html where I found a workaround to avoid rebooting (just put the laptop into sleep... the screen resurrect at wake up, although I also have to reload gnome-shell).

Thank you! I get this with my new X250 too, the workaround (putting it into sleep) works for me, without restarting anything :-)

Offline

#5 2015-06-10 16:06:38

bendavis78
Member
Registered: 2014-06-21
Posts: 38

Re: DRM Intel i915 errors

I found that my screen sometimes blanks out when I alt-tab between windows, but will automatically come back after a second or two. When it happens, my kernel log shows this error:

[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

It's only mildly annoying, but is there a fix for it?

Offline

#6 2016-01-25 09:09:38

pethead
Member
From: RU
Registered: 2015-02-25
Posts: 32

Re: DRM Intel i915 errors

bendavis78 wrote:

I found that my screen sometimes blanks out when I alt-tab between windows, but will automatically come back after a second or two. When it happens, my kernel log shows this error:

[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

It's only mildly annoying, but is there a fix for it?

/etc/X11/xorg.conf.d/20-intel.conf :
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "AccelMethod" "uxa"
#Option "AccelMethod" "sna"
EndSection


This Must Be The Place I Waited Years To Leave

Offline

Board footer

Powered by FluxBB